Message ID | 20220305133823.158961-1-zhanglianjie@uniontech.com (mailing list archive) |
---|---|
State | Accepted |
Commit | ee3e6d69a21b50c060e5c94cbe25668bf9d0cbab |
Headers | show |
Series | drivers/xen: use helper macro __ATTR_RW | expand |
On Sat, Mar 05, 2022 at 11:33:58PM +0800, zhanglianjie wrote: > Hi, > > 在 2022/3/5 21:55, Greg Kroah-Hartman 写道: > > On Sat, Mar 05, 2022 at 09:38:23PM +0800, zhanglianjie wrote: > > > Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more clear. > > > Minor readability improvement. > > > > > > Signed-off-by: zhanglianjie <zhanglianjie@uniontech.com> > > > > Is this the name you sign legal documents with? (I have to ask...) > Yes, this is my signature. > > > > > > > > diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c > > > index feb1d16252e7..fcb0792f090e 100644 > > > --- a/drivers/xen/sys-hypervisor.c > > > +++ b/drivers/xen/sys-hypervisor.c > > > @@ -22,11 +22,10 @@ > > > #endif > > > > > > #define HYPERVISOR_ATTR_RO(_name) \ > > > -static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name) > > > +static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name) > > > > Why change this line? That's not relevant to this change :( > > > There are two spaces between struct hyp_sysfs_attr and _name, by the way, > modify it. Coding style cleanups should be a separate patch, as each change should only do one logical thing. But hey, I'm not the maintainer of this file/driver, others might be more lax. good luck! greg k-h
Hi, 在 2022/3/6 03:42, Greg Kroah-Hartman 写道: > On Sat, Mar 05, 2022 at 11:33:58PM +0800, zhanglianjie wrote: >> Hi, >> >> 在 2022/3/5 21:55, Greg Kroah-Hartman 写道: >>> On Sat, Mar 05, 2022 at 09:38:23PM +0800, zhanglianjie wrote: >>>> Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more clear. >>>> Minor readability improvement. >>>> >>>> Signed-off-by: zhanglianjie <zhanglianjie@uniontech.com> >>> >>> Is this the name you sign legal documents with? (I have to ask...) >> Yes, this is my signature. >>> >>>> >>>> diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c >>>> index feb1d16252e7..fcb0792f090e 100644 >>>> --- a/drivers/xen/sys-hypervisor.c >>>> +++ b/drivers/xen/sys-hypervisor.c >>>> @@ -22,11 +22,10 @@ >>>> #endif >>>> >>>> #define HYPERVISOR_ATTR_RO(_name) \ >>>> -static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name) >>>> +static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name) >>> >>> Why change this line? That's not relevant to this change :( >>> >> There are two spaces between struct hyp_sysfs_attr and _name, by the way, >> modify it. > > Coding style cleanups should be a separate patch, as each change should > only do one logical thing. > > But hey, I'm not the maintainer of this file/driver, others might be > more lax. Thanks for the guide, I will pay attention to these in the future. > > good luck! > > greg k-h >
On 3/5/22 8:38 AM, zhanglianjie wrote: > Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more clear. > Minor readability improvement. > > Signed-off-by: zhanglianjie <zhanglianjie@uniontech.com> Reviewed-by: Boris Ostrovsky <boris.ostrovsky@oracle.com> Applied to for-linus-5.18 (with whitespace change noted in commit message)
diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c index feb1d16252e7..fcb0792f090e 100644 --- a/drivers/xen/sys-hypervisor.c +++ b/drivers/xen/sys-hypervisor.c @@ -22,11 +22,10 @@ #endif #define HYPERVISOR_ATTR_RO(_name) \ -static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name) +static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name) #define HYPERVISOR_ATTR_RW(_name) \ -static struct hyp_sysfs_attr _name##_attr = \ - __ATTR(_name, 0644, _name##_show, _name##_store) +static struct hyp_sysfs_attr _name##_attr = __ATTR_RW(_name) struct hyp_sysfs_attr { struct attribute attr;
Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more clear. Minor readability improvement. Signed-off-by: zhanglianjie <zhanglianjie@uniontech.com> -- 2.20.1