diff mbox series

mm/mremap:: Use vma_lookup() instead of find_vma()

Message ID 20220312083118.48284-1-linmiaohe@huawei.com (mailing list archive)
State New
Headers show
Series mm/mremap:: Use vma_lookup() instead of find_vma() | expand

Commit Message

Miaohe Lin March 12, 2022, 8:31 a.m. UTC
Using vma_lookup() verifies the address is contained in the found vma.
This results in easier to read the code.

Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
---
 mm/mremap.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

David Hildenbrand March 14, 2022, 1:12 p.m. UTC | #1
On 12.03.22 09:31, Miaohe Lin wrote:
> Using vma_lookup() verifies the address is contained in the found vma.
> This results in easier to read the code.
> 
> Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
> ---
>  mm/mremap.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/mm/mremap.c b/mm/mremap.c
> index 002eec83e91e..9d76da79594d 100644
> --- a/mm/mremap.c
> +++ b/mm/mremap.c
> @@ -942,8 +942,8 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
>  
>  	if (mmap_write_lock_killable(current->mm))
>  		return -EINTR;
> -	vma = find_vma(mm, addr);
> -	if (!vma || vma->vm_start > addr) {
> +	vma = vma_lookup(mm, addr);
> +	if (!vma) {
>  		ret = EFAULT;
>  		goto out;
>  	}

Reviewed-by: David Hildenbrand <david@redhat.com>
diff mbox series

Patch

diff --git a/mm/mremap.c b/mm/mremap.c
index 002eec83e91e..9d76da79594d 100644
--- a/mm/mremap.c
+++ b/mm/mremap.c
@@ -942,8 +942,8 @@  SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
 
 	if (mmap_write_lock_killable(current->mm))
 		return -EINTR;
-	vma = find_vma(mm, addr);
-	if (!vma || vma->vm_start > addr) {
+	vma = vma_lookup(mm, addr);
+	if (!vma) {
 		ret = EFAULT;
 		goto out;
 	}