Message ID | 20220519101847.87907-2-xiubli@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | ceph: wait async unlink to finish | expand |
On Thu, May 19, 2022 at 06:18:45PM +0800, Xiubo Li wrote: > Reviewed-by: Jeff Layton <jlayton@kernel.org> > Signed-off-by: Xiubo Li <xiubli@redhat.com> > --- > fs/dcache.c | 15 +++++++++++++++ > include/linux/dcache.h | 2 ++ > 2 files changed, 17 insertions(+) > > diff --git a/fs/dcache.c b/fs/dcache.c > index 93f4f5ee07bf..95a72f92a94b 100644 > --- a/fs/dcache.c > +++ b/fs/dcache.c > @@ -2262,6 +2262,21 @@ static inline bool d_same_name(const struct dentry *dentry, > name) == 0; > } > > +/** > + * d_compare - compare dentry name with case-exact name > + * @parent: parent dentry > + * @dentry: the negative dentry that was passed to the parent's lookup func > + * @name: the case-exact name to be associated with the returned dentry > + * > + * Return: 0 if names are same, or 1 > + */ > +bool d_compare(const struct dentry *parent, const struct dentry *dentry, > + const struct qstr *name) > +{ > + return !d_same_name(dentry, parent, name); What's wrong with d_same_name()? Why introduce a whole new operation and export it when you the same prototype except first and second argument moved with an even more confusing name? > +} > +EXPORT_SYMBOL(d_compare); New symbols should go with EXPORT_SYMBOL_GPL() instead. Luis
On Mon, 2022-05-23 at 10:57 -0700, Luis Chamberlain wrote: > On Thu, May 19, 2022 at 06:18:45PM +0800, Xiubo Li wrote: > > Reviewed-by: Jeff Layton <jlayton@kernel.org> > > Signed-off-by: Xiubo Li <xiubli@redhat.com> > > --- > > fs/dcache.c | 15 +++++++++++++++ > > include/linux/dcache.h | 2 ++ > > 2 files changed, 17 insertions(+) > > > > diff --git a/fs/dcache.c b/fs/dcache.c > > index 93f4f5ee07bf..95a72f92a94b 100644 > > --- a/fs/dcache.c > > +++ b/fs/dcache.c > > @@ -2262,6 +2262,21 @@ static inline bool d_same_name(const struct dentry *dentry, > > name) == 0; > > } > > > > +/** > > + * d_compare - compare dentry name with case-exact name > > + * @parent: parent dentry > > + * @dentry: the negative dentry that was passed to the parent's lookup func > > + * @name: the case-exact name to be associated with the returned dentry > > + * > > + * Return: 0 if names are same, or 1 > > + */ > > +bool d_compare(const struct dentry *parent, const struct dentry *dentry, > > + const struct qstr *name) > > +{ > > + return !d_same_name(dentry, parent, name); > > What's wrong with d_same_name()? Why introduce a whole new operation > and export it when you the same prototype except first and second > argument moved with an even more confusing name? > Agreed. That would be better. > > +} > > +EXPORT_SYMBOL(d_compare); > > New symbols should go with EXPORT_SYMBOL_GPL() instead. > > Luis In the past, Al has pushed back against that since EXPORT_SYMBOL_GPL has no clear legal meaning. He may have changed his opinion since, but I haven't heard that that was the case.
On Thu, May 19, 2022 at 06:18:45PM +0800, Xiubo Li wrote: > Reviewed-by: Jeff Layton <jlayton@kernel.org> > Signed-off-by: Xiubo Li <xiubli@redhat.com> ... empty commit message? > --- > fs/dcache.c | 15 +++++++++++++++ > include/linux/dcache.h | 2 ++ > 2 files changed, 17 insertions(+) > > diff --git a/fs/dcache.c b/fs/dcache.c > index 93f4f5ee07bf..95a72f92a94b 100644 > --- a/fs/dcache.c > +++ b/fs/dcache.c > @@ -2262,6 +2262,21 @@ static inline bool d_same_name(const struct dentry *dentry, > name) == 0; > } > > +/** > + * d_compare - compare dentry name with case-exact name > + * @parent: parent dentry > + * @dentry: the negative dentry that was passed to the parent's lookup func > + * @name: the case-exact name to be associated with the returned dentry > + * > + * Return: 0 if names are same, or 1 > + */ > +bool d_compare(const struct dentry *parent, const struct dentry *dentry, > + const struct qstr *name) > +{ > + return !d_same_name(dentry, parent, name); > +} > +EXPORT_SYMBOL(d_compare); > + > /** > * __d_lookup_rcu - search for a dentry (racy, store-free) > * @parent: parent dentry > diff --git a/include/linux/dcache.h b/include/linux/dcache.h > index f5bba51480b2..444b2230e5c3 100644 > --- a/include/linux/dcache.h > +++ b/include/linux/dcache.h > @@ -233,6 +233,8 @@ extern struct dentry * d_alloc_parallel(struct dentry *, const struct qstr *, > wait_queue_head_t *); > extern struct dentry * d_splice_alias(struct inode *, struct dentry *); > extern struct dentry * d_add_ci(struct dentry *, struct inode *, struct qstr *); > +extern bool d_compare(const struct dentry *parent, const struct dentry *dentry, > + const struct qstr *name); > extern struct dentry * d_exact_alias(struct dentry *, struct inode *); > extern struct dentry *d_find_any_alias(struct inode *inode); > extern struct dentry * d_obtain_alias(struct inode *); > -- > 2.36.0.rc1 >
On 5/24/22 4:11 AM, Matthew Wilcox wrote: > On Thu, May 19, 2022 at 06:18:45PM +0800, Xiubo Li wrote: >> Reviewed-by: Jeff Layton <jlayton@kernel.org> >> Signed-off-by: Xiubo Li <xiubli@redhat.com> > ... empty commit message? Will add it. Thanks. >> --- >> fs/dcache.c | 15 +++++++++++++++ >> include/linux/dcache.h | 2 ++ >> 2 files changed, 17 insertions(+) >> >> diff --git a/fs/dcache.c b/fs/dcache.c >> index 93f4f5ee07bf..95a72f92a94b 100644 >> --- a/fs/dcache.c >> +++ b/fs/dcache.c >> @@ -2262,6 +2262,21 @@ static inline bool d_same_name(const struct dentry *dentry, >> name) == 0; >> } >> >> +/** >> + * d_compare - compare dentry name with case-exact name >> + * @parent: parent dentry >> + * @dentry: the negative dentry that was passed to the parent's lookup func >> + * @name: the case-exact name to be associated with the returned dentry >> + * >> + * Return: 0 if names are same, or 1 >> + */ >> +bool d_compare(const struct dentry *parent, const struct dentry *dentry, >> + const struct qstr *name) >> +{ >> + return !d_same_name(dentry, parent, name); >> +} >> +EXPORT_SYMBOL(d_compare); >> + >> /** >> * __d_lookup_rcu - search for a dentry (racy, store-free) >> * @parent: parent dentry >> diff --git a/include/linux/dcache.h b/include/linux/dcache.h >> index f5bba51480b2..444b2230e5c3 100644 >> --- a/include/linux/dcache.h >> +++ b/include/linux/dcache.h >> @@ -233,6 +233,8 @@ extern struct dentry * d_alloc_parallel(struct dentry *, const struct qstr *, >> wait_queue_head_t *); >> extern struct dentry * d_splice_alias(struct inode *, struct dentry *); >> extern struct dentry * d_add_ci(struct dentry *, struct inode *, struct qstr *); >> +extern bool d_compare(const struct dentry *parent, const struct dentry *dentry, >> + const struct qstr *name); >> extern struct dentry * d_exact_alias(struct dentry *, struct inode *); >> extern struct dentry *d_find_any_alias(struct inode *inode); >> extern struct dentry * d_obtain_alias(struct inode *); >> -- >> 2.36.0.rc1 >>
On 5/24/22 1:57 AM, Luis Chamberlain wrote: > On Thu, May 19, 2022 at 06:18:45PM +0800, Xiubo Li wrote: >> Reviewed-by: Jeff Layton <jlayton@kernel.org> >> Signed-off-by: Xiubo Li <xiubli@redhat.com> >> --- >> fs/dcache.c | 15 +++++++++++++++ >> include/linux/dcache.h | 2 ++ >> 2 files changed, 17 insertions(+) >> >> diff --git a/fs/dcache.c b/fs/dcache.c >> index 93f4f5ee07bf..95a72f92a94b 100644 >> --- a/fs/dcache.c >> +++ b/fs/dcache.c >> @@ -2262,6 +2262,21 @@ static inline bool d_same_name(const struct dentry *dentry, >> name) == 0; >> } >> >> +/** >> + * d_compare - compare dentry name with case-exact name >> + * @parent: parent dentry >> + * @dentry: the negative dentry that was passed to the parent's lookup func >> + * @name: the case-exact name to be associated with the returned dentry >> + * >> + * Return: 0 if names are same, or 1 >> + */ >> +bool d_compare(const struct dentry *parent, const struct dentry *dentry, >> + const struct qstr *name) >> +{ >> + return !d_same_name(dentry, parent, name); > What's wrong with d_same_name()? Why introduce a whole new operation > and export it when you the same prototype except first and second > argument moved with an even more confusing name? Sounds resonable, will export the d_same_name instead. >> +} >> +EXPORT_SYMBOL(d_compare); > New symbols should go with EXPORT_SYMBOL_GPL() instead. Not familiar with the story about this, before I checked the Doc and didn't find any where says we must use it and just followed what recent commits did. If this is what we should use I will switch to it in the next version. Thanks -- Xiubo > > Luis >
diff --git a/fs/dcache.c b/fs/dcache.c index 93f4f5ee07bf..95a72f92a94b 100644 --- a/fs/dcache.c +++ b/fs/dcache.c @@ -2262,6 +2262,21 @@ static inline bool d_same_name(const struct dentry *dentry, name) == 0; } +/** + * d_compare - compare dentry name with case-exact name + * @parent: parent dentry + * @dentry: the negative dentry that was passed to the parent's lookup func + * @name: the case-exact name to be associated with the returned dentry + * + * Return: 0 if names are same, or 1 + */ +bool d_compare(const struct dentry *parent, const struct dentry *dentry, + const struct qstr *name) +{ + return !d_same_name(dentry, parent, name); +} +EXPORT_SYMBOL(d_compare); + /** * __d_lookup_rcu - search for a dentry (racy, store-free) * @parent: parent dentry diff --git a/include/linux/dcache.h b/include/linux/dcache.h index f5bba51480b2..444b2230e5c3 100644 --- a/include/linux/dcache.h +++ b/include/linux/dcache.h @@ -233,6 +233,8 @@ extern struct dentry * d_alloc_parallel(struct dentry *, const struct qstr *, wait_queue_head_t *); extern struct dentry * d_splice_alias(struct inode *, struct dentry *); extern struct dentry * d_add_ci(struct dentry *, struct inode *, struct qstr *); +extern bool d_compare(const struct dentry *parent, const struct dentry *dentry, + const struct qstr *name); extern struct dentry * d_exact_alias(struct dentry *, struct inode *); extern struct dentry *d_find_any_alias(struct inode *inode); extern struct dentry * d_obtain_alias(struct inode *);