diff mbox series

[07/16] iio: adc: at91-sama5d2_adc: simplify the code in at91_adc_read_info_raw()

Message ID 20220609083213.1795019-8-claudiu.beznea@microchip.com (mailing list archive)
State New, archived
Headers show
Series iio: adc: at91-sama5d2_adc: add support for temperature sensor | expand

Commit Message

Claudiu Beznea June 9, 2022, 8:32 a.m. UTC
Simplify a bit the code in at91_adc_read_info_raw() by reducing the
number of lines of code.

Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
---
 drivers/iio/adc/at91-sama5d2_adc.c | 35 +++++++++---------------------
 1 file changed, 10 insertions(+), 25 deletions(-)

Comments

Jonathan Cameron June 11, 2022, 5:54 p.m. UTC | #1
On Thu, 9 Jun 2022 11:32:04 +0300
Claudiu Beznea <claudiu.beznea@microchip.com> wrote:

> Simplify a bit the code in at91_adc_read_info_raw() by reducing the
> number of lines of code.
> 
> Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>

I'm not convinced this is worth while, but there are some lesser
steps visible in this patch that probably are.

Given your earlier reorg to move at01_adc_adjust_val_osr() under the locks,
you can now move the locks to the caller, thus not needing to handle them
separately in all the exit paths.

> ---
>  drivers/iio/adc/at91-sama5d2_adc.c | 35 +++++++++---------------------
>  1 file changed, 10 insertions(+), 25 deletions(-)
> 
> diff --git a/drivers/iio/adc/at91-sama5d2_adc.c b/drivers/iio/adc/at91-sama5d2_adc.c
> index b52f1020feaf..fbb98e216e70 100644
> --- a/drivers/iio/adc/at91-sama5d2_adc.c
> +++ b/drivers/iio/adc/at91-sama5d2_adc.c
> @@ -1576,6 +1576,7 @@ static int at91_adc_read_info_raw(struct iio_dev *indio_dev,
>  				  struct iio_chan_spec const *chan, int *val)
>  {
>  	struct at91_adc_state *st = iio_priv(indio_dev);
> +	int (*fn)(struct at91_adc_state *, int, u16 *) = NULL;
>  	u16 tmp_val;
>  	int ret;
>  
> @@ -1583,29 +1584,18 @@ static int at91_adc_read_info_raw(struct iio_dev *indio_dev,
>  	 * Keep in mind that we cannot use software trigger or touchscreen
>  	 * if external trigger is enabled
>  	 */
> -	if (chan->type == IIO_POSITIONRELATIVE) {
> -		ret = iio_device_claim_direct_mode(indio_dev);
> -		if (ret)
> -			return ret;

You can drop this out of the if statements as it happens in all paths.
Or even better, move it to the caller..

> -		mutex_lock(&st->lock);
> -
> -		ret = at91_adc_read_position(st, chan->channel,
> -					     &tmp_val);

huh? ret not checked? 

> -		*val = tmp_val;
> -		ret = at91_adc_adjust_val_osr(st, val);
Sure this is duplicated, but meh it's only a few lines.


> -		mutex_unlock(&st->lock);
> -		iio_device_release_direct_mode(indio_dev);

this early release (compared to the long path) is the only bit really
gets duplicated in all paths..

> +	if (chan->type == IIO_POSITIONRELATIVE)
> +		fn = at91_adc_read_position;
> +	if (chan->type == IIO_PRESSURE)
> +		fn = at91_adc_read_pressure;
>  
> +	ret = iio_device_claim_direct_mode(indio_dev);
> +	if (ret)
>  		return ret;
> -	}
> -	if (chan->type == IIO_PRESSURE) {
this should always have been an else if () as the chan->type couldn't be both.

> -		ret = iio_device_claim_direct_mode(indio_dev);
> -		if (ret)
> -			return ret;
> -		mutex_lock(&st->lock);
hence this lot can be shared with the above.

> +	mutex_lock(&st->lock);
>  
> -		ret = at91_adc_read_pressure(st, chan->channel,
> -					     &tmp_val);
> +	if (fn) {
> +		ret = fn(st, chan->channel, &tmp_val);
>  		*val = tmp_val;
>  		ret = at91_adc_adjust_val_osr(st, val);
>  		mutex_unlock(&st->lock);
> @@ -1616,11 +1606,6 @@ static int at91_adc_read_info_raw(struct iio_dev *indio_dev,
>  
>  	/* in this case we have a voltage channel */
>  
> -	ret = iio_device_claim_direct_mode(indio_dev);
> -	if (ret)
> -		return ret;
> -	mutex_lock(&st->lock);
> -
>  	st->chan = chan;
>  
>  	at91_adc_cor(st, chan);
Claudiu Beznea June 14, 2022, 8:49 a.m. UTC | #2
On 11.06.2022 20:54, Jonathan Cameron wrote:
> EXTERNAL EMAIL: Do not click links or open attachments unless you know the content is safe
> 
> On Thu, 9 Jun 2022 11:32:04 +0300
> Claudiu Beznea <claudiu.beznea@microchip.com> wrote:
> 
>> Simplify a bit the code in at91_adc_read_info_raw() by reducing the
>> number of lines of code.
>>
>> Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
> 
> I'm not convinced this is worth while, but there are some lesser
> steps visible in this patch that probably are.
> 
> Given your earlier reorg to move at01_adc_adjust_val_osr() under the locks,
> you can now move the locks to the caller, thus not needing to handle them
> separately in all the exit paths.

OK, I'll give it a try. With this, would you prefer to still keep this patch?

> 
>> ---
>>  drivers/iio/adc/at91-sama5d2_adc.c | 35 +++++++++---------------------
>>  1 file changed, 10 insertions(+), 25 deletions(-)
>>
>> diff --git a/drivers/iio/adc/at91-sama5d2_adc.c b/drivers/iio/adc/at91-sama5d2_adc.c
>> index b52f1020feaf..fbb98e216e70 100644
>> --- a/drivers/iio/adc/at91-sama5d2_adc.c
>> +++ b/drivers/iio/adc/at91-sama5d2_adc.c
>> @@ -1576,6 +1576,7 @@ static int at91_adc_read_info_raw(struct iio_dev *indio_dev,
>>                                 struct iio_chan_spec const *chan, int *val)
>>  {
>>       struct at91_adc_state *st = iio_priv(indio_dev);
>> +     int (*fn)(struct at91_adc_state *, int, u16 *) = NULL;
>>       u16 tmp_val;
>>       int ret;
>>
>> @@ -1583,29 +1584,18 @@ static int at91_adc_read_info_raw(struct iio_dev *indio_dev,
>>        * Keep in mind that we cannot use software trigger or touchscreen
>>        * if external trigger is enabled
>>        */
>> -     if (chan->type == IIO_POSITIONRELATIVE) {
>> -             ret = iio_device_claim_direct_mode(indio_dev);
>> -             if (ret)
>> -                     return ret;
> 
> You can drop this out of the if statements as it happens in all paths.
> Or even better, move it to the caller..
> 
>> -             mutex_lock(&st->lock);
>> -
>> -             ret = at91_adc_read_position(st, chan->channel,
>> -                                          &tmp_val);
> 
> huh? ret not checked?

Yep, this should have been missed...

> 
>> -             *val = tmp_val;
>> -             ret = at91_adc_adjust_val_osr(st, val);
> Sure this is duplicated, but meh it's only a few lines.
> 
> 
>> -             mutex_unlock(&st->lock);
>> -             iio_device_release_direct_mode(indio_dev);
> 
> this early release (compared to the long path) is the only bit really
> gets duplicated in all paths..
> 
>> +     if (chan->type == IIO_POSITIONRELATIVE)
>> +             fn = at91_adc_read_position;
>> +     if (chan->type == IIO_PRESSURE)
>> +             fn = at91_adc_read_pressure;
>>
>> +     ret = iio_device_claim_direct_mode(indio_dev);
>> +     if (ret)
>>               return ret;
>> -     }
>> -     if (chan->type == IIO_PRESSURE) {
> this should always have been an else if () as the chan->type couldn't be both.
> 
>> -             ret = iio_device_claim_direct_mode(indio_dev);
>> -             if (ret)
>> -                     return ret;
>> -             mutex_lock(&st->lock);
> hence this lot can be shared with the above.

To be sure of what I've understood correctly: in the end you prefer to have
a patch with the point you suggested rather then the initial patch?

Thank you,
Claudiu Beznea

> 
>> +     mutex_lock(&st->lock);
>>
>> -             ret = at91_adc_read_pressure(st, chan->channel,
>> -                                          &tmp_val);
>> +     if (fn) {
>> +             ret = fn(st, chan->channel, &tmp_val);
>>               *val = tmp_val;
>>               ret = at91_adc_adjust_val_osr(st, val);
>>               mutex_unlock(&st->lock);
>> @@ -1616,11 +1606,6 @@ static int at91_adc_read_info_raw(struct iio_dev *indio_dev,
>>
>>       /* in this case we have a voltage channel */
>>
>> -     ret = iio_device_claim_direct_mode(indio_dev);
>> -     if (ret)
>> -             return ret;
>> -     mutex_lock(&st->lock);
>> -
>>       st->chan = chan;
>>
>>       at91_adc_cor(st, chan);
>
Jonathan Cameron June 14, 2022, noon UTC | #3
On Tue, 14 Jun 2022 08:49:03 +0000
<Claudiu.Beznea@microchip.com> wrote:

> On 11.06.2022 20:54, Jonathan Cameron wrote:
> > EXTERNAL EMAIL: Do not click links or open attachments unless you know the content is safe
> > 
> > On Thu, 9 Jun 2022 11:32:04 +0300
> > Claudiu Beznea <claudiu.beznea@microchip.com> wrote:
> >   
> >> Simplify a bit the code in at91_adc_read_info_raw() by reducing the
> >> number of lines of code.
> >>
> >> Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>  
> > 
> > I'm not convinced this is worth while, but there are some lesser
> > steps visible in this patch that probably are.
> > 
> > Given your earlier reorg to move at01_adc_adjust_val_osr() under the locks,
> > you can now move the locks to the caller, thus not needing to handle them
> > separately in all the exit paths.  
> 
> OK, I'll give it a try. With this, would you prefer to still keep this patch?
> 
No. I don't think it will bring enough benefit for the loss of readability.
Having moved the locking, there will only be a few repeated lines.

Jonathan
diff mbox series

Patch

diff --git a/drivers/iio/adc/at91-sama5d2_adc.c b/drivers/iio/adc/at91-sama5d2_adc.c
index b52f1020feaf..fbb98e216e70 100644
--- a/drivers/iio/adc/at91-sama5d2_adc.c
+++ b/drivers/iio/adc/at91-sama5d2_adc.c
@@ -1576,6 +1576,7 @@  static int at91_adc_read_info_raw(struct iio_dev *indio_dev,
 				  struct iio_chan_spec const *chan, int *val)
 {
 	struct at91_adc_state *st = iio_priv(indio_dev);
+	int (*fn)(struct at91_adc_state *, int, u16 *) = NULL;
 	u16 tmp_val;
 	int ret;
 
@@ -1583,29 +1584,18 @@  static int at91_adc_read_info_raw(struct iio_dev *indio_dev,
 	 * Keep in mind that we cannot use software trigger or touchscreen
 	 * if external trigger is enabled
 	 */
-	if (chan->type == IIO_POSITIONRELATIVE) {
-		ret = iio_device_claim_direct_mode(indio_dev);
-		if (ret)
-			return ret;
-		mutex_lock(&st->lock);
-
-		ret = at91_adc_read_position(st, chan->channel,
-					     &tmp_val);
-		*val = tmp_val;
-		ret = at91_adc_adjust_val_osr(st, val);
-		mutex_unlock(&st->lock);
-		iio_device_release_direct_mode(indio_dev);
+	if (chan->type == IIO_POSITIONRELATIVE)
+		fn = at91_adc_read_position;
+	if (chan->type == IIO_PRESSURE)
+		fn = at91_adc_read_pressure;
 
+	ret = iio_device_claim_direct_mode(indio_dev);
+	if (ret)
 		return ret;
-	}
-	if (chan->type == IIO_PRESSURE) {
-		ret = iio_device_claim_direct_mode(indio_dev);
-		if (ret)
-			return ret;
-		mutex_lock(&st->lock);
+	mutex_lock(&st->lock);
 
-		ret = at91_adc_read_pressure(st, chan->channel,
-					     &tmp_val);
+	if (fn) {
+		ret = fn(st, chan->channel, &tmp_val);
 		*val = tmp_val;
 		ret = at91_adc_adjust_val_osr(st, val);
 		mutex_unlock(&st->lock);
@@ -1616,11 +1606,6 @@  static int at91_adc_read_info_raw(struct iio_dev *indio_dev,
 
 	/* in this case we have a voltage channel */
 
-	ret = iio_device_claim_direct_mode(indio_dev);
-	if (ret)
-		return ret;
-	mutex_lock(&st->lock);
-
 	st->chan = chan;
 
 	at91_adc_cor(st, chan);