Message ID | 20220707005602.696557-1-pizhenwei@bytedance.com (mailing list archive) |
---|---|
Headers | show |
Series | qga: add command 'guest-get-cpustats' | expand |
Queued, thanks. On Thu, Jul 7, 2022 at 4:01 AM zhenwei pi <pizhenwei@bytedance.com> wrote: > v3 -> v4: > - Separate qapi script change from qga. > > v2 -> v3: > - Rename 'GuestOsType' to 'GuestCpuStatsType'. > - Add 'linux' into polluted_words, rename 'linuxos' to 'linux'. Remove > 'windows' from 'GuestCpuStatsType', because currently we don't use it. > > v1 -> v2: > - Konstantin & Marc-André pointed out that the structure 'GuestCpuStats' > is too *linux style*, so re-define it to 'GuestLinuxCpuStats', and use > an union type of 'GuestCpuStats'. > > - Modify comment info from 'man proc', also add linux version infomation. > > - Test sscanf return value by '(i == EOF)' (To Marc-André: name is declared > as 'char name[64];', so we can't test '!name'). > > - Suggested by Marc-André, use 'int clk_tck = sysconf(_SC_CLK_TCK);' > instead of hard code. > > v1: > - Implement guest agent command 'guest-get-cpustats' > > Zhenwei Pi (2): > qapi: Avoid generating C identifier 'linux' > qga: add command 'guest-get-cpustats' > > qga/commands-posix.c | 89 ++++++++++++++++++++++++++++++++++++++++++ > qga/commands-win32.c | 6 +++ > qga/qapi-schema.json | 81 ++++++++++++++++++++++++++++++++++++++ > scripts/qapi/common.py | 2 +- > 4 files changed, 177 insertions(+), 1 deletion(-) > > -- > 2.20.1 > >