diff mbox series

[v18,1/2] dt-bindings: usb: Add analogix anx7411 PD binding

Message ID 20220713084139.2810115-1-xji@analogixsemi.com (mailing list archive)
State Superseded
Headers show
Series [v18,1/2] dt-bindings: usb: Add analogix anx7411 PD binding | expand

Commit Message

Xin Ji July 13, 2022, 8:41 a.m. UTC
Add analogix PD chip anx7411 device binding

Reviewed-by: Rob Herring <robh@kernel.org>
Signed-off-by: Xin Ji <xji@analogixsemi.com>

---
v17 -> v18 : Change node name from "usb_typec" to "typec"
v16 -> v17 : Add node name "usb_typec"
v15 -> v16 : No changes
v14 -> v15 : No changes
v13 -> v14 :
    1. Fix Robot compile error. Fix node name not correct.
    2. Change HEX to lowercase.
    3. Use "ports" property.
v12 -> v13 :
    1. Drop the quotes for "$id" and "$schema"
    2. Remove "allOf" label
    3. Change node name from "i2c1" to "i2c"
    4. Change node name from "typec" to "usb-typec"
---
 .../bindings/usb/analogix,anx7411.yaml        | 81 +++++++++++++++++++
 1 file changed, 81 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/usb/analogix,anx7411.yaml

Comments

Krzysztof Kozlowski July 13, 2022, 9:28 a.m. UTC | #1
On 13/07/2022 10:41, Xin Ji wrote:
> Add analogix PD chip anx7411 device binding
> 
> Reviewed-by: Rob Herring <robh@kernel.org>
> Signed-off-by: Xin Ji <xji@analogixsemi.com>
> 
> ---
> v17 -> v18 : Change node name from "usb_typec" to "typec"

Node name was anx7411, not usb_typec. What are you changing here? The label?

Best regards,
Krzysztof
Xin Ji July 14, 2022, 2:02 a.m. UTC | #2
On Wed, Jul 13, 2022 at 11:28:16AM +0200, Krzysztof Kozlowski wrote:
> On 13/07/2022 10:41, Xin Ji wrote:
> > Add analogix PD chip anx7411 device binding
> > 
> > Reviewed-by: Rob Herring <robh@kernel.org>
> > Signed-off-by: Xin Ji <xji@analogixsemi.com>
> > 
> > ---
> > v17 -> v18 : Change node name from "usb_typec" to "typec"
> 
> Node name was anx7411, not usb_typec. What are you changing here? The label?
Hi Krzysztof, sorry, I'm confused by your comment, this patch followed the
other dts example in other yaml file and passed the dts checking by
command "make dt_binding_check".

Do you mean change the the node name "anx7411" to "typec"?

Thanks,
Xin
> 
> Best regards,
> Krzysztof
Krzysztof Kozlowski July 14, 2022, 6:52 a.m. UTC | #3
On 14/07/2022 04:02, Xin Ji wrote:
> On Wed, Jul 13, 2022 at 11:28:16AM +0200, Krzysztof Kozlowski wrote:
>> On 13/07/2022 10:41, Xin Ji wrote:
>>> Add analogix PD chip anx7411 device binding
>>>
>>> Reviewed-by: Rob Herring <robh@kernel.org>
>>> Signed-off-by: Xin Ji <xji@analogixsemi.com>
>>>
>>> ---
>>> v17 -> v18 : Change node name from "usb_typec" to "typec"
>>
>> Node name was anx7411, not usb_typec. What are you changing here? The label?
> Hi Krzysztof, sorry, I'm confused by your comment, this patch followed the
> other dts example in other yaml file and passed the dts checking by
> command "make dt_binding_check".
> 
> Do you mean change the the node name "anx7411" to "typec"?

Yes, since the some revisions ago I asked to use a generic name for the
node (generic node name).


Best regards,
Krzysztof
Xin Ji July 14, 2022, 8:01 a.m. UTC | #4
On Thu, Jul 14, 2022 at 08:52:09AM +0200, Krzysztof Kozlowski wrote:
> On 14/07/2022 04:02, Xin Ji wrote:
> > On Wed, Jul 13, 2022 at 11:28:16AM +0200, Krzysztof Kozlowski wrote:
> >> On 13/07/2022 10:41, Xin Ji wrote:
> >>> Add analogix PD chip anx7411 device binding
> >>>
> >>> Reviewed-by: Rob Herring <robh@kernel.org>
> >>> Signed-off-by: Xin Ji <xji@analogixsemi.com>
> >>>
> >>> ---
> >>> v17 -> v18 : Change node name from "usb_typec" to "typec"
> >>
> >> Node name was anx7411, not usb_typec. What are you changing here? The label?
> > Hi Krzysztof, sorry, I'm confused by your comment, this patch followed the
> > other dts example in other yaml file and passed the dts checking by
> > command "make dt_binding_check".
> > 
> > Do you mean change the the node name "anx7411" to "typec"?
> 
> Yes, since the some revisions ago I asked to use a generic name for the
> node (generic node name).
> 
> 
> Best regards,
> Krzysztof
Hi Krzysztof, OK, I'll change it in next version.
Thanks,
Xin
diff mbox series

Patch

diff --git a/Documentation/devicetree/bindings/usb/analogix,anx7411.yaml b/Documentation/devicetree/bindings/usb/analogix,anx7411.yaml
new file mode 100644
index 000000000000..080bb9a61f40
--- /dev/null
+++ b/Documentation/devicetree/bindings/usb/analogix,anx7411.yaml
@@ -0,0 +1,81 @@ 
+# SPDX-License-Identifier: GPL-2.0-only OR BSD-2-Clause
+%YAML 1.2
+---
+$id: http://devicetree.org/schemas/usb/analogix,anx7411.yaml#
+$schema: http://devicetree.org/meta-schemas/core.yaml#
+
+title: Analogix ANX7411 Type-C controller bindings
+
+maintainers:
+  - Xin Ji <xji@analogixsemi.com>
+
+properties:
+  compatible:
+    enum:
+      - analogix,anx7411
+
+  reg:
+    maxItems: 1
+
+  interrupts:
+    maxItems: 1
+
+  connector:
+    type: object
+    $ref: ../connector/usb-connector.yaml
+    description:
+      Properties for usb c connector.
+
+    properties:
+      compatible:
+        const: usb-c-connector
+
+      power-role: true
+
+      data-role: true
+
+      try-power-role: true
+
+    required:
+      - compatible
+
+required:
+  - compatible
+  - reg
+  - connector
+
+additionalProperties: false
+
+examples:
+  - |
+    #include <dt-bindings/interrupt-controller/irq.h>
+    i2c {
+        #address-cells = <1>;
+        #size-cells = <0>;
+
+        typec: anx7411@2c {
+            compatible = "analogix,anx7411";
+            reg = <0x2c>;
+            interrupts = <8 IRQ_TYPE_EDGE_FALLING>;
+            interrupt-parent = <&gpio0>;
+
+            typec_con: connector {
+                compatible = "usb-c-connector";
+                power-role = "dual";
+                data-role = "dual";
+                try-power-role = "source";
+
+                ports {
+                    #address-cells = <1>;
+                    #size-cells = <0>;
+                    port@0 {
+                        reg = <0>;
+                        typec_con_ep: endpoint {
+                            remote-endpoint = <&usbotg_hs_ep>;
+                        };
+                    };
+                };
+            };
+        };
+    };
+...