Message ID | 20220726092248.128336-10-frankja@linux.ibm.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | dump: Add arch section and s390x PV dump | expand |
On Tue, Jul 26, 2022 at 1:23 PM Janosch Frank <frankja@linux.ibm.com> wrote: > > Let's move ELF related members into one block and guest memory related > ones into another to improve readability. > > Signed-off-by: Janosch Frank <frankja@linux.ibm.com> > Reviewed-by: Richard Henderson <richard.henderson@linaro.org> > Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> > --- > include/sysemu/dump.h | 16 +++++++++------- > 1 file changed, 9 insertions(+), 7 deletions(-) > > diff --git a/include/sysemu/dump.h b/include/sysemu/dump.h > index 686555f908..3937afe0f9 100644 > --- a/include/sysemu/dump.h > +++ b/include/sysemu/dump.h > @@ -154,15 +154,8 @@ typedef struct DumpState { > GuestPhysBlockList guest_phys_blocks; > ArchDumpInfo dump_info; > MemoryMappingList list; > - uint32_t phdr_num; > - uint32_t shdr_num; > bool resume; > bool detached; > - ssize_t note_size; > - hwaddr shdr_offset; > - hwaddr phdr_offset; > - hwaddr section_offset; There is a bit of churn because you remove this field and add it back later. Worth to explain in the commit message imho. > - hwaddr note_offset; > hwaddr memory_offset; > int fd; > > @@ -171,6 +164,15 @@ typedef struct DumpState { > int64_t begin; /* Start address of the chunk we want to dump */ > int64_t length; /* Length of the dump we want to dump */ > > + /* Elf dump related data */ > + uint32_t phdr_num; > + uint32_t shdr_num; > + uint32_t sh_info; > + ssize_t note_size; > + hwaddr shdr_offset; > + hwaddr phdr_offset; > + hwaddr note_offset; > + > void *elf_header; > void *elf_section_hdrs; > uint64_t elf_section_data_size; > -- > 2.34.1 >
On 7/26/22 11:22, Janosch Frank wrote: > Let's move ELF related members into one block and guest memory related > ones into another to improve readability. > > Signed-off-by: Janosch Frank <frankja@linux.ibm.com> > Reviewed-by: Richard Henderson <richard.henderson@linaro.org> > Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> > --- > include/sysemu/dump.h | 16 +++++++++------- > 1 file changed, 9 insertions(+), 7 deletions(-) > > diff --git a/include/sysemu/dump.h b/include/sysemu/dump.h > index 686555f908..3937afe0f9 100644 > --- a/include/sysemu/dump.h > +++ b/include/sysemu/dump.h > @@ -154,15 +154,8 @@ typedef struct DumpState { > GuestPhysBlockList guest_phys_blocks; > ArchDumpInfo dump_info; > MemoryMappingList list; > - uint32_t phdr_num; > - uint32_t shdr_num; > bool resume; > bool detached; > - ssize_t note_size; > - hwaddr shdr_offset; > - hwaddr phdr_offset; > - hwaddr section_offset; > - hwaddr note_offset; > hwaddr memory_offset; > int fd; > > @@ -171,6 +164,15 @@ typedef struct DumpState { > int64_t begin; /* Start address of the chunk we want to dump */ > int64_t length; /* Length of the dump we want to dump */ > > + /* Elf dump related data */ > + uint32_t phdr_num; > + uint32_t shdr_num; > + uint32_t sh_info; Why is this ^ here? > + ssize_t note_size; > + hwaddr shdr_offset; > + hwaddr phdr_offset; > + hwaddr note_offset; > + > void *elf_header; > void *elf_section_hdrs; > uint64_t elf_section_data_size;
On 7/29/22 19:21, Janis Schoetterl-Glausch wrote: > On 7/26/22 11:22, Janosch Frank wrote: >> Let's move ELF related members into one block and guest memory related >> ones into another to improve readability. >> >> Signed-off-by: Janosch Frank <frankja@linux.ibm.com> >> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> >> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> >> --- >> include/sysemu/dump.h | 16 +++++++++------- >> 1 file changed, 9 insertions(+), 7 deletions(-) >> >> diff --git a/include/sysemu/dump.h b/include/sysemu/dump.h >> index 686555f908..3937afe0f9 100644 >> --- a/include/sysemu/dump.h >> +++ b/include/sysemu/dump.h >> @@ -154,15 +154,8 @@ typedef struct DumpState { >> GuestPhysBlockList guest_phys_blocks; >> ArchDumpInfo dump_info; >> MemoryMappingList list; >> - uint32_t phdr_num; >> - uint32_t shdr_num; >> bool resume; >> bool detached; >> - ssize_t note_size; >> - hwaddr shdr_offset; >> - hwaddr phdr_offset; >> - hwaddr section_offset; >> - hwaddr note_offset; >> hwaddr memory_offset; >> int fd; >> >> @@ -171,6 +164,15 @@ typedef struct DumpState { >> int64_t begin; /* Start address of the chunk we want to dump */ >> int64_t length; /* Length of the dump we want to dump */ >> >> + /* Elf dump related data */ >> + uint32_t phdr_num; >> + uint32_t shdr_num; >> + uint32_t sh_info; > > Why is this ^ here? Re-base damage > >> + ssize_t note_size; >> + hwaddr shdr_offset; >> + hwaddr phdr_offset; >> + hwaddr note_offset; >> + >> void *elf_header; >> void *elf_section_hdrs; >> uint64_t elf_section_data_size; >
diff --git a/include/sysemu/dump.h b/include/sysemu/dump.h index 686555f908..3937afe0f9 100644 --- a/include/sysemu/dump.h +++ b/include/sysemu/dump.h @@ -154,15 +154,8 @@ typedef struct DumpState { GuestPhysBlockList guest_phys_blocks; ArchDumpInfo dump_info; MemoryMappingList list; - uint32_t phdr_num; - uint32_t shdr_num; bool resume; bool detached; - ssize_t note_size; - hwaddr shdr_offset; - hwaddr phdr_offset; - hwaddr section_offset; - hwaddr note_offset; hwaddr memory_offset; int fd; @@ -171,6 +164,15 @@ typedef struct DumpState { int64_t begin; /* Start address of the chunk we want to dump */ int64_t length; /* Length of the dump we want to dump */ + /* Elf dump related data */ + uint32_t phdr_num; + uint32_t shdr_num; + uint32_t sh_info; + ssize_t note_size; + hwaddr shdr_offset; + hwaddr phdr_offset; + hwaddr note_offset; + void *elf_header; void *elf_section_hdrs; uint64_t elf_section_data_size;