diff mbox series

[v4,1/5] HID: core: Export hid_match_id()

Message ID 20220830132549.7240-1-hadess@hadess.net (mailing list archive)
State Mainlined
Commit 80305f97c3a46f8e01c9974b8efc7619a422251c
Delegated to: Jiri Kosina
Headers show
Series [v4,1/5] HID: core: Export hid_match_id() | expand

Commit Message

Bastien Nocera Aug. 30, 2022, 1:25 p.m. UTC
Export hid_match_id() so it can be used in device-specific drivers to
implement their own matching with open-coding a match function.

Signed-off-by: Bastien Nocera <hadess@hadess.net>
---
 drivers/hid/hid-core.c | 1 +
 1 file changed, 1 insertion(+)

Comments

Bastien Nocera Sept. 7, 2022, 3:39 p.m. UTC | #1
Jiri,

If those patches look good to you, would be great to get merged.
Benjamin doesn't have the bandwidth to test the patches on his own test
hardware right now, but I've been using them daily for a week now.

Cheers

On Tue, 2022-08-30 at 15:25 +0200, Bastien Nocera wrote:
> Export hid_match_id() so it can be used in device-specific drivers to
> implement their own matching with open-coding a match function.
> 
> Signed-off-by: Bastien Nocera <hadess@hadess.net>
> ---
>  drivers/hid/hid-core.c | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
> index b7f5566e338d..72f8d8835b34 100644
> --- a/drivers/hid/hid-core.c
> +++ b/drivers/hid/hid-core.c
> @@ -2088,6 +2088,7 @@ const struct hid_device_id *hid_match_id(const
> struct hid_device *hdev,
>  
>         return NULL;
>  }
> +EXPORT_SYMBOL_GPL(hid_match_id);
>  
>  static const struct hid_device_id hid_hiddev_list[] = {
>         { HID_USB_DEVICE(USB_VENDOR_ID_MGE, USB_DEVICE_ID_MGE_UPS) },
Jiri Kosina Sept. 7, 2022, 8:09 p.m. UTC | #2
On Wed, 7 Sep 2022, Bastien Nocera wrote:

> > Export hid_match_id() so it can be used in device-specific drivers to
> > implement their own matching with open-coding a match function.
> > 
> > Signed-off-by: Bastien Nocera <hadess@hadess.net>
> > ---
> >  drivers/hid/hid-core.c | 1 +
> >  1 file changed, 1 insertion(+)
> > 
> > diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
> > index b7f5566e338d..72f8d8835b34 100644
> > --- a/drivers/hid/hid-core.c
> > +++ b/drivers/hid/hid-core.c
> > @@ -2088,6 +2088,7 @@ const struct hid_device_id *hid_match_id(const
> > struct hid_device *hdev,
> >  
> >         return NULL;
> >  }
> > +EXPORT_SYMBOL_GPL(hid_match_id);
> >  
> >  static const struct hid_device_id hid_hiddev_list[] = {
> >         { HID_USB_DEVICE(USB_VENDOR_ID_MGE, USB_DEVICE_ID_MGE_UPS) },
> 
> If those patches look good to you, would be great to get merged.
> Benjamin doesn't have the bandwidth to test the patches on his own test
> hardware right now, but I've been using them daily for a week now.

Alright, I was waiting for Ack from Benjamin, but based on this, and due 
to the fact that I don't see any issue with it myself, I've now applied 
the series to for-6.1/logitech branch so that it gets as much linux-next 
exposure as possible.

Thanks,
Bastien Nocera Sept. 8, 2022, 8:03 a.m. UTC | #3
On Wed, 2022-09-07 at 22:09 +0200, Jiri Kosina wrote:
> On Wed, 7 Sep 2022, Bastien Nocera wrote:
> 
> > > Export hid_match_id() so it can be used in device-specific
> > > drivers to
> > > implement their own matching with open-coding a match function.
> > > 
> > > Signed-off-by: Bastien Nocera <hadess@hadess.net>
> > > ---
> > >  drivers/hid/hid-core.c | 1 +
> > >  1 file changed, 1 insertion(+)
> > > 
> > > diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
> > > index b7f5566e338d..72f8d8835b34 100644
> > > --- a/drivers/hid/hid-core.c
> > > +++ b/drivers/hid/hid-core.c
> > > @@ -2088,6 +2088,7 @@ const struct hid_device_id
> > > *hid_match_id(const
> > > struct hid_device *hdev,
> > >  
> > >         return NULL;
> > >  }
> > > +EXPORT_SYMBOL_GPL(hid_match_id);
> > >  
> > >  static const struct hid_device_id hid_hiddev_list[] = {
> > >         { HID_USB_DEVICE(USB_VENDOR_ID_MGE,
> > > USB_DEVICE_ID_MGE_UPS) },
> > 
> > If those patches look good to you, would be great to get merged.
> > Benjamin doesn't have the bandwidth to test the patches on his own
> > test
> > hardware right now, but I've been using them daily for a week now.
> 
> Alright, I was waiting for Ack from Benjamin, but based on this, and
> due 
> to the fact that I don't see any issue with it myself, I've now
> applied 
> the series to for-6.1/logitech branch so that it gets as much linux-
> next 
> exposure as possible.

Great, thanks!

Peter, if there were any other bugs in the hid-logitech-hidpp
implementation that needed handling, please file them at
bugzilla.kernel.org so they don't get lost.
diff mbox series

Patch

diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
index b7f5566e338d..72f8d8835b34 100644
--- a/drivers/hid/hid-core.c
+++ b/drivers/hid/hid-core.c
@@ -2088,6 +2088,7 @@  const struct hid_device_id *hid_match_id(const struct hid_device *hdev,
 
 	return NULL;
 }
+EXPORT_SYMBOL_GPL(hid_match_id);
 
 static const struct hid_device_id hid_hiddev_list[] = {
 	{ HID_USB_DEVICE(USB_VENDOR_ID_MGE, USB_DEVICE_ID_MGE_UPS) },