Message ID | a7c1394346725b7435792628c8d4c06a0a745e0b.1662134821.git.christophe.jaillet@wanadoo.fr (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [v3] vfio/fsl-mc: Fix a typo in a message | expand |
Reviewed-by: Diana Craciun <diana.craciun@oss.nxp.com> On 9/2/2022 7:07 PM, Christophe JAILLET wrote: > L and S are swapped in the message. > s/VFIO_FLS_MC/VFIO_FSL_MC/ > > Also use 'ret' instead of 'WARN_ON(ret)' to avoid a duplicated message. > > Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr> > --- > Changes in v3: > * Remove WARN_ON() and WARN() and only keep dev_warn() [Diana Madalina Craciun <diana.craciun@oss.nxp.com>] > > Changes in v2: > * s/comment/message/ in the subject [Cornelia Huck <cohuck@redhat.com>] > * use WARN instead of WARN_ON+dev_warn [Jason Gunthorpe <jgg@ziepe.ca>] > https://lore.kernel.org/all/3d2aa8434393ee8d2aa23a620e59ce1059c9d7ad.1660663440.git.christophe.jaillet@wanadoo.fr/ > > v1: > https://lore.kernel.org/all/2b65bf8d2b4d940cafbafcede07c23c35f042f5a.1659815764.git.christophe.jaillet@wanadoo > --- > drivers/vfio/fsl-mc/vfio_fsl_mc.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c > index 3feff729f3ce..42b344bd7cd5 100644 > --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c > +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c > @@ -108,9 +108,9 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev) > /* reset the device before cleaning up the interrupts */ > ret = vfio_fsl_mc_reset_device(vdev); > > - if (WARN_ON(ret)) > + if (ret) > dev_warn(&mc_cont->dev, > - "VFIO_FLS_MC: reset device has failed (%d)\n", ret); > + "VFIO_FSL_MC: reset device has failed (%d)\n", ret); > > vfio_fsl_mc_irqs_cleanup(vdev); >
On Fri, Sep 02 2022, Christophe JAILLET <christophe.jaillet@wanadoo.fr> wrote: > L and S are swapped in the message. > s/VFIO_FLS_MC/VFIO_FSL_MC/ > > Also use 'ret' instead of 'WARN_ON(ret)' to avoid a duplicated message. > > Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr> > --- > Changes in v3: > * Remove WARN_ON() and WARN() and only keep dev_warn() [Diana Madalina Craciun <diana.craciun@oss.nxp.com>] > > Changes in v2: > * s/comment/message/ in the subject [Cornelia Huck <cohuck@redhat.com>] > * use WARN instead of WARN_ON+dev_warn [Jason Gunthorpe <jgg@ziepe.ca>] > https://lore.kernel.org/all/3d2aa8434393ee8d2aa23a620e59ce1059c9d7ad.1660663440.git.christophe.jaillet@wanadoo.fr/ > > v1: > https://lore.kernel.org/all/2b65bf8d2b4d940cafbafcede07c23c35f042f5a.1659815764.git.christophe.jaillet@wanadoo > --- > drivers/vfio/fsl-mc/vfio_fsl_mc.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) Acked-by: Cornelia Huck <cohuck@redhat.com>
On Fri, 2 Sep 2022 18:07:54 +0200 Christophe JAILLET <christophe.jaillet@wanadoo.fr> wrote: > L and S are swapped in the message. > s/VFIO_FLS_MC/VFIO_FSL_MC/ > > Also use 'ret' instead of 'WARN_ON(ret)' to avoid a duplicated message. > > Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr> > --- > Changes in v3: > * Remove WARN_ON() and WARN() and only keep dev_warn() [Diana Madalina Craciun <diana.craciun@oss.nxp.com>] Applied to vfio next branch for v6.1. Thanks, Alex
diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c index 3feff729f3ce..42b344bd7cd5 100644 --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c @@ -108,9 +108,9 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev) /* reset the device before cleaning up the interrupts */ ret = vfio_fsl_mc_reset_device(vdev); - if (WARN_ON(ret)) + if (ret) dev_warn(&mc_cont->dev, - "VFIO_FLS_MC: reset device has failed (%d)\n", ret); + "VFIO_FSL_MC: reset device has failed (%d)\n", ret); vfio_fsl_mc_irqs_cleanup(vdev);
L and S are swapped in the message. s/VFIO_FLS_MC/VFIO_FSL_MC/ Also use 'ret' instead of 'WARN_ON(ret)' to avoid a duplicated message. Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr> --- Changes in v3: * Remove WARN_ON() and WARN() and only keep dev_warn() [Diana Madalina Craciun <diana.craciun@oss.nxp.com>] Changes in v2: * s/comment/message/ in the subject [Cornelia Huck <cohuck@redhat.com>] * use WARN instead of WARN_ON+dev_warn [Jason Gunthorpe <jgg@ziepe.ca>] https://lore.kernel.org/all/3d2aa8434393ee8d2aa23a620e59ce1059c9d7ad.1660663440.git.christophe.jaillet@wanadoo.fr/ v1: https://lore.kernel.org/all/2b65bf8d2b4d940cafbafcede07c23c35f042f5a.1659815764.git.christophe.jaillet@wanadoo --- drivers/vfio/fsl-mc/vfio_fsl_mc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)