diff mbox series

[2/2] ASoC: dt-bindings: nau8825: Add ADCOUT IO drive strength control

Message ID 20220912115427.710417-2-CTLIN0@nuvoton.com (mailing list archive)
State Superseded
Headers show
Series [1/2] ASoC: nau8825: Add ADCOUT IO drive strength control | expand

Commit Message

David Lin Sept. 12, 2022, 11:54 a.m. UTC
Add a property to control the driving of ADCOUT.

Signed-off-by: David Lin <CTLIN0@nuvoton.com>
---
 Documentation/devicetree/bindings/sound/nau8825.txt | 2 ++
 1 file changed, 2 insertions(+)

Comments

Mark Brown Sept. 12, 2022, 12:05 p.m. UTC | #1
On Mon, Sep 12, 2022 at 07:54:29PM +0800, David Lin wrote:

> +  - nuvoton,adcout-drive-str: make ADCOUT IO drive strength with stronger if set.
> +

This isn't the clearest property name or description TBH.  For a
device specific setting like this it might be clearer to add a
reference to the register bit so it's easier for people to tie
the behaviour back to the actual device behaviour change.
There's also probably something clearer than "stronger" that
could be used here.

Perhaps adding something like "strong" would be good - with the
name I'd expected the property to be a numerical strength rather
than a boolean.
David Lin Sept. 13, 2022, 7:25 a.m. UTC | #2
On 2022/9/12 下午 08:05, Mark Brown wrote:
> On Mon, Sep 12, 2022 at 07:54:29PM +0800, David Lin wrote:
>
>> +  - nuvoton,adcout-drive-str: make ADCOUT IO drive strength with stronger if set.
>> +
> This isn't the clearest property name or description TBH.  For a
> device specific setting like this it might be clearer to add a
> reference to the register bit so it's easier for people to tie
> the behaviour back to the actual device behaviour change.
> There's also probably something clearer than "stronger" that
> could be used here.
OK, maybe I should change property name to "adcout-drive-strong" and the
description to "make the drive strength of ADCOUT IO PIN strong if set.
Otherwise, the drive keeps normal strength.".
> Perhaps adding something like "strong" would be good - with the
> name I'd expected the property to be a numerical strength rather
> than a boolean.
 From our design, the register just have one bit for this feature, so
the strength just have normal or stronger. Therefore, I use boolean
property for it.
Mark Brown Sept. 13, 2022, 10:59 a.m. UTC | #3
On Tue, Sep 13, 2022 at 03:25:39PM +0800, AS50 CTLin0 wrote:

> OK, maybe I should change property name to "adcout-drive-strong" and the
> description to "make the drive strength of ADCOUT IO PIN strong if set.
> Otherwise, the drive keeps normal strength.".

That sounds good.

> > Perhaps adding something like "strong" would be good - with the
> > name I'd expected the property to be a numerical strength rather
> > than a boolean.

> From our design, the register just have one bit for this feature, so
> the strength just have normal or stronger. Therefore, I use boolean
> property for it.

Using a boolean property is fine, it just feels weird that it
doesn't say specifically what "stronger" means here.  I was just
thinking adding a note in the description but either way it's not
essential.
David Lin Sept. 13, 2022, 11:42 a.m. UTC | #4
On 2022/9/13 下午 06:59, Mark Brown wrote:
> On Tue, Sep 13, 2022 at 03:25:39PM +0800, AS50 CTLin0 wrote:
>
>> OK, maybe I should change property name to "adcout-drive-strong" and the
>> description to "make the drive strength of ADCOUT IO PIN strong if set.
>> Otherwise, the drive keeps normal strength.".
> That sounds good.
>
>>> Perhaps adding something like "strong" would be good - with the
>>> name I'd expected the property to be a numerical strength rather
>>> than a boolean.
>>  From our design, the register just have one bit for this feature, so
>> the strength just have normal or stronger. Therefore, I use boolean
>> property for it.
> Using a boolean property is fine, it just feels weird that it
> doesn't say specifically what "stronger" means here.  I was just
> thinking adding a note in the description but either way it's not
> essential.

Thanks for your review. It will make the patch more clearly.

I will refine it and send new patches for review.
diff mbox series

Patch

diff --git a/Documentation/devicetree/bindings/sound/nau8825.txt b/Documentation/devicetree/bindings/sound/nau8825.txt
index 388a7bc60b1f..bad7d7c5bb45 100644
--- a/Documentation/devicetree/bindings/sound/nau8825.txt
+++ b/Documentation/devicetree/bindings/sound/nau8825.txt
@@ -71,6 +71,8 @@  Optional properties:
 
   - nuvoton,crosstalk-enable: make crosstalk function enable if set.
 
+  - nuvoton,adcout-drive-str: make ADCOUT IO drive strength with stronger if set.
+
   - clocks: list of phandle and clock specifier pairs according to common clock bindings for the
       clocks described in clock-names
   - clock-names: should include "mclk" for the MCLK master clock