Message ID | 20221029214058.25159-1-tegongkang@gmail.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | [v2] Bluetooth: Use kzalloc instead of kmalloc/memset | expand |
Context | Check | Description |
---|---|---|
tedd_an/pre-ci_am | success | Success |
tedd_an/checkpatch | success | Checkpatch PASS |
tedd_an/gitlint | success | Gitlint PASS |
tedd_an/subjectprefix | success | PASS |
tedd_an/buildkernel | success | Build Kernel PASS |
tedd_an/buildkernel32 | success | Build Kernel32 PASS |
tedd_an/incremental_build | success | Pass |
tedd_an/testrunnersetup | success | Test Runner Setup PASS |
tedd_an/testrunnerl2cap-tester | success | Total: 40, Passed: 40 (100.0%), Failed: 0, Not Run: 0 |
tedd_an/testrunneriso-tester | success | Total: 55, Passed: 55 (100.0%), Failed: 0, Not Run: 0 |
tedd_an/testrunnerbnep-tester | success | Total: 1, Passed: 1 (100.0%), Failed: 0, Not Run: 0 |
tedd_an/testrunnermgmt-tester | success | Total: 494, Passed: 494 (100.0%), Failed: 0, Not Run: 0 |
tedd_an/testrunnerrfcomm-tester | success | Total: 11, Passed: 11 (100.0%), Failed: 0, Not Run: 0 |
tedd_an/testrunnersco-tester | success | Total: 12, Passed: 12 (100.0%), Failed: 0, Not Run: 0 |
tedd_an/testrunnerioctl-tester | success | Total: 28, Passed: 28 (100.0%), Failed: 0, Not Run: 0 |
tedd_an/testrunnermesh-tester | success | Total: 10, Passed: 10 (100.0%), Failed: 0, Not Run: 0 |
tedd_an/testrunnersmp-tester | success | Total: 8, Passed: 8 (100.0%), Failed: 0, Not Run: 0 |
tedd_an/testrunneruserchan-tester | success | Total: 4, Passed: 4 (100.0%), Failed: 0, Not Run: 0 |
This is automated email and please do not reply to this email! Dear submitter, Thank you for submitting the patches to the linux bluetooth mailing list. This is a CI test results with your patch series: PW Link:https://patchwork.kernel.org/project/bluetooth/list/?series=690188 ---Test result--- Test Summary: CheckPatch PASS 1.40 seconds GitLint PASS 0.89 seconds SubjectPrefix PASS 0.62 seconds BuildKernel PASS 41.75 seconds BuildKernel32 PASS 36.54 seconds Incremental Build with patchesPASS 56.77 seconds TestRunner: Setup PASS 607.79 seconds TestRunner: l2cap-tester PASS 19.67 seconds TestRunner: iso-tester PASS 19.76 seconds TestRunner: bnep-tester PASS 7.30 seconds TestRunner: mgmt-tester PASS 127.25 seconds TestRunner: rfcomm-tester PASS 13.28 seconds TestRunner: sco-tester PASS 12.15 seconds TestRunner: ioctl-tester PASS 14.10 seconds TestRunner: mesh-tester PASS 9.79 seconds TestRunner: smp-tester PASS 10.80 seconds TestRunner: userchan-tester PASS 7.76 seconds --- Regards, Linux Bluetooth
Dear Kang, Thank you for the patch. Am 29.10.22 um 23:40 schrieb Kang Minchul: > This commit replace kmalloc + memset to kzalloc replace*s* (Though starting with “This commit …” is redundant. > for better code readability and simplicity. > > Following messages are related cocci warnings. Maybe: This addresse the cocci warning below. > WARNING: kzalloc should be used for d, instead of kmalloc/memset > > Signed-off-by: Kang Minchul <tegongkang@gmail.com> > --- > V1 -> V2: Change subject prefix > > net/bluetooth/hci_conn.c | 6 ++---- > 1 file changed, 2 insertions(+), 4 deletions(-) > > diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c > index 7a59c4487050..287d313aa312 100644 > --- a/net/bluetooth/hci_conn.c > +++ b/net/bluetooth/hci_conn.c > @@ -824,11 +824,10 @@ static int hci_le_terminate_big(struct hci_dev *hdev, u8 big, u8 bis) > > bt_dev_dbg(hdev, "big 0x%2.2x bis 0x%2.2x", big, bis); > > - d = kmalloc(sizeof(*d), GFP_KERNEL); > + d = kzalloc(sizeof(*d), GFP_KERNEL); > if (!d) > return -ENOMEM; > > - memset(d, 0, sizeof(*d)); > d->big = big; > d->bis = bis; > > @@ -861,11 +860,10 @@ static int hci_le_big_terminate(struct hci_dev *hdev, u8 big, u16 sync_handle) > > bt_dev_dbg(hdev, "big 0x%2.2x sync_handle 0x%4.4x", big, sync_handle); > > - d = kmalloc(sizeof(*d), GFP_KERNEL); > + d = kzalloc(sizeof(*d), GFP_KERNEL); > if (!d) > return -ENOMEM; > > - memset(d, 0, sizeof(*d)); > d->big = big; > d->sync_handle = sync_handle; Reviewed-by: Paul Menzel <pmenzel@molgen.mpg.de> Kind regards, Paul
> Am 29.10.22 um 23:40 schrieb Kang Minchul: > > This commit replace kmalloc + memset to kzalloc > > replace*s* > > (Though starting with “This commit …” is redundant. > > > for better code readability and simplicity. > > > > Following messages are related cocci warnings. > > Maybe: This addresse the cocci warning below. > > > WARNING: kzalloc should be used for d, instead of kmalloc/memset > > > > Signed-off-by: Kang Minchul <tegongkang@gmail.com> > > --- > > V1 -> V2: Change subject prefix > > > > net/bluetooth/hci_conn.c | 6 ++---- > > 1 file changed, 2 insertions(+), 4 deletions(-) > > > > diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c > > index 7a59c4487050..287d313aa312 100644 > > --- a/net/bluetooth/hci_conn.c > > +++ b/net/bluetooth/hci_conn.c > > @@ -824,11 +824,10 @@ static int hci_le_terminate_big(struct hci_dev *hdev, u8 big, u8 bis) > > > > bt_dev_dbg(hdev, "big 0x%2.2x bis 0x%2.2x", big, bis); > > > > - d = kmalloc(sizeof(*d), GFP_KERNEL); > > + d = kzalloc(sizeof(*d), GFP_KERNEL); > > if (!d) > > return -ENOMEM; > > > > - memset(d, 0, sizeof(*d)); > > d->big = big; > > d->bis = bis; > > > > @@ -861,11 +860,10 @@ static int hci_le_big_terminate(struct hci_dev *hdev, u8 big, u16 sync_handle) > > > > bt_dev_dbg(hdev, "big 0x%2.2x sync_handle 0x%4.4x", big, sync_handle); > > > > - d = kmalloc(sizeof(*d), GFP_KERNEL); > > + d = kzalloc(sizeof(*d), GFP_KERNEL); > > if (!d) > > return -ENOMEM; > > > > - memset(d, 0, sizeof(*d)); > > d->big = big; > > d->sync_handle = sync_handle; > > Reviewed-by: Paul Menzel <pmenzel@molgen.mpg.de> > > > Kind regards, > > Paul Thank you so much for your feedback! Should I amend the previous commit message and resend PATCH v3? regards, Kang Minchul
I just amended the message and sent patch v3. Again, thanks for the feedback. regards, Kang Minchul
diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c index 7a59c4487050..287d313aa312 100644 --- a/net/bluetooth/hci_conn.c +++ b/net/bluetooth/hci_conn.c @@ -824,11 +824,10 @@ static int hci_le_terminate_big(struct hci_dev *hdev, u8 big, u8 bis) bt_dev_dbg(hdev, "big 0x%2.2x bis 0x%2.2x", big, bis); - d = kmalloc(sizeof(*d), GFP_KERNEL); + d = kzalloc(sizeof(*d), GFP_KERNEL); if (!d) return -ENOMEM; - memset(d, 0, sizeof(*d)); d->big = big; d->bis = bis; @@ -861,11 +860,10 @@ static int hci_le_big_terminate(struct hci_dev *hdev, u8 big, u16 sync_handle) bt_dev_dbg(hdev, "big 0x%2.2x sync_handle 0x%4.4x", big, sync_handle); - d = kmalloc(sizeof(*d), GFP_KERNEL); + d = kzalloc(sizeof(*d), GFP_KERNEL); if (!d) return -ENOMEM; - memset(d, 0, sizeof(*d)); d->big = big; d->sync_handle = sync_handle;
This commit replace kmalloc + memset to kzalloc for better code readability and simplicity. Following messages are related cocci warnings. WARNING: kzalloc should be used for d, instead of kmalloc/memset Signed-off-by: Kang Minchul <tegongkang@gmail.com> --- V1 -> V2: Change subject prefix net/bluetooth/hci_conn.c | 6 ++---- 1 file changed, 2 insertions(+), 4 deletions(-)