Message ID | 20221226155029.244355-6-mcanal@igalia.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Convert drivers to the new debugfs device-centered functions | expand |
On Mon, Dec 26, 2022 at 12:50:25PM -0300, Maíra Canal wrote: > Replace the use of drm_debugfs_create_files() with the new > drm_debugfs_add_file() function, which center the debugfs files > management on the drm_device instead of drm_minor. Moreover, remove the > debugfs_init hook and add the debugfs files directly on arcpgu_probe(), > before drm_dev_register(). > > Signed-off-by: Maíra Canal <mcanal@igalia.com> > --- > drivers/gpu/drm/tiny/arcpgu.c | 22 ++++++---------------- > 1 file changed, 6 insertions(+), 16 deletions(-) > > diff --git a/drivers/gpu/drm/tiny/arcpgu.c b/drivers/gpu/drm/tiny/arcpgu.c > index 611bbee15071..b074a0b4c7b3 100644 > --- a/drivers/gpu/drm/tiny/arcpgu.c > +++ b/drivers/gpu/drm/tiny/arcpgu.c > @@ -338,8 +338,8 @@ static int arcpgu_unload(struct drm_device *drm) > #ifdef CONFIG_DEBUG_FS > static int arcpgu_show_pxlclock(struct seq_file *m, void *arg) > { > - struct drm_info_node *node = (struct drm_info_node *)m->private; > - struct drm_device *drm = node->minor->dev; > + struct drm_debugfs_entry *entry = m->private; > + struct drm_device *drm = entry->dev; > struct arcpgu_drm_private *arcpgu = dev_to_arcpgu(drm); > unsigned long clkrate = clk_get_rate(arcpgu->clk); > unsigned long mode_clock = arcpgu->pipe.crtc.mode.crtc_clock * 1000; > @@ -348,17 +348,6 @@ static int arcpgu_show_pxlclock(struct seq_file *m, void *arg) > seq_printf(m, "mode: %lu\n", mode_clock); > return 0; > } > - > -static struct drm_info_list arcpgu_debugfs_list[] = { > - { "clocks", arcpgu_show_pxlclock, 0 }, > -}; > - > -static void arcpgu_debugfs_init(struct drm_minor *minor) > -{ > - drm_debugfs_create_files(arcpgu_debugfs_list, > - ARRAY_SIZE(arcpgu_debugfs_list), > - minor->debugfs_root, minor); > -} > #endif > > static const struct drm_driver arcpgu_drm_driver = { > @@ -371,9 +360,6 @@ static const struct drm_driver arcpgu_drm_driver = { > .patchlevel = 0, > .fops = &arcpgu_drm_ops, > DRM_GEM_DMA_DRIVER_OPS, > -#ifdef CONFIG_DEBUG_FS > - .debugfs_init = arcpgu_debugfs_init, > -#endif > }; > > static int arcpgu_probe(struct platform_device *pdev) > @@ -390,6 +376,10 @@ static int arcpgu_probe(struct platform_device *pdev) > if (ret) > return ret; > > +#ifdef CONFIG_DEBUG_FS > + drm_debugfs_add_file(&arcpgu->drm, "clocks", arcpgu_show_pxlclock, NULL); > +#endif A pure bikeshed, but I think it's cleaner to drop the #ifdef here and above and mark the potentially unused functions as __maybe_unused. With or without that: Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch> > + > ret = drm_dev_register(&arcpgu->drm, 0); > if (ret) > goto err_unload; > -- > 2.38.1 >
diff --git a/drivers/gpu/drm/tiny/arcpgu.c b/drivers/gpu/drm/tiny/arcpgu.c index 611bbee15071..b074a0b4c7b3 100644 --- a/drivers/gpu/drm/tiny/arcpgu.c +++ b/drivers/gpu/drm/tiny/arcpgu.c @@ -338,8 +338,8 @@ static int arcpgu_unload(struct drm_device *drm) #ifdef CONFIG_DEBUG_FS static int arcpgu_show_pxlclock(struct seq_file *m, void *arg) { - struct drm_info_node *node = (struct drm_info_node *)m->private; - struct drm_device *drm = node->minor->dev; + struct drm_debugfs_entry *entry = m->private; + struct drm_device *drm = entry->dev; struct arcpgu_drm_private *arcpgu = dev_to_arcpgu(drm); unsigned long clkrate = clk_get_rate(arcpgu->clk); unsigned long mode_clock = arcpgu->pipe.crtc.mode.crtc_clock * 1000; @@ -348,17 +348,6 @@ static int arcpgu_show_pxlclock(struct seq_file *m, void *arg) seq_printf(m, "mode: %lu\n", mode_clock); return 0; } - -static struct drm_info_list arcpgu_debugfs_list[] = { - { "clocks", arcpgu_show_pxlclock, 0 }, -}; - -static void arcpgu_debugfs_init(struct drm_minor *minor) -{ - drm_debugfs_create_files(arcpgu_debugfs_list, - ARRAY_SIZE(arcpgu_debugfs_list), - minor->debugfs_root, minor); -} #endif static const struct drm_driver arcpgu_drm_driver = { @@ -371,9 +360,6 @@ static const struct drm_driver arcpgu_drm_driver = { .patchlevel = 0, .fops = &arcpgu_drm_ops, DRM_GEM_DMA_DRIVER_OPS, -#ifdef CONFIG_DEBUG_FS - .debugfs_init = arcpgu_debugfs_init, -#endif }; static int arcpgu_probe(struct platform_device *pdev) @@ -390,6 +376,10 @@ static int arcpgu_probe(struct platform_device *pdev) if (ret) return ret; +#ifdef CONFIG_DEBUG_FS + drm_debugfs_add_file(&arcpgu->drm, "clocks", arcpgu_show_pxlclock, NULL); +#endif + ret = drm_dev_register(&arcpgu->drm, 0); if (ret) goto err_unload;
Replace the use of drm_debugfs_create_files() with the new drm_debugfs_add_file() function, which center the debugfs files management on the drm_device instead of drm_minor. Moreover, remove the debugfs_init hook and add the debugfs files directly on arcpgu_probe(), before drm_dev_register(). Signed-off-by: Maíra Canal <mcanal@igalia.com> --- drivers/gpu/drm/tiny/arcpgu.c | 22 ++++++---------------- 1 file changed, 6 insertions(+), 16 deletions(-)