Message ID | 20230105132457.4125372-4-treapking@chromium.org (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | Register Type-C mode-switch in DP bridge endpoints | expand |
On Thu, Jan 05, 2023 at 09:24:51PM +0800, Pin-yen Lin wrote: > Add helpers to register and unregister Type-C "switches" for bridges > capable of switching their output between two downstream devices. > > The helper registers USB Type-C mode switches when the "mode-switch" > and the "data-lanes" properties are available in Device Tree. ... > + port_data->typec_mux = typec_mux_register(dev, &mux_desc); > + if (IS_ERR(port_data->typec_mux)) { > + ret = PTR_ERR(port_data->typec_mux); > + dev_err(dev, "Mode switch register for port %d failed: %d\n", > + port_num, ret); > + } > + > + return ret; ... > + struct device_node *sw; > + int ret = 0; It's easy to break things if you squeeze more code in the future in this function, so I recommend to split assignment to be closer to its first user (see below). > + for_each_child_of_node(port, sw) { > + if (of_property_read_bool(sw, "mode-switch")) > + switch_desc->num_typec_switches++; > + } > + > + if (!switch_desc->num_typec_switches) { > + dev_warn(dev, "No Type-C switches node found\n"); > + return ret; return 0; > + } > + > + switch_desc->typec_ports = devm_kcalloc( > + dev, switch_desc->num_typec_switches, > + sizeof(struct drm_dp_typec_port_data), GFP_KERNEL); > + > + if (!switch_desc->typec_ports) > + return -ENOMEM; > + /* Register switches for each connector. */ > + for_each_child_of_node(port, sw) { > + if (!of_property_read_bool(sw, "mode-switch")) > + continue; > + ret = drm_dp_register_mode_switch(dev, sw, switch_desc, data, mux_set); > + if (ret) { > + dev_err(dev, "Failed to register mode switch: %d\n", ret); > + of_node_put(sw); > + break; > + } > + } > + if (ret) > + drm_dp_unregister_typec_switches(switch_desc); > + > + return ret; Why not adding a goto label? ret = drm_dp_register_mode_switch(dev, sw, switch_desc, data, mux_set); if (ret) goto err_unregister_typec_switches; return 0; err_unregister_typec_switches: of_node_put(sw); drm_dp_unregister_typec_switches(switch_desc); dev_err(dev, "Failed to register mode switch: %d\n", ret); return ret;
Hi Pin-yen, Thank you for the patch! Yet something to improve: [auto build test ERROR on drm-misc/drm-misc-next] [also build test ERROR on driver-core/driver-core-testing driver-core/driver-core-next driver-core/driver-core-linus chrome-platform/for-next drm/drm-next linus/master v6.2-rc2 next-20230105] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submitting patch, we suggest to use '--base' as documented in https://git-scm.com/docs/git-format-patch#_base_tree_information] url: https://github.com/intel-lab-lkp/linux/commits/Pin-yen-Lin/device-property-Add-remote-endpoint-to-devcon-matcher/20230105-212902 base: git://anongit.freedesktop.org/drm/drm-misc drm-misc-next patch link: https://lore.kernel.org/r/20230105132457.4125372-4-treapking%40chromium.org patch subject: [PATCH v7 3/9] drm/display: Add Type-C switch helpers config: arm-defconfig compiler: arm-linux-gnueabi-gcc (GCC) 12.1.0 reproduce (this is a W=1 build): wget https://raw.githubusercontent.com/intel/lkp-tests/master/sbin/make.cross -O ~/bin/make.cross chmod +x ~/bin/make.cross # https://github.com/intel-lab-lkp/linux/commit/c037bdca262df88564fff58cb5233d50180c7215 git remote add linux-review https://github.com/intel-lab-lkp/linux git fetch --no-tags linux-review Pin-yen-Lin/device-property-Add-remote-endpoint-to-devcon-matcher/20230105-212902 git checkout c037bdca262df88564fff58cb5233d50180c7215 # save the config file mkdir build_dir && cp config build_dir/.config COMPILER_INSTALL_PATH=$HOME/0day COMPILER=gcc-12.1.0 make.cross W=1 O=build_dir ARCH=arm olddefconfig COMPILER_INSTALL_PATH=$HOME/0day COMPILER=gcc-12.1.0 make.cross W=1 O=build_dir ARCH=arm SHELL=/bin/bash If you fix the issue, kindly add following tag where applicable | Reported-by: kernel test robot <lkp@intel.com> All errors (new ones prefixed by >>): arm-linux-gnueabi-ld: drivers/gpu/drm/display/drm_dp_helper.o: in function `drm_dp_unregister_typec_switches': >> drm_dp_helper.c:(.text+0x1298): undefined reference to `typec_mux_unregister' arm-linux-gnueabi-ld: drivers/gpu/drm/display/drm_dp_helper.o: in function `drm_dp_register_typec_switches': >> drm_dp_helper.c:(.text+0x160c): undefined reference to `typec_mux_register' >> arm-linux-gnueabi-ld: drm_dp_helper.c:(.text+0x16e8): undefined reference to `typec_mux_unregister'
Hi Andy, Thanks for the review. On Thu, Jan 5, 2023 at 11:41 PM Andy Shevchenko <andriy.shevchenko@linux.intel.com> wrote: > > On Thu, Jan 05, 2023 at 09:24:51PM +0800, Pin-yen Lin wrote: > > Add helpers to register and unregister Type-C "switches" for bridges > > capable of switching their output between two downstream devices. > > > > The helper registers USB Type-C mode switches when the "mode-switch" > > and the "data-lanes" properties are available in Device Tree. > > ... > > > + port_data->typec_mux = typec_mux_register(dev, &mux_desc); > > + if (IS_ERR(port_data->typec_mux)) { > > + ret = PTR_ERR(port_data->typec_mux); > > + dev_err(dev, "Mode switch register for port %d failed: %d\n", > > + port_num, ret); > > + } > > + > > + return ret; > > ... > > > + struct device_node *sw; > > > + int ret = 0; > > It's easy to break things if you squeeze more code in the future in this > function, so I recommend to split assignment to be closer to its first user > (see below). > > > + for_each_child_of_node(port, sw) { > > + if (of_property_read_bool(sw, "mode-switch")) > > + switch_desc->num_typec_switches++; > > + } > > + > > + if (!switch_desc->num_typec_switches) { > > + dev_warn(dev, "No Type-C switches node found\n"); > > > + return ret; > > return 0; Thanks for the suggestion. I'll update this in v8. > > > + } > > + > > + switch_desc->typec_ports = devm_kcalloc( > > + dev, switch_desc->num_typec_switches, > > + sizeof(struct drm_dp_typec_port_data), GFP_KERNEL); > > + > > + if (!switch_desc->typec_ports) > > + return -ENOMEM; > > > + /* Register switches for each connector. */ > > + for_each_child_of_node(port, sw) { > > + if (!of_property_read_bool(sw, "mode-switch")) > > + continue; > > + ret = drm_dp_register_mode_switch(dev, sw, switch_desc, data, mux_set); > > + if (ret) { > > + dev_err(dev, "Failed to register mode switch: %d\n", ret); > > + of_node_put(sw); > > + break; > > + } > > + } > > > + if (ret) > > + drm_dp_unregister_typec_switches(switch_desc); > > + > > + return ret; > > Why not adding a goto label? I didn't know that goto label is preferred even when there are no duplicated code blocks in the function. I'll update this accordingly in v8. > > ret = drm_dp_register_mode_switch(dev, sw, switch_desc, data, mux_set); > if (ret) > goto err_unregister_typec_switches; > > return 0; > > err_unregister_typec_switches: > of_node_put(sw); > drm_dp_unregister_typec_switches(switch_desc); > dev_err(dev, "Failed to register mode switch: %d\n", ret); > return ret; > > -- > With Best Regards, > Andy Shevchenko > > Best regards, Pin-yen
diff --git a/drivers/gpu/drm/display/drm_dp_helper.c b/drivers/gpu/drm/display/drm_dp_helper.c index 16565a0a5da6..02a026f905ec 100644 --- a/drivers/gpu/drm/display/drm_dp_helper.c +++ b/drivers/gpu/drm/display/drm_dp_helper.c @@ -30,11 +30,13 @@ #include <linux/sched.h> #include <linux/seq_file.h> #include <linux/string_helpers.h> +#include <linux/usb/typec_mux.h> #include <linux/dynamic_debug.h> #include <drm/display/drm_dp_helper.h> #include <drm/display/drm_dp_mst_helper.h> #include <drm/drm_edid.h> +#include <drm/drm_of.h> #include <drm/drm_print.h> #include <drm/drm_vblank.h> #include <drm/drm_panel.h> @@ -3891,3 +3893,133 @@ int drm_panel_dp_aux_backlight(struct drm_panel *panel, struct drm_dp_aux *aux) EXPORT_SYMBOL(drm_panel_dp_aux_backlight); #endif + +#if IS_ENABLED(CONFIG_TYPEC) +static int drm_dp_register_mode_switch(struct device *dev, struct device_node *node, + struct drm_dp_typec_switch_desc *switch_desc, + void *data, void *mux_set) +{ + struct drm_dp_typec_port_data *port_data; + struct typec_mux_desc mux_desc = {}; + char name[32]; + u32 dp_lanes[2]; + int ret, num_lanes, port_num = -1; + + num_lanes = drm_of_get_data_lanes_count(node, 0, 2); + if (num_lanes <= 0) { + dev_err(dev, "Error on getting data lanes count: %d\n", + num_lanes); + return num_lanes; + } + + ret = of_property_read_u32_array(node, "data-lanes", dp_lanes, num_lanes); + if (ret) { + dev_err(dev, "Failed to read the data-lanes variable: %d\n", + ret); + return ret; + } + + port_num = dp_lanes[0] / 2; + + port_data = &switch_desc->typec_ports[port_num]; + port_data->data = data; + mux_desc.fwnode = &node->fwnode; + mux_desc.drvdata = port_data; + snprintf(name, sizeof(name), "%s-%u", node->name, port_num); + mux_desc.name = name; + mux_desc.set = mux_set; + + port_data->typec_mux = typec_mux_register(dev, &mux_desc); + if (IS_ERR(port_data->typec_mux)) { + ret = PTR_ERR(port_data->typec_mux); + dev_err(dev, "Mode switch register for port %d failed: %d\n", + port_num, ret); + } + + return ret; +} + +/** + * drm_dp_register_typec_switches() - register Type-C switches + * @dev: Device that registers Type-C switches + * @port: Device node for the switch + * @switch_desc: A Type-C switch descriptor + * @data: Private data for the switches + * @mux_set: Callback function for typec_mux_set + * + * This function registers USB Type-C switches for DP bridges that can switch + * the output signal between their output pins. + * + * Currently only mode switches are implemented, and the function assumes the + * given @port device node has endpoints with "mode-switch" property. + * Register the endpoint as port 0 if the "data-lanes" property falls in 0/1, + * and register it as port 1 if "data-lanes" falls in 2/3. + */ +int drm_dp_register_typec_switches(struct device *dev, struct device_node *port, + struct drm_dp_typec_switch_desc *switch_desc, + void *data, void *mux_set) +{ + struct device_node *sw; + int ret = 0; + + for_each_child_of_node(port, sw) { + if (of_property_read_bool(sw, "mode-switch")) + switch_desc->num_typec_switches++; + } + + if (!switch_desc->num_typec_switches) { + dev_warn(dev, "No Type-C switches node found\n"); + return ret; + } + + switch_desc->typec_ports = devm_kcalloc( + dev, switch_desc->num_typec_switches, + sizeof(struct drm_dp_typec_port_data), GFP_KERNEL); + + if (!switch_desc->typec_ports) + return -ENOMEM; + + /* Register switches for each connector. */ + for_each_child_of_node(port, sw) { + if (!of_property_read_bool(sw, "mode-switch")) + continue; + ret = drm_dp_register_mode_switch(dev, sw, switch_desc, data, mux_set); + if (ret) { + dev_err(dev, "Failed to register mode switch: %d\n", ret); + of_node_put(sw); + break; + } + } + + if (ret) + drm_dp_unregister_typec_switches(switch_desc); + + return ret; +} +EXPORT_SYMBOL(drm_dp_register_typec_switches); + +/** + * drm_dp_unregister_typec_switches() - unregister Type-C switches + * @switch_desc: A Type-C switch descriptor + */ +void drm_dp_unregister_typec_switches(struct drm_dp_typec_switch_desc *switch_desc) +{ + int i; + + for (i = 0; i < switch_desc->num_typec_switches; i++) + typec_mux_unregister(switch_desc->typec_ports[i].typec_mux); +} +EXPORT_SYMBOL(drm_dp_unregister_typec_switches); +#else +void drm_dp_unregister_typec_switches(struct drm_dp_typec_switch_desc *switch_desc) +{ +} +EXPORT_SYMBOL(drm_dp_register_typec_switches); +int drm_dp_register_typec_switches(struct device *dev, struct device_node *port, + struct drm_dp_typec_switch_desc *switch_desc, + void *data, void *mux_set) +{ + return 0; +} +EXPORT_SYMBOL(drm_dp_unregister_typec_switches); +#endif diff --git a/include/drm/display/drm_dp_helper.h b/include/drm/display/drm_dp_helper.h index ab55453f2d2c..fef0a9a0d8ea 100644 --- a/include/drm/display/drm_dp_helper.h +++ b/include/drm/display/drm_dp_helper.h @@ -763,4 +763,20 @@ bool drm_dp_downstream_rgb_to_ycbcr_conversion(const u8 dpcd[DP_RECEIVER_CAP_SIZ const u8 port_cap[4], u8 color_spc); int drm_dp_pcon_convert_rgb_to_ycbcr(struct drm_dp_aux *aux, u8 color_spc); +struct drm_dp_typec_port_data { + struct typec_mux_dev *typec_mux; + void *data; + bool dp_connected; +}; + +struct drm_dp_typec_switch_desc { + int num_typec_switches; + struct drm_dp_typec_port_data *typec_ports; +}; + +void drm_dp_unregister_typec_switches(struct drm_dp_typec_switch_desc *switch_desc); +int drm_dp_register_typec_switches(struct device *dev, struct device_node *port, + struct drm_dp_typec_switch_desc *switch_desc, + void *data, void *mux_set); + #endif /* _DRM_DP_HELPER_H_ */
Add helpers to register and unregister Type-C "switches" for bridges capable of switching their output between two downstream devices. The helper registers USB Type-C mode switches when the "mode-switch" and the "data-lanes" properties are available in Device Tree. Signed-off-by: Pin-yen Lin <treapking@chromium.org> --- Changes in v7: - Extracted the common codes to a helper function - New in v7 drivers/gpu/drm/display/drm_dp_helper.c | 132 ++++++++++++++++++++++++ include/drm/display/drm_dp_helper.h | 16 +++ 2 files changed, 148 insertions(+)