diff mbox series

common/rc: drop SGI DMF specific _mount_ops_filter

Message ID 20230110222243.6522-1-ddiss@suse.de (mailing list archive)
State New, archived
Headers show
Series common/rc: drop SGI DMF specific _mount_ops_filter | expand

Commit Message

David Disseldorp Jan. 10, 2023, 10:22 p.m. UTC
The _mount() helper function is the only caller of _mount_ops_filter(),
which appears to have been used in the past to replace the SGI DMF
specific mtpt= mount option setting.

_mount() invocations could now be replaced with $MOUNT_PROG calls
directly, but I've retained the helper function for readability.

Link: https://irix7.com/techpubs/007-3683-007.pdf
Signed-off-by: David Disseldorp <ddiss@suse.de>
---
 common/rc | 15 +--------------
 1 file changed, 1 insertion(+), 14 deletions(-)

Comments

Zorro Lang Jan. 11, 2023, 9:56 a.m. UTC | #1
On Tue, Jan 10, 2023 at 11:22:43PM +0100, David Disseldorp wrote:
> The _mount() helper function is the only caller of _mount_ops_filter(),
> which appears to have been used in the past to replace the SGI DMF
> specific mtpt= mount option setting.
> 
> _mount() invocations could now be replaced with $MOUNT_PROG calls
> directly, but I've retained the helper function for readability.
> 
> Link: https://irix7.com/techpubs/007-3683-007.pdf
> Signed-off-by: David Disseldorp <ddiss@suse.de>
> ---

This makes sense to me. Likes we've removed dmapi things, this "-o mtpt"
support can be removed too.

The _mount_ops_filter() might can be brought back if we need a filter
for _mount() in one day, I think that's another story. Now let's remove
it if it's useless.

Reviewed-by: Zorro Lang <zlang@redhat.com>

>  common/rc | 15 +--------------
>  1 file changed, 1 insertion(+), 14 deletions(-)
> 
> diff --git a/common/rc b/common/rc
> index 23530413..81ce1026 100644
> --- a/common/rc
> +++ b/common/rc
> @@ -120,7 +120,7 @@ _get_hugepagesize()
>  
>  _mount()
>  {
> -    $MOUNT_PROG `_mount_ops_filter $*`
> +    $MOUNT_PROG $*
>  }
>  
>  # Call _mount to do mount operation but also save mountpoint to
> @@ -211,19 +211,6 @@ _test_options()
>  	TEST_OPTIONS="$TEST_OPTIONS ${log_opt}logdev=$TEST_LOGDEV"
>  }
>  
> -_mount_ops_filter()
> -{
> -    local params="$*"
> -    local last_index=$(( $# - 1 ))
> -
> -    [ $last_index -gt 0 ] && shift $last_index
> -    local fs_escaped=$1
> -
> -    echo $params | \
> -        $PERL_PROG -ne "s#mtpt=[^,|^\n|^\s]*#mtpt=$fs_escaped\1\2#; print;"
> -
> -}
> -
>  # Used for mounting non-scratch devices (e.g. loop, dm constructs)
>  # with the safe set of scratch mount options (e.g. loop image may be
>  # hosted on $SCRATCH_DEV, so can't use external scratch devices).
> -- 
> 2.35.3
>
diff mbox series

Patch

diff --git a/common/rc b/common/rc
index 23530413..81ce1026 100644
--- a/common/rc
+++ b/common/rc
@@ -120,7 +120,7 @@  _get_hugepagesize()
 
 _mount()
 {
-    $MOUNT_PROG `_mount_ops_filter $*`
+    $MOUNT_PROG $*
 }
 
 # Call _mount to do mount operation but also save mountpoint to
@@ -211,19 +211,6 @@  _test_options()
 	TEST_OPTIONS="$TEST_OPTIONS ${log_opt}logdev=$TEST_LOGDEV"
 }
 
-_mount_ops_filter()
-{
-    local params="$*"
-    local last_index=$(( $# - 1 ))
-
-    [ $last_index -gt 0 ] && shift $last_index
-    local fs_escaped=$1
-
-    echo $params | \
-        $PERL_PROG -ne "s#mtpt=[^,|^\n|^\s]*#mtpt=$fs_escaped\1\2#; print;"
-
-}
-
 # Used for mounting non-scratch devices (e.g. loop, dm constructs)
 # with the safe set of scratch mount options (e.g. loop image may be
 # hosted on $SCRATCH_DEV, so can't use external scratch devices).