diff mbox series

[v2,2/6] riscv: Rename Kconfig.erratas to Kconfig.errata

Message ID 20230224154601.88163-3-ajones@ventanamicro.com (mailing list archive)
State Accepted
Commit a3d095ac00faee0deb575ba053f0567b0d124d0b
Headers show
Series riscv: alternative/cpufeature related cleanups | expand

Checks

Context Check Description
conchuod/cover_letter success Series has a cover letter
conchuod/tree_selection success Guessed tree name to be for-next
conchuod/fixes_present success Fixes tag not required for -next series
conchuod/maintainers_pattern success MAINTAINERS pattern errors before the patch: 13 and now 13
conchuod/verify_signedoff success Signed-off-by tag matches author and committer
conchuod/kdoc success Errors and warnings before: 0 this patch: 0
conchuod/build_rv64_clang_allmodconfig success Errors and warnings before: 0 this patch: 0
conchuod/module_param success Was 0 now: 0
conchuod/build_rv64_gcc_allmodconfig success Errors and warnings before: 0 this patch: 0
conchuod/alphanumeric_selects success Out of order selects before the patch: 729 and now 729
conchuod/build_rv32_defconfig success Build OK
conchuod/dtb_warn_rv64 success Errors and warnings before: 2 this patch: 2
conchuod/header_inline success No static functions without inline keyword in header files
conchuod/checkpatch warning WARNING: It's generally not useful to have the filename in the file WARNING: added, moved or deleted file(s), does MAINTAINERS need updating?
conchuod/source_inline success Was 0 now: 0
conchuod/build_rv64_nommu_k210_defconfig success Build OK
conchuod/verify_fixes success No Fixes tag
conchuod/build_rv64_nommu_virt_defconfig success Build OK

Commit Message

Andrew Jones Feb. 24, 2023, 3:45 p.m. UTC
Errata is already plural for erratum. Rename it to make the
grammar gooder.

Signed-off-by: Andrew Jones <ajones@ventanamicro.com>
Reviewed-by: Conor Dooley <conor.dooley@microchip.com>
Reviewed-by: Heiko Stuebner <heiko.stuebner@vrull.eu>
---
 arch/riscv/Kconfig                             | 2 +-
 arch/riscv/{Kconfig.erratas => Kconfig.errata} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename arch/riscv/{Kconfig.erratas => Kconfig.errata} (100%)

Comments

Ben Dooks Feb. 24, 2023, 3:53 p.m. UTC | #1
On 24/02/2023 15:45, Andrew Jones wrote:
> Errata is already plural for erratum. Rename it to make the
> grammar gooder.

gooder o_o

let's just go emjoi (╯°□°)╯︵ ┻━┻
Palmer Dabbelt March 15, 2023, 4:35 a.m. UTC | #2
On Fri, 24 Feb 2023 07:53:48 PST (-0800), ben.dooks@codethink.co.uk wrote:
> On 24/02/2023 15:45, Andrew Jones wrote:
>> Errata is already plural for erratum. Rename it to make the
>> grammar gooder.
>
> gooder o_o

Thanks, this one bugged me every time I saw it.

>
> let's just go emjoi (╯°□°)╯︵ ┻━┻
>
> -- 
> Ben Dooks				http://www.codethink.co.uk/
> Senior Engineer				Codethink - Providing Genius
>
> https://www.codethink.co.uk/privacy.html
>
>
> _______________________________________________
> linux-riscv mailing list
> linux-riscv@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-riscv
diff mbox series

Patch

diff --git a/arch/riscv/Kconfig b/arch/riscv/Kconfig
index eb087e17c91b..80bc960706e3 100644
--- a/arch/riscv/Kconfig
+++ b/arch/riscv/Kconfig
@@ -246,7 +246,7 @@  config AS_HAS_INSN
 	def_bool $(as-instr,.insn r 51$(comma) 0$(comma) 0$(comma) t0$(comma) t0$(comma) zero)
 
 source "arch/riscv/Kconfig.socs"
-source "arch/riscv/Kconfig.erratas"
+source "arch/riscv/Kconfig.errata"
 
 menu "Platform type"
 
diff --git a/arch/riscv/Kconfig.erratas b/arch/riscv/Kconfig.errata
similarity index 100%
rename from arch/riscv/Kconfig.erratas
rename to arch/riscv/Kconfig.errata