mbox series

[v2,0/6] riscv: alternative/cpufeature related cleanups

Message ID 20230224154601.88163-1-ajones@ventanamicro.com (mailing list archive)
Headers show
Series riscv: alternative/cpufeature related cleanups | expand

Message

Andrew Jones Feb. 24, 2023, 3:45 p.m. UTC
This series has no intended functional change. These cleanups were
found while renaming errata_id to patch_id in order to better
convey that its purpose is larger than errata (it's also for
cpufeatures).

Based on riscv-linux/for-next

Thanks,
drew

v2:
  - Rebased on latest riscv-linux/for-next
  - Add a new patch to reword the help text for RISCV_ALTERNATIVE
    as suggested by Conor
  - Snuck a comment cleanup into the errata_id -> patch_id patch
  - Reworded commit message of the last patch [Conor]
  - picked up R-b's from Conor and Heiko

Andrew Jones (6):
  riscv: Clarify RISCV_ALTERNATIVE help text
  riscv: Rename Kconfig.erratas to Kconfig.errata
  riscv: alternatives: Remove unnecessary define and unused struct
  riscv: alternatives: Rename errata_id to patch_id
  riscv: lib: Include hwcap.h directly
  riscv: cpufeature: Drop errata_list.h and other unused includes

 arch/riscv/Kconfig                            |  8 +--
 .../riscv/{Kconfig.erratas => Kconfig.errata} |  0
 arch/riscv/errata/sifive/errata.c             |  8 +--
 arch/riscv/errata/thead/errata.c              |  4 +-
 arch/riscv/include/asm/alternative-macros.h   | 72 +++++++++----------
 arch/riscv/include/asm/alternative.h          | 11 +--
 arch/riscv/kernel/cpufeature.c                | 11 +--
 arch/riscv/lib/strcmp.S                       |  3 +-
 arch/riscv/lib/strlen.S                       |  3 +-
 arch/riscv/lib/strncmp.S                      |  3 +-
 10 files changed, 54 insertions(+), 69 deletions(-)
 rename arch/riscv/{Kconfig.erratas => Kconfig.errata} (100%)

Comments

patchwork-bot+linux-riscv@kernel.org March 18, 2023, 1 a.m. UTC | #1
Hello:

This series was applied to riscv/linux.git (for-next)
by Palmer Dabbelt <palmer@rivosinc.com>:

On Fri, 24 Feb 2023 16:45:55 +0100 you wrote:
> This series has no intended functional change. These cleanups were
> found while renaming errata_id to patch_id in order to better
> convey that its purpose is larger than errata (it's also for
> cpufeatures).
> 
> Based on riscv-linux/for-next
> 
> [...]

Here is the summary with links:
  - [v2,1/6] riscv: Clarify RISCV_ALTERNATIVE help text
    https://git.kernel.org/riscv/c/099122af4e29
  - [v2,2/6] riscv: Rename Kconfig.erratas to Kconfig.errata
    https://git.kernel.org/riscv/c/a3d095ac00fa
  - [v2,3/6] riscv: alternatives: Remove unnecessary define and unused struct
    https://git.kernel.org/riscv/c/ce06b42a4a96
  - [v2,4/6] riscv: alternatives: Rename errata_id to patch_id
    https://git.kernel.org/riscv/c/ff19a8dee196
  - [v2,5/6] riscv: lib: Include hwcap.h directly
    https://git.kernel.org/riscv/c/28ea374da1d9
  - [v2,6/6] riscv: cpufeature: Drop errata_list.h and other unused includes
    https://git.kernel.org/riscv/c/816a69744102

You are awesome, thank you!