diff mbox series

[RESEND,v2] usb: dwc3: remove dead code in dwc3_otg_get_irq

Message ID 20230425015532.13622-1-lihuya@hust.edu.cn (mailing list archive)
State New, archived
Headers show
Series [RESEND,v2] usb: dwc3: remove dead code in dwc3_otg_get_irq | expand

Commit Message

Liang Yuhang April 25, 2023, 1:55 a.m. UTC
platform_get_irq() only return non-zero irq number on success, or
negative error number on failure.

There is no need to check the return value of platform_get_irq()
to determine the return value of dwc3_otg_get_irq(), removing
them to solve this problem.

Signed-off-by: Liang Yuhang <lihuya@hust.edu.cn>

---
v1 -> v2: change name to real name
---
 drivers/usb/dwc3/drd.c | 5 -----
 1 file changed, 5 deletions(-)

Comments

Greg KH April 25, 2023, 5:12 a.m. UTC | #1
On Tue, Apr 25, 2023 at 09:55:32AM +0800, Liang Yuhang wrote:
> platform_get_irq() only return non-zero irq number on success, or
> negative error number on failure.
> 
> There is no need to check the return value of platform_get_irq()
> to determine the return value of dwc3_otg_get_irq(), removing
> them to solve this problem.
> 
> Signed-off-by: Liang Yuhang <lihuya@hust.edu.cn>
> 
> ---
> v1 -> v2: change name to real name
> ---
>  drivers/usb/dwc3/drd.c | 5 -----
>  1 file changed, 5 deletions(-)

Why is this a RESEND?  And why is it resent?  You changed something from
v1 to v2, but that does not mean it is a resend.

Note, I STRONGLY encourage people to get experience by working in
drivers/staging/ first, before going out to the rest of the kernel and
dealing with fast-moving subsystems.  Perhaps try that first?

thanks,

greg k-h
diff mbox series

Patch

diff --git a/drivers/usb/dwc3/drd.c b/drivers/usb/dwc3/drd.c
index 039bf241769a..c2e09700212d 100644
--- a/drivers/usb/dwc3/drd.c
+++ b/drivers/usb/dwc3/drd.c
@@ -154,11 +154,6 @@  static int dwc3_otg_get_irq(struct dwc3 *dwc)
 		goto out;
 
 	irq = platform_get_irq(dwc3_pdev, 0);
-	if (irq > 0)
-		goto out;
-
-	if (!irq)
-		irq = -EINVAL;
 
 out:
 	return irq;