mbox series

[net-next,0/9] ptp .adjphase cleanups

Message ID 20230510205306.136766-1-rrameshbabu@nvidia.com (mailing list archive)
Headers show
Series ptp .adjphase cleanups | expand

Message

Rahul Rameshbabu May 10, 2023, 8:52 p.m. UTC
The goal of this patch series is to improve documentation of .adjphase, add
a new callback .getmaxphase to enable advertising the max phase offset a
device PHC can support, and support invoking .adjphase from the testptp
kselftest.

Link: https://lore.kernel.org/netdev/20230120160609.19160723@kernel.org/

Rahul Rameshbabu (9):
  ptp: Clarify ptp_clock_info .adjphase expects an internal servo to be
    used
  docs: ptp.rst: Add information about NVIDIA Mellanox devices
  testptp: Remove magic numbers related to nanosecond to second
    conversion
  testptp: Add support for testing ptp_clock_info .adjphase callback
  ptp: Add .getmaxphase callback to ptp_clock_info
  net/mlx5: Add .getmaxphase ptp_clock_info callback
  ptp: ptp_clockmatrix: Add .getmaxphase ptp_clock_info callback
  ptp: idt82p33: Add .getmaxphase ptp_clock_info callback
  ptp: ocp: Add .getmaxphase ptp_clock_info callback

 Documentation/driver-api/ptp.rst              | 30 ++++++++++++++++
 .../ethernet/mellanox/mlx5/core/lib/clock.c   | 31 ++++++++--------
 drivers/ptp/ptp_chardev.c                     |  5 ++-
 drivers/ptp/ptp_clock.c                       |  4 +++
 drivers/ptp/ptp_clockmatrix.c                 | 36 +++++++++----------
 drivers/ptp/ptp_clockmatrix.h                 |  2 +-
 drivers/ptp/ptp_idt82p33.c                    | 18 +++++-----
 drivers/ptp/ptp_idt82p33.h                    |  4 +--
 drivers/ptp/ptp_ocp.c                         |  7 ++++
 drivers/ptp/ptp_sysfs.c                       | 12 +++++++
 include/linux/ptp_clock_kernel.h              | 11 ++++--
 include/uapi/linux/ptp_clock.h                |  3 +-
 tools/testing/selftests/ptp/testptp.c         | 29 ++++++++++++---
 13 files changed, 136 insertions(+), 56 deletions(-)

Comments

Richard Cochran May 11, 2023, 2:23 a.m. UTC | #1
On Wed, May 10, 2023 at 01:52:57PM -0700, Rahul Rameshbabu wrote:
> The goal of this patch series is to improve documentation of .adjphase, add
> a new callback .getmaxphase to enable advertising the max phase offset a
> device PHC can support, and support invoking .adjphase from the testptp
> kselftest.

Let's make sure to get ACKs on these three...

3600   C 10.May'23 Rahul Rameshbab      ├─>[PATCH net-next 7/9] ptp: ptp_clockmatrix: Add .getmaxphase ptp_clock_info callback
3601   C 10.May'23 Rahul Rameshbab      ├─>[PATCH net-next 8/9] ptp: idt82p33: Add .getmaxphase ptp_clock_info callback
3602   C 10.May'23 Rahul Rameshbab      └─>[PATCH net-next 9/9] ptp: ocp: Add .getmaxphase ptp_clock_info callback

Thanks,
Richard
Rahul Rameshbabu May 11, 2023, 8:26 p.m. UTC | #2
On Wed, 10 May, 2023 19:23:37 -0700 Richard Cochran <richardcochran@gmail.com> wrote:
> On Wed, May 10, 2023 at 01:52:57PM -0700, Rahul Rameshbabu wrote:
>> The goal of this patch series is to improve documentation of .adjphase, add
>> a new callback .getmaxphase to enable advertising the max phase offset a
>> device PHC can support, and support invoking .adjphase from the testptp
>> kselftest.
>
> Let's make sure to get ACKs on these three...
>
> 3600   C 10.May'23 Rahul Rameshbab      ├─>[PATCH net-next 7/9] ptp: ptp_clockmatrix: Add .getmaxphase ptp_clock_info callback
> 3601   C 10.May'23 Rahul Rameshbab      ├─>[PATCH net-next 8/9] ptp: idt82p33: Add .getmaxphase ptp_clock_info callback
> 3602   C 10.May'23 Rahul Rameshbab      └─>[PATCH net-next 9/9] ptp: ocp: Add .getmaxphase ptp_clock_info callback

Yeah, I had a small PEBKAC issue when the git-send-email command was
invoked (still had --suppress-cc in the commandline from test runs in my
shell history)... Will be sure to verify the CCs on each patch when
sending out the v2 for this series.

>
> Thanks,
> Richard
p
-- Rahul Rameshbabu