Message ID | 20230516202430.4157216-6-yazen.ghannam@amd.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Enhance AMD SMN Error Checking | expand |
On Tue, May 16, 2023 at 03:24:29PM -0500, Yazen Ghannam wrote: > The CCD temperature register is read in two places. These reads are done > using an AMD SMN access, and a number of parameters are needed for the > operation. > > Move the SMN access and parameter gathering into a helper function in > order to simply the code flow. This also has a benefit of centralizing > the hardware register access in a single place in case fixes or special > decoding is required. > > Signed-off-by: Yazen Ghannam <yazen.ghannam@amd.com> > --- > drivers/hwmon/k10temp.c | 19 ++++++++++++++----- > 1 file changed, 14 insertions(+), 5 deletions(-) > > diff --git a/drivers/hwmon/k10temp.c b/drivers/hwmon/k10temp.c > index 6ea1fa62b7c1..06af1fe38af7 100644 > --- a/drivers/hwmon/k10temp.c > +++ b/drivers/hwmon/k10temp.c > @@ -150,6 +150,18 @@ static void read_tempreg_nb_zen(struct pci_dev *pdev, u32 *regval) > *regval = 0; > } > > +static int read_ccd_temp_reg(struct k10temp_data *data, int ccd, u32 *regval) > +{ > + u16 node_id = amd_pci_dev_to_node_id(data->pdev); > + u32 tmp; > + > + if (amd_smn_read(node_id, ZEN_CCD_TEMP(data->ccd_offset, ccd), &tmp)) > + return -EINVAL; As mentioned before, this is not appropriate. The error code from amd_smn_read() should be returned. > + > + *regval = tmp; This seems pointless. Why not just pass regval as parameter to amd_smn_read() ? This function should be reduced to return amd_smn_read(node_id, ZEN_CCD_TEMP(data->ccd_offset, ccd), regval)); > + return 0; > +} > + > static long get_raw_temp(struct k10temp_data *data) > { > u32 regval; > @@ -214,9 +226,7 @@ static int k10temp_read_temp(struct device *dev, u32 attr, int channel, > *val = 0; > break; > case 2 ... 13: /* Tccd{1-12} */ > - if (amd_smn_read(amd_pci_dev_to_node_id(data->pdev), > - ZEN_CCD_TEMP(data->ccd_offset, channel - 2), > - ®val)) > + if (read_ccd_temp_reg(data, channel - 2, ®val)) > return -EINVAL; Now this is really wrong, no matter what. Why bother replacing the error code in read_ccd_temp_reg() only to replace it again ? > > *val = (regval & ZEN_CCD_TEMP_MASK) * 125 - 49000; > @@ -376,8 +386,7 @@ static void k10temp_get_ccd_support(struct pci_dev *pdev, > int i; > > for (i = 0; i < limit; i++) { > - if (amd_smn_read(amd_pci_dev_to_node_id(pdev), > - ZEN_CCD_TEMP(data->ccd_offset, i), ®val)) > + if (read_ccd_temp_reg(data, i, ®val)) > continue; > > if (regval & ZEN_CCD_TEMP_VALID) > -- > 2.34.1 >
On 5/17/23 8:30 AM, Guenter Roeck wrote: > On Tue, May 16, 2023 at 03:24:29PM -0500, Yazen Ghannam wrote: >> The CCD temperature register is read in two places. These reads are done >> using an AMD SMN access, and a number of parameters are needed for the >> operation. >> >> Move the SMN access and parameter gathering into a helper function in >> order to simply the code flow. This also has a benefit of centralizing >> the hardware register access in a single place in case fixes or special >> decoding is required. >> >> Signed-off-by: Yazen Ghannam <yazen.ghannam@amd.com> >> --- >> drivers/hwmon/k10temp.c | 19 ++++++++++++++----- >> 1 file changed, 14 insertions(+), 5 deletions(-) >> >> diff --git a/drivers/hwmon/k10temp.c b/drivers/hwmon/k10temp.c >> index 6ea1fa62b7c1..06af1fe38af7 100644 >> --- a/drivers/hwmon/k10temp.c >> +++ b/drivers/hwmon/k10temp.c >> @@ -150,6 +150,18 @@ static void read_tempreg_nb_zen(struct pci_dev *pdev, u32 *regval) >> *regval = 0; >> } >> >> +static int read_ccd_temp_reg(struct k10temp_data *data, int ccd, u32 *regval) >> +{ >> + u16 node_id = amd_pci_dev_to_node_id(data->pdev); >> + u32 tmp; >> + >> + if (amd_smn_read(node_id, ZEN_CCD_TEMP(data->ccd_offset, ccd), &tmp)) >> + return -EINVAL; > > As mentioned before, this is not appropriate. The error code > from amd_smn_read() should be returned. > Okay, will do. >> + >> + *regval = tmp; > > This seems pointless. Why not just pass regval as parameter > to amd_smn_read() ? > > This function should be reduced to > > return amd_smn_read(node_id, ZEN_CCD_TEMP(data->ccd_offset, ccd), regval)); > Yes, will do. I think I got carried away with the "don't save invalid value" idea. But this isn't necessary if the caller checks the return code and avoids using the value. >> + return 0; >> +} >> + >> static long get_raw_temp(struct k10temp_data *data) >> { >> u32 regval; >> @@ -214,9 +226,7 @@ static int k10temp_read_temp(struct device *dev, u32 attr, int channel, >> *val = 0; >> break; >> case 2 ... 13: /* Tccd{1-12} */ >> - if (amd_smn_read(amd_pci_dev_to_node_id(data->pdev), >> - ZEN_CCD_TEMP(data->ccd_offset, channel - 2), >> - ®val)) >> + if (read_ccd_temp_reg(data, channel - 2, ®val)) >> return -EINVAL; > > Now this is really wrong, no matter what. Why bother replacing the > error code in read_ccd_temp_reg() only to replace it again ? > Understood. Will fix like the other places. Thanks, Yazen
diff --git a/drivers/hwmon/k10temp.c b/drivers/hwmon/k10temp.c index 6ea1fa62b7c1..06af1fe38af7 100644 --- a/drivers/hwmon/k10temp.c +++ b/drivers/hwmon/k10temp.c @@ -150,6 +150,18 @@ static void read_tempreg_nb_zen(struct pci_dev *pdev, u32 *regval) *regval = 0; } +static int read_ccd_temp_reg(struct k10temp_data *data, int ccd, u32 *regval) +{ + u16 node_id = amd_pci_dev_to_node_id(data->pdev); + u32 tmp; + + if (amd_smn_read(node_id, ZEN_CCD_TEMP(data->ccd_offset, ccd), &tmp)) + return -EINVAL; + + *regval = tmp; + return 0; +} + static long get_raw_temp(struct k10temp_data *data) { u32 regval; @@ -214,9 +226,7 @@ static int k10temp_read_temp(struct device *dev, u32 attr, int channel, *val = 0; break; case 2 ... 13: /* Tccd{1-12} */ - if (amd_smn_read(amd_pci_dev_to_node_id(data->pdev), - ZEN_CCD_TEMP(data->ccd_offset, channel - 2), - ®val)) + if (read_ccd_temp_reg(data, channel - 2, ®val)) return -EINVAL; *val = (regval & ZEN_CCD_TEMP_MASK) * 125 - 49000; @@ -376,8 +386,7 @@ static void k10temp_get_ccd_support(struct pci_dev *pdev, int i; for (i = 0; i < limit; i++) { - if (amd_smn_read(amd_pci_dev_to_node_id(pdev), - ZEN_CCD_TEMP(data->ccd_offset, i), ®val)) + if (read_ccd_temp_reg(data, i, ®val)) continue; if (regval & ZEN_CCD_TEMP_VALID)
The CCD temperature register is read in two places. These reads are done using an AMD SMN access, and a number of parameters are needed for the operation. Move the SMN access and parameter gathering into a helper function in order to simply the code flow. This also has a benefit of centralizing the hardware register access in a single place in case fixes or special decoding is required. Signed-off-by: Yazen Ghannam <yazen.ghannam@amd.com> --- drivers/hwmon/k10temp.c | 19 ++++++++++++++----- 1 file changed, 14 insertions(+), 5 deletions(-)