Message ID | 20230513132136.15021-8-yi.l.liu@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Enhance vfio PCI hot reset for vfio cdev device | expand |
On 5/13/23 15:21, Yi Liu wrote: > There are drivers that need to search vfio_device within a given dev_set. > e.g. vfio-pci. So add a helper. > > Signed-off-by: Yi Liu <yi.l.liu@intel.com> > --- > drivers/vfio/pci/vfio_pci_core.c | 8 +++----- > drivers/vfio/vfio_main.c | 15 +++++++++++++++ > include/linux/vfio.h | 3 +++ > 3 files changed, 21 insertions(+), 5 deletions(-) > > diff --git a/drivers/vfio/pci/vfio_pci_core.c b/drivers/vfio/pci/vfio_pci_core.c > index 39e7823088e7..4df2def35bdd 100644 > --- a/drivers/vfio/pci/vfio_pci_core.c > +++ b/drivers/vfio/pci/vfio_pci_core.c > @@ -2335,12 +2335,10 @@ static bool vfio_dev_in_groups(struct vfio_pci_core_device *vdev, > static int vfio_pci_is_device_in_set(struct pci_dev *pdev, void *data) > { > struct vfio_device_set *dev_set = data; > - struct vfio_device *cur; > > - list_for_each_entry(cur, &dev_set->device_list, dev_set_list) > - if (cur->dev == &pdev->dev) > - return 0; > - return -EBUSY; > + lockdep_assert_held(&dev_set->lock); May be drop the lockdep_assert_held() above since there is one in vfio_find_device_in_devset(). Thanks, C. > + > + return vfio_find_device_in_devset(dev_set, &pdev->dev) ? 0 : -EBUSY; > } > > /* > diff --git a/drivers/vfio/vfio_main.c b/drivers/vfio/vfio_main.c > index f0ca33b2e1df..ab4f3a794f78 100644 > --- a/drivers/vfio/vfio_main.c > +++ b/drivers/vfio/vfio_main.c > @@ -141,6 +141,21 @@ unsigned int vfio_device_set_open_count(struct vfio_device_set *dev_set) > } > EXPORT_SYMBOL_GPL(vfio_device_set_open_count); > > +struct vfio_device * > +vfio_find_device_in_devset(struct vfio_device_set *dev_set, > + struct device *dev) > +{ > + struct vfio_device *cur; > + > + lockdep_assert_held(&dev_set->lock); > + > + list_for_each_entry(cur, &dev_set->device_list, dev_set_list) > + if (cur->dev == dev) > + return cur; > + return NULL; > +} > +EXPORT_SYMBOL_GPL(vfio_find_device_in_devset); > + > /* > * Device objects - create, release, get, put, search > */ > diff --git a/include/linux/vfio.h b/include/linux/vfio.h > index fcbe084b18c8..4c17395ed4d2 100644 > --- a/include/linux/vfio.h > +++ b/include/linux/vfio.h > @@ -259,6 +259,9 @@ void vfio_unregister_group_dev(struct vfio_device *device); > > int vfio_assign_device_set(struct vfio_device *device, void *set_id); > unsigned int vfio_device_set_open_count(struct vfio_device_set *dev_set); > +struct vfio_device * > +vfio_find_device_in_devset(struct vfio_device_set *dev_set, > + struct device *dev); > > int vfio_mig_get_next_state(struct vfio_device *device, > enum vfio_device_mig_state cur_fsm,
On Sat, 13 May 2023 06:21:33 -0700 Yi Liu <yi.l.liu@intel.com> wrote: > There are drivers that need to search vfio_device within a given dev_set. > e.g. vfio-pci. So add a helper. > > Signed-off-by: Yi Liu <yi.l.liu@intel.com> > --- > drivers/vfio/pci/vfio_pci_core.c | 8 +++----- > drivers/vfio/vfio_main.c | 15 +++++++++++++++ > include/linux/vfio.h | 3 +++ > 3 files changed, 21 insertions(+), 5 deletions(-) > > diff --git a/drivers/vfio/pci/vfio_pci_core.c b/drivers/vfio/pci/vfio_pci_core.c > index 39e7823088e7..4df2def35bdd 100644 > --- a/drivers/vfio/pci/vfio_pci_core.c > +++ b/drivers/vfio/pci/vfio_pci_core.c > @@ -2335,12 +2335,10 @@ static bool vfio_dev_in_groups(struct vfio_pci_core_device *vdev, > static int vfio_pci_is_device_in_set(struct pci_dev *pdev, void *data) > { > struct vfio_device_set *dev_set = data; > - struct vfio_device *cur; > > - list_for_each_entry(cur, &dev_set->device_list, dev_set_list) > - if (cur->dev == &pdev->dev) > - return 0; > - return -EBUSY; > + lockdep_assert_held(&dev_set->lock); > + > + return vfio_find_device_in_devset(dev_set, &pdev->dev) ? 0 : -EBUSY; Maybe an opportunity to revisit why this returns -EBUSY rather than something reasonable like -ENODEV. It looks like we picked up the -EBUSY in a882c16a2b7e where I think it was trying to preserve the return of vfio_pci_try_zap_and_vma_lock_cb() but the return value here is not even propagated so this looks like an chance to have it make sense again. Thanks, Alex > } > > /* > diff --git a/drivers/vfio/vfio_main.c b/drivers/vfio/vfio_main.c > index f0ca33b2e1df..ab4f3a794f78 100644 > --- a/drivers/vfio/vfio_main.c > +++ b/drivers/vfio/vfio_main.c > @@ -141,6 +141,21 @@ unsigned int vfio_device_set_open_count(struct vfio_device_set *dev_set) > } > EXPORT_SYMBOL_GPL(vfio_device_set_open_count); > > +struct vfio_device * > +vfio_find_device_in_devset(struct vfio_device_set *dev_set, > + struct device *dev) > +{ > + struct vfio_device *cur; > + > + lockdep_assert_held(&dev_set->lock); > + > + list_for_each_entry(cur, &dev_set->device_list, dev_set_list) > + if (cur->dev == dev) > + return cur; > + return NULL; > +} > +EXPORT_SYMBOL_GPL(vfio_find_device_in_devset); > + > /* > * Device objects - create, release, get, put, search > */ > diff --git a/include/linux/vfio.h b/include/linux/vfio.h > index fcbe084b18c8..4c17395ed4d2 100644 > --- a/include/linux/vfio.h > +++ b/include/linux/vfio.h > @@ -259,6 +259,9 @@ void vfio_unregister_group_dev(struct vfio_device *device); > > int vfio_assign_device_set(struct vfio_device *device, void *set_id); > unsigned int vfio_device_set_open_count(struct vfio_device_set *dev_set); > +struct vfio_device * > +vfio_find_device_in_devset(struct vfio_device_set *dev_set, > + struct device *dev); > > int vfio_mig_get_next_state(struct vfio_device *device, > enum vfio_device_mig_state cur_fsm,
> From: Alex Williamson <alex.williamson@redhat.com> > Sent: Thursday, May 18, 2023 3:13 AM > > On Sat, 13 May 2023 06:21:33 -0700 > Yi Liu <yi.l.liu@intel.com> wrote: > > > There are drivers that need to search vfio_device within a given dev_set. > > e.g. vfio-pci. So add a helper. > > > > Signed-off-by: Yi Liu <yi.l.liu@intel.com> > > --- > > drivers/vfio/pci/vfio_pci_core.c | 8 +++----- > > drivers/vfio/vfio_main.c | 15 +++++++++++++++ > > include/linux/vfio.h | 3 +++ > > 3 files changed, 21 insertions(+), 5 deletions(-) > > > > diff --git a/drivers/vfio/pci/vfio_pci_core.c b/drivers/vfio/pci/vfio_pci_core.c > > index 39e7823088e7..4df2def35bdd 100644 > > --- a/drivers/vfio/pci/vfio_pci_core.c > > +++ b/drivers/vfio/pci/vfio_pci_core.c > > @@ -2335,12 +2335,10 @@ static bool vfio_dev_in_groups(struct > vfio_pci_core_device *vdev, > > static int vfio_pci_is_device_in_set(struct pci_dev *pdev, void *data) > > { > > struct vfio_device_set *dev_set = data; > > - struct vfio_device *cur; > > > > - list_for_each_entry(cur, &dev_set->device_list, dev_set_list) > > - if (cur->dev == &pdev->dev) > > - return 0; > > - return -EBUSY; > > + lockdep_assert_held(&dev_set->lock); > > + > > + return vfio_find_device_in_devset(dev_set, &pdev->dev) ? 0 : -EBUSY; > > Maybe an opportunity to revisit why this returns -EBUSY rather than > something reasonable like -ENODEV. It looks like we picked up the > -EBUSY in a882c16a2b7e where I think it was trying to preserve the > return of vfio_pci_try_zap_and_vma_lock_cb() but the return value here > is not even propagated so this looks like an chance to have it make > sense again. Thanks, From the name of this function, yes, -ENODEV is better. is it Ok to modify it to be -ENODEV in this patch or a separate one? Regards, Yi Liu > > > } > > > > /* > > diff --git a/drivers/vfio/vfio_main.c b/drivers/vfio/vfio_main.c > > index f0ca33b2e1df..ab4f3a794f78 100644 > > --- a/drivers/vfio/vfio_main.c > > +++ b/drivers/vfio/vfio_main.c > > @@ -141,6 +141,21 @@ unsigned int vfio_device_set_open_count(struct > vfio_device_set *dev_set) > > } > > EXPORT_SYMBOL_GPL(vfio_device_set_open_count); > > > > +struct vfio_device * > > +vfio_find_device_in_devset(struct vfio_device_set *dev_set, > > + struct device *dev) > > +{ > > + struct vfio_device *cur; > > + > > + lockdep_assert_held(&dev_set->lock); > > + > > + list_for_each_entry(cur, &dev_set->device_list, dev_set_list) > > + if (cur->dev == dev) > > + return cur; > > + return NULL; > > +} > > +EXPORT_SYMBOL_GPL(vfio_find_device_in_devset); > > + > > /* > > * Device objects - create, release, get, put, search > > */ > > diff --git a/include/linux/vfio.h b/include/linux/vfio.h > > index fcbe084b18c8..4c17395ed4d2 100644 > > --- a/include/linux/vfio.h > > +++ b/include/linux/vfio.h > > @@ -259,6 +259,9 @@ void vfio_unregister_group_dev(struct vfio_device *device); > > > > int vfio_assign_device_set(struct vfio_device *device, void *set_id); > > unsigned int vfio_device_set_open_count(struct vfio_device_set *dev_set); > > +struct vfio_device * > > +vfio_find_device_in_devset(struct vfio_device_set *dev_set, > > + struct device *dev); > > > > int vfio_mig_get_next_state(struct vfio_device *device, > > enum vfio_device_mig_state cur_fsm,
On Thu, 18 May 2023 12:31:07 +0000 "Liu, Yi L" <yi.l.liu@intel.com> wrote: > > From: Alex Williamson <alex.williamson@redhat.com> > > Sent: Thursday, May 18, 2023 3:13 AM > > > > On Sat, 13 May 2023 06:21:33 -0700 > > Yi Liu <yi.l.liu@intel.com> wrote: > > > > > There are drivers that need to search vfio_device within a given dev_set. > > > e.g. vfio-pci. So add a helper. > > > > > > Signed-off-by: Yi Liu <yi.l.liu@intel.com> > > > --- > > > drivers/vfio/pci/vfio_pci_core.c | 8 +++----- > > > drivers/vfio/vfio_main.c | 15 +++++++++++++++ > > > include/linux/vfio.h | 3 +++ > > > 3 files changed, 21 insertions(+), 5 deletions(-) > > > > > > diff --git a/drivers/vfio/pci/vfio_pci_core.c b/drivers/vfio/pci/vfio_pci_core.c > > > index 39e7823088e7..4df2def35bdd 100644 > > > --- a/drivers/vfio/pci/vfio_pci_core.c > > > +++ b/drivers/vfio/pci/vfio_pci_core.c > > > @@ -2335,12 +2335,10 @@ static bool vfio_dev_in_groups(struct > > vfio_pci_core_device *vdev, > > > static int vfio_pci_is_device_in_set(struct pci_dev *pdev, void *data) > > > { > > > struct vfio_device_set *dev_set = data; > > > - struct vfio_device *cur; > > > > > > - list_for_each_entry(cur, &dev_set->device_list, dev_set_list) > > > - if (cur->dev == &pdev->dev) > > > - return 0; > > > - return -EBUSY; > > > + lockdep_assert_held(&dev_set->lock); > > > + > > > + return vfio_find_device_in_devset(dev_set, &pdev->dev) ? 0 : -EBUSY; > > > > Maybe an opportunity to revisit why this returns -EBUSY rather than > > something reasonable like -ENODEV. It looks like we picked up the > > -EBUSY in a882c16a2b7e where I think it was trying to preserve the > > return of vfio_pci_try_zap_and_vma_lock_cb() but the return value here > > is not even propagated so this looks like an chance to have it make > > sense again. Thanks, > > From the name of this function, yes, -ENODEV is better. is it > Ok to modify it to be -ENODEV in this patch or a separate one? This patch is fine so long as it's noted in the commit log. Thanks, Alex > > > } > > > > > > /* > > > diff --git a/drivers/vfio/vfio_main.c b/drivers/vfio/vfio_main.c > > > index f0ca33b2e1df..ab4f3a794f78 100644 > > > --- a/drivers/vfio/vfio_main.c > > > +++ b/drivers/vfio/vfio_main.c > > > @@ -141,6 +141,21 @@ unsigned int vfio_device_set_open_count(struct > > vfio_device_set *dev_set) > > > } > > > EXPORT_SYMBOL_GPL(vfio_device_set_open_count); > > > > > > +struct vfio_device * > > > +vfio_find_device_in_devset(struct vfio_device_set *dev_set, > > > + struct device *dev) > > > +{ > > > + struct vfio_device *cur; > > > + > > > + lockdep_assert_held(&dev_set->lock); > > > + > > > + list_for_each_entry(cur, &dev_set->device_list, dev_set_list) > > > + if (cur->dev == dev) > > > + return cur; > > > + return NULL; > > > +} > > > +EXPORT_SYMBOL_GPL(vfio_find_device_in_devset); > > > + > > > /* > > > * Device objects - create, release, get, put, search > > > */ > > > diff --git a/include/linux/vfio.h b/include/linux/vfio.h > > > index fcbe084b18c8..4c17395ed4d2 100644 > > > --- a/include/linux/vfio.h > > > +++ b/include/linux/vfio.h > > > @@ -259,6 +259,9 @@ void vfio_unregister_group_dev(struct vfio_device *device); > > > > > > int vfio_assign_device_set(struct vfio_device *device, void *set_id); > > > unsigned int vfio_device_set_open_count(struct vfio_device_set *dev_set); > > > +struct vfio_device * > > > +vfio_find_device_in_devset(struct vfio_device_set *dev_set, > > > + struct device *dev); > > > > > > int vfio_mig_get_next_state(struct vfio_device *device, > > > enum vfio_device_mig_state cur_fsm, >
diff --git a/drivers/vfio/pci/vfio_pci_core.c b/drivers/vfio/pci/vfio_pci_core.c index 39e7823088e7..4df2def35bdd 100644 --- a/drivers/vfio/pci/vfio_pci_core.c +++ b/drivers/vfio/pci/vfio_pci_core.c @@ -2335,12 +2335,10 @@ static bool vfio_dev_in_groups(struct vfio_pci_core_device *vdev, static int vfio_pci_is_device_in_set(struct pci_dev *pdev, void *data) { struct vfio_device_set *dev_set = data; - struct vfio_device *cur; - list_for_each_entry(cur, &dev_set->device_list, dev_set_list) - if (cur->dev == &pdev->dev) - return 0; - return -EBUSY; + lockdep_assert_held(&dev_set->lock); + + return vfio_find_device_in_devset(dev_set, &pdev->dev) ? 0 : -EBUSY; } /* diff --git a/drivers/vfio/vfio_main.c b/drivers/vfio/vfio_main.c index f0ca33b2e1df..ab4f3a794f78 100644 --- a/drivers/vfio/vfio_main.c +++ b/drivers/vfio/vfio_main.c @@ -141,6 +141,21 @@ unsigned int vfio_device_set_open_count(struct vfio_device_set *dev_set) } EXPORT_SYMBOL_GPL(vfio_device_set_open_count); +struct vfio_device * +vfio_find_device_in_devset(struct vfio_device_set *dev_set, + struct device *dev) +{ + struct vfio_device *cur; + + lockdep_assert_held(&dev_set->lock); + + list_for_each_entry(cur, &dev_set->device_list, dev_set_list) + if (cur->dev == dev) + return cur; + return NULL; +} +EXPORT_SYMBOL_GPL(vfio_find_device_in_devset); + /* * Device objects - create, release, get, put, search */ diff --git a/include/linux/vfio.h b/include/linux/vfio.h index fcbe084b18c8..4c17395ed4d2 100644 --- a/include/linux/vfio.h +++ b/include/linux/vfio.h @@ -259,6 +259,9 @@ void vfio_unregister_group_dev(struct vfio_device *device); int vfio_assign_device_set(struct vfio_device *device, void *set_id); unsigned int vfio_device_set_open_count(struct vfio_device_set *dev_set); +struct vfio_device * +vfio_find_device_in_devset(struct vfio_device_set *dev_set, + struct device *dev); int vfio_mig_get_next_state(struct vfio_device *device, enum vfio_device_mig_state cur_fsm,
There are drivers that need to search vfio_device within a given dev_set. e.g. vfio-pci. So add a helper. Signed-off-by: Yi Liu <yi.l.liu@intel.com> --- drivers/vfio/pci/vfio_pci_core.c | 8 +++----- drivers/vfio/vfio_main.c | 15 +++++++++++++++ include/linux/vfio.h | 3 +++ 3 files changed, 21 insertions(+), 5 deletions(-)