Message ID | 20230719195417.1704513-2-axboe@kernel.dk (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | Improve async iomap DIO performance | expand |
> + /* > + * Synchronous dio, task itself will handle any completion work > + * that needs after IO. All we need to do is wake the task. > + */ > + if (dio->wait_for_completion) { > + struct task_struct *waiter = dio->submit.waiter; > + WRITE_ONCE(dio->submit.waiter, NULL); I know the existing code got it wrong, but can you please add an empty line after the variable declaration here? > + /* > + * If this dio is an async write, queue completion work for async > + * handling. Reads can always complete inline. > + */ > + if (dio->flags & IOMAP_DIO_WRITE) { > + struct inode *inode = file_inode(iocb->ki_filp); > + > + WRITE_ONCE(iocb->private, NULL); > + INIT_WORK(&dio->aio.work, iomap_dio_complete_work); > + queue_work(inode->i_sb->s_dio_done_wq, &dio->aio.work); > + } else { If we already do the goto style I'd probably do it here as well instead of the else. Otherwise this looks good to me.
On 7/19/23 10:50?PM, Christoph Hellwig wrote: >> + /* >> + * Synchronous dio, task itself will handle any completion work >> + * that needs after IO. All we need to do is wake the task. >> + */ >> + if (dio->wait_for_completion) { >> + struct task_struct *waiter = dio->submit.waiter; >> + WRITE_ONCE(dio->submit.waiter, NULL); > > I know the existing code got it wrong, but can you please add an empty > line after the variable declaration here? Sure, will add. >> + /* >> + * If this dio is an async write, queue completion work for async >> + * handling. Reads can always complete inline. >> + */ >> + if (dio->flags & IOMAP_DIO_WRITE) { >> + struct inode *inode = file_inode(iocb->ki_filp); >> + >> + WRITE_ONCE(iocb->private, NULL); >> + INIT_WORK(&dio->aio.work, iomap_dio_complete_work); >> + queue_work(inode->i_sb->s_dio_done_wq, &dio->aio.work); >> + } else { > > If we already do the goto style I'd probably do it here as well instead > of the else. It does end up like that later on, but I can do it earlier and leave the least desirable method (workqueue) at the end from this patch.
diff --git a/fs/iomap/direct-io.c b/fs/iomap/direct-io.c index ea3b868c8355..1c32f734c767 100644 --- a/fs/iomap/direct-io.c +++ b/fs/iomap/direct-io.c @@ -152,27 +152,40 @@ void iomap_dio_bio_end_io(struct bio *bio) { struct iomap_dio *dio = bio->bi_private; bool should_dirty = (dio->flags & IOMAP_DIO_DIRTY); + struct kiocb *iocb = dio->iocb; if (bio->bi_status) iomap_dio_set_error(dio, blk_status_to_errno(bio->bi_status)); + if (!atomic_dec_and_test(&dio->ref)) + goto release_bio; - if (atomic_dec_and_test(&dio->ref)) { - if (dio->wait_for_completion) { - struct task_struct *waiter = dio->submit.waiter; - WRITE_ONCE(dio->submit.waiter, NULL); - blk_wake_io_task(waiter); - } else if (dio->flags & IOMAP_DIO_WRITE) { - struct inode *inode = file_inode(dio->iocb->ki_filp); - - WRITE_ONCE(dio->iocb->private, NULL); - INIT_WORK(&dio->aio.work, iomap_dio_complete_work); - queue_work(inode->i_sb->s_dio_done_wq, &dio->aio.work); - } else { - WRITE_ONCE(dio->iocb->private, NULL); - iomap_dio_complete_work(&dio->aio.work); - } + /* + * Synchronous dio, task itself will handle any completion work + * that needs after IO. All we need to do is wake the task. + */ + if (dio->wait_for_completion) { + struct task_struct *waiter = dio->submit.waiter; + WRITE_ONCE(dio->submit.waiter, NULL); + blk_wake_io_task(waiter); + goto release_bio; + } + + /* + * If this dio is an async write, queue completion work for async + * handling. Reads can always complete inline. + */ + if (dio->flags & IOMAP_DIO_WRITE) { + struct inode *inode = file_inode(iocb->ki_filp); + + WRITE_ONCE(iocb->private, NULL); + INIT_WORK(&dio->aio.work, iomap_dio_complete_work); + queue_work(inode->i_sb->s_dio_done_wq, &dio->aio.work); + } else { + WRITE_ONCE(iocb->private, NULL); + iomap_dio_complete_work(&dio->aio.work); } +release_bio: if (should_dirty) { bio_check_pages_dirty(bio); } else {
Make the logic a bit easier to follow: 1) Add a release_bio out path, as everybody needs to touch that, and have our bio ref check jump there if it's non-zero. 2) Add a kiocb local variable. 3) Add comments for each of the three conditions (sync, inline, or async workqueue punt). No functional changes in this patch. Signed-off-by: Jens Axboe <axboe@kernel.dk> --- fs/iomap/direct-io.c | 43 ++++++++++++++++++++++++++++--------------- 1 file changed, 28 insertions(+), 15 deletions(-)