Message ID | 20230927135241.2287547-1-tushar.vyavahare@intel.com (mailing list archive) |
---|---|
Headers | show |
Series | Add a test for SHARED_UMEM feature | expand |
On Wed, 27 Sept 2023 at 15:31, Tushar Vyavahare <tushar.vyavahare@intel.com> wrote: > > Implement a test for the SHARED_UMEM feature in this patch set and make > necessary changes/improvements. Ensure that the framework now supports > different streams for different sockets. > > v2->v3 > - Set the sock_num at the end of the while loop. > - Declare xsk at the top of the while loop. > > v1->v2 > - Remove generate_mac_addresses() and generate mac addresses based on > the number of sockets in __test_spec_init() function. [Magnus] > - Update Makefile to include find_bit.c for compiling xskxceiver. > - Add bitmap_full() function to verify all bits are set to break the while loop > in the receive_pkts() and send_pkts() functions. > - Replace __test_and_set_bit() function with __set_bit() function. > - Add single return check for wait_for_tx_completion() function call. > > Patch series summary: > > 1: Move the packet stream from the ifobject struct to the xsk_socket_info > struct to enable the use of different streams for different sockets > This will facilitate the sending and receiving of data from multiple > sockets simultaneously using the SHARED_XDP_UMEM feature. > > It gives flexibility of send/recive individual traffic on particular > socket. > > 2: Rename the header file to a generic name so that it can be used by all > future XDP programs. > > 3: Move the src_mac and dst_mac fields from the ifobject structure to the > xsk_socket_info structure to achieve per-socket MAC address assignment. > Require this in order to steer traffic to various sockets in subsequent > patches. > > 4: Improve the receive_pkt() function to enable it to receive packets from > multiple sockets. Define a sock_num variable to iterate through all the > sockets in the Rx path. Add nb_valid_entries to check that all the > expected number of packets are received. > > 5: The pkt_set() function no longer needs the umem parameter. This commit > removes the umem parameter from the pkt_set() function. > > 6: Iterate over all the sockets in the send pkts function. Update > send_pkts() to handle multiple sockets for sending packets. > Multiple TX sockets are utilized alternately based on the batch size > for improve packet transmission. > > 7: Modify xsk_update_xskmap() to accept the index as an argument, enabling > the addition of multiple sockets to xskmap. > > 8: Add a new test for testing shared umem feature. This is accomplished by > adding a new XDP program and using the multiple sockets. The new XDP > program redirects the packets based on the destination MAC address. Thanks Tushar! For the set: Acked-by: Magnus Karlsson <magnus.karlsson@intel.com> > Tushar Vyavahare (8): > selftests/xsk: move pkt_stream to the xsk_socket_info > selftests/xsk: rename xsk_xdp_metadata.h to xsk_xdp_common.h > selftests/xsk: move src_mac and dst_mac to the xsk_socket_info > selftests/xsk: iterate over all the sockets in the receive pkts > function > selftests/xsk: remove unnecessary parameter from pkt_set() function > call > selftests/xsk: iterate over all the sockets in the send pkts function > selftests/xsk: modify xsk_update_xskmap() to accept the index as an > argument > selftests/xsk: add a test for shared umem feature > > tools/testing/selftests/bpf/Makefile | 4 +- > .../selftests/bpf/progs/xsk_xdp_progs.c | 22 +- > tools/testing/selftests/bpf/xsk.c | 3 +- > tools/testing/selftests/bpf/xsk.h | 2 +- > tools/testing/selftests/bpf/xsk_xdp_common.h | 12 + > .../testing/selftests/bpf/xsk_xdp_metadata.h | 5 - > tools/testing/selftests/bpf/xskxceiver.c | 513 +++++++++++------- > tools/testing/selftests/bpf/xskxceiver.h | 13 +- > 8 files changed, 363 insertions(+), 211 deletions(-) > create mode 100644 tools/testing/selftests/bpf/xsk_xdp_common.h > delete mode 100644 tools/testing/selftests/bpf/xsk_xdp_metadata.h > > -- > 2.34.1 > >
Hello: This series was applied to bpf/bpf-next.git (master) by Daniel Borkmann <daniel@iogearbox.net>: On Wed, 27 Sep 2023 19:22:33 +0530 you wrote: > Implement a test for the SHARED_UMEM feature in this patch set and make > necessary changes/improvements. Ensure that the framework now supports > different streams for different sockets. > > v2->v3 > - Set the sock_num at the end of the while loop. > - Declare xsk at the top of the while loop. > > [...] Here is the summary with links: - [bpf-next,v3,1/8] selftests/xsk: move pkt_stream to the xsk_socket_info https://git.kernel.org/bpf/bpf-next/c/8367eb954e24 - [bpf-next,v3,2/8] selftests/xsk: rename xsk_xdp_metadata.h to xsk_xdp_common.h https://git.kernel.org/bpf/bpf-next/c/93ba11247907 - [bpf-next,v3,3/8] selftests/xsk: move src_mac and dst_mac to the xsk_socket_info https://git.kernel.org/bpf/bpf-next/c/985fd2145a29 - [bpf-next,v3,4/8] selftests/xsk: iterate over all the sockets in the receive pkts function https://git.kernel.org/bpf/bpf-next/c/8913e653e9b8 - [bpf-next,v3,5/8] selftests/xsk: remove unnecessary parameter from pkt_set() function call https://git.kernel.org/bpf/bpf-next/c/46e43786cc60 - [bpf-next,v3,6/8] selftests/xsk: iterate over all the sockets in the send pkts function https://git.kernel.org/bpf/bpf-next/c/fd0815ae9b8a - [bpf-next,v3,7/8] selftests/xsk: modify xsk_update_xskmap() to accept the index as an argument https://git.kernel.org/bpf/bpf-next/c/fc2cb86495da - [bpf-next,v3,8/8] selftests/xsk: add a test for shared umem feature https://git.kernel.org/bpf/bpf-next/c/6d198a89c004 You are awesome, thank you!