Message ID | 20231005125757.649345-3-james.clark@arm.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | kvm/coresight: Support exclude guest and exclude host | expand |
On 05/10/2023 13:57, James Clark wrote: > This flag actually causes the TRFCR register to be saved, so rename it > to that effect. > > Currently it only happens when TRBE is used, but in a later commit > TRFCR will be saved and restored even if TRBE isn't used, so the new > name will be more accurate. > > Signed-off-by: James Clark <james.clark@arm.com> Reviewed-by: Suzuki K Poulose <suzuki.poulose@arm.com>
On 05/10/2023 17:41, Suzuki K Poulose wrote: > On 05/10/2023 13:57, James Clark wrote: >> This flag actually causes the TRFCR register to be saved, so rename it >> to that effect. >> >> Currently it only happens when TRBE is used, but in a later commit >> TRFCR will be saved and restored even if TRBE isn't used, so the new >> name will be more accurate. >> >> Signed-off-by: James Clark <james.clark@arm.com> > > Reviewed-by: Suzuki K Poulose <suzuki.poulose@arm.com> Reviewing the patch 5, this change may need to be dropped and instead we need to add a new flag for TRFCR. Suzuki > >
On 05/10/2023 19:04, Suzuki K Poulose wrote: > On 05/10/2023 17:41, Suzuki K Poulose wrote: >> On 05/10/2023 13:57, James Clark wrote: >>> This flag actually causes the TRFCR register to be saved, so rename it >>> to that effect. >>> >>> Currently it only happens when TRBE is used, but in a later commit >>> TRFCR will be saved and restored even if TRBE isn't used, so the new >>> name will be more accurate. >>> >>> Signed-off-by: James Clark <james.clark@arm.com> >> >> Reviewed-by: Suzuki K Poulose <suzuki.poulose@arm.com> > > Reviewing the patch 5, this change may need to be dropped > and instead we need to add a new flag for TRFCR. > > Suzuki > Yes I dropped this commit and added a new one to add a new flag.
diff --git a/arch/arm64/include/asm/kvm_host.h b/arch/arm64/include/asm/kvm_host.h index 0ca4b34f8513..e36f7e8a76ce 100644 --- a/arch/arm64/include/asm/kvm_host.h +++ b/arch/arm64/include/asm/kvm_host.h @@ -741,8 +741,8 @@ struct kvm_vcpu_arch { #define DEBUG_DIRTY __vcpu_single_flag(iflags, BIT(4)) /* Save SPE context if active */ #define DEBUG_STATE_SAVE_SPE __vcpu_single_flag(iflags, BIT(5)) -/* Save TRBE context if active */ -#define DEBUG_STATE_SAVE_TRBE __vcpu_single_flag(iflags, BIT(6)) +/* Save TRFCR and disable TRBE if necessary */ +#define DEBUG_STATE_SAVE_TRFCR __vcpu_single_flag(iflags, BIT(6)) /* vcpu running in HYP context */ #define VCPU_HYP_CONTEXT __vcpu_single_flag(iflags, BIT(7)) diff --git a/arch/arm64/kvm/debug.c b/arch/arm64/kvm/debug.c index 8725291cb00a..6a1bad1a921b 100644 --- a/arch/arm64/kvm/debug.c +++ b/arch/arm64/kvm/debug.c @@ -334,11 +334,11 @@ void kvm_arch_vcpu_load_debug_state_flags(struct kvm_vcpu *vcpu) /* Check if we have TRBE implemented and available at the host */ if (cpuid_feature_extract_unsigned_field(dfr0, ID_AA64DFR0_EL1_TraceBuffer_SHIFT) && !(read_sysreg_s(SYS_TRBIDR_EL1) & TRBIDR_EL1_P)) - vcpu_set_flag(vcpu, DEBUG_STATE_SAVE_TRBE); + vcpu_set_flag(vcpu, DEBUG_STATE_SAVE_TRFCR); } void kvm_arch_vcpu_put_debug_state_flags(struct kvm_vcpu *vcpu) { vcpu_clear_flag(vcpu, DEBUG_STATE_SAVE_SPE); - vcpu_clear_flag(vcpu, DEBUG_STATE_SAVE_TRBE); + vcpu_clear_flag(vcpu, DEBUG_STATE_SAVE_TRFCR); } diff --git a/arch/arm64/kvm/hyp/nvhe/debug-sr.c b/arch/arm64/kvm/hyp/nvhe/debug-sr.c index 4558c02eb352..89c208112eb7 100644 --- a/arch/arm64/kvm/hyp/nvhe/debug-sr.c +++ b/arch/arm64/kvm/hyp/nvhe/debug-sr.c @@ -85,7 +85,7 @@ void __debug_save_host_buffers_nvhe(struct kvm_vcpu *vcpu) if (vcpu_get_flag(vcpu, DEBUG_STATE_SAVE_SPE)) __debug_save_spe(&vcpu->arch.host_debug_state.pmscr_el1); /* Disable and flush Self-Hosted Trace generation */ - if (vcpu_get_flag(vcpu, DEBUG_STATE_SAVE_TRBE)) + if (vcpu_get_flag(vcpu, DEBUG_STATE_SAVE_TRFCR)) __debug_save_trace(&vcpu->arch.host_debug_state.trfcr_el1); } @@ -98,7 +98,7 @@ void __debug_restore_host_buffers_nvhe(struct kvm_vcpu *vcpu) { if (vcpu_get_flag(vcpu, DEBUG_STATE_SAVE_SPE)) __debug_restore_spe(vcpu->arch.host_debug_state.pmscr_el1); - if (vcpu_get_flag(vcpu, DEBUG_STATE_SAVE_TRBE)) + if (vcpu_get_flag(vcpu, DEBUG_STATE_SAVE_TRFCR)) __debug_restore_trace(vcpu->arch.host_debug_state.trfcr_el1); }
This flag actually causes the TRFCR register to be saved, so rename it to that effect. Currently it only happens when TRBE is used, but in a later commit TRFCR will be saved and restored even if TRBE isn't used, so the new name will be more accurate. Signed-off-by: James Clark <james.clark@arm.com> --- arch/arm64/include/asm/kvm_host.h | 4 ++-- arch/arm64/kvm/debug.c | 4 ++-- arch/arm64/kvm/hyp/nvhe/debug-sr.c | 4 ++-- 3 files changed, 6 insertions(+), 6 deletions(-)