Message ID | 1696614170-18969-1-git-send-email-quic_vnivarth@quicinc.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 8a6b446d8a13673bfcf44fbd09d737ae4ccf0bfd |
Headers | show |
Series | spi: spi-geni-qcom: Rename the label unmap_if_dma | expand |
Hi, On Fri, Oct 6, 2023 at 10:43 AM Vijaya Krishna Nivarthi <quic_vnivarth@quicinc.com> wrote: > > The code at unmap_if_dma label doesn't contain unmapping dma anymore but > has only fsm reset. > > Rename it to reset_if_dma accordingly. > > No functional change. > > Signed-off-by: Vijaya Krishna Nivarthi <quic_vnivarth@quicinc.com> > --- > drivers/spi/spi-geni-qcom.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) I guess perhaps technically this could have: Fixes: 3a76c7ca9e77 ("spi: spi-geni-qcom: Do not do DMA map/unmap inside driver, use framework instead") ...since before that commit it _did_ do the unmap, right? ;-) In any case, this seems good to me: Reviewed-by: Douglas Anderson <dianders@chromium.org>
On Fri, 06 Oct 2023 23:12:50 +0530, Vijaya Krishna Nivarthi wrote: > The code at unmap_if_dma label doesn't contain unmapping dma anymore but > has only fsm reset. > > Rename it to reset_if_dma accordingly. > > No functional change. > > [...] Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/spi.git for-next Thanks! [1/1] spi: spi-geni-qcom: Rename the label unmap_if_dma commit: 8a6b446d8a13673bfcf44fbd09d737ae4ccf0bfd All being well this means that it will be integrated into the linux-next tree (usually sometime in the next 24 hours) and sent to Linus during the next merge window (or sooner if it is a bug fix), however if problems are discovered then the patch may be dropped or reverted. You may get further e-mails resulting from automated or manual testing and review of the tree, please engage with people reporting problems and send followup patches addressing any issues that are reported if needed. If any updates are required or you are submitting further changes they should be sent as incremental updates against current git, existing patches will not be replaced. Please add any relevant lists and maintainers to the CCs when replying to this mail. Thanks, Mark
diff --git a/drivers/spi/spi-geni-qcom.c b/drivers/spi/spi-geni-qcom.c index f4f376a..b956a32 100644 --- a/drivers/spi/spi-geni-qcom.c +++ b/drivers/spi/spi-geni-qcom.c @@ -166,7 +166,7 @@ static void handle_se_timeout(struct spi_master *spi, * doesn`t support CMD Cancel sequnece */ spin_unlock_irq(&mas->lock); - goto unmap_if_dma; + goto reset_if_dma; } reinit_completion(&mas->cancel_done); @@ -175,7 +175,7 @@ static void handle_se_timeout(struct spi_master *spi, time_left = wait_for_completion_timeout(&mas->cancel_done, HZ); if (time_left) - goto unmap_if_dma; + goto reset_if_dma; spin_lock_irq(&mas->lock); reinit_completion(&mas->abort_done); @@ -193,7 +193,7 @@ static void handle_se_timeout(struct spi_master *spi, mas->abort_failed = true; } -unmap_if_dma: +reset_if_dma: if (mas->cur_xfer_mode == GENI_SE_DMA) { if (xfer) { if (xfer->tx_buf) {
The code at unmap_if_dma label doesn't contain unmapping dma anymore but has only fsm reset. Rename it to reset_if_dma accordingly. No functional change. Signed-off-by: Vijaya Krishna Nivarthi <quic_vnivarth@quicinc.com> --- drivers/spi/spi-geni-qcom.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)