Message ID | 20231211140732.11475-1-bpoirier@nvidia.com (mailing list archive) |
---|---|
Headers | show |
Series | bridge: vni: UI fixes | expand |
On Mon, 11 Dec 2023 09:07:12 -0500 Benjamin Poirier <bpoirier@nvidia.com> wrote: > This series mainly contains fixes to `bridge vni` command input and output. > There are also a few adjacent changes to `bridge vlan` and `bridge vni`. > > Benjamin Poirier (20): > bridge: vni: Accept 'del' command > bridge: vni: Remove dead code in group argument parsing > bridge: vni: Fix duplicate group and remote error messages > bridge: vni: Report duplicate vni argument using duparg() > bridge: vni: Fix vni filter help strings > bridge: vlan: Use printf() to avoid temporary buffer > bridge: vlan: Remove paranoid check > bridge: vni: Remove print_vnifilter_rtm_filter() > bridge: vni: Move open_json_object() within print_vni() > bridge: vni: Guard close_vni_port() call > bridge: vni: Reverse the logic in print_vnifilter_rtm() > bridge: vni: Remove stray newlines after each interface > bridge: vni: Replace open-coded instance of print_nl() > bridge: vni: Remove unused argument in open_vni_port() > bridge: vni: Align output columns > bridge: vni: Indent statistics with 2 spaces > bridge: Deduplicate print_range() > json_print: Output to temporary buffer in print_range() only as needed > json_print: Rename print_range() argument > bridge: Provide rta_type() > > bridge/bridge.c | 2 +- > bridge/vlan.c | 38 +++------------ > bridge/vni.c | 113 +++++++++++++++++-------------------------- > include/json_print.h | 2 + > include/libnetlink.h | 4 ++ > lib/json_print.c | 15 ++++++ > 6 files changed, 75 insertions(+), 99 deletions(-) > These are all ok except the first one. Please resubmit, and consider consolidating some of the patches. Better to have 10 patches than 20.
Hello: This series was applied to iproute2/iproute2.git (main) by Stephen Hemminger <stephen@networkplumber.org>: On Mon, 11 Dec 2023 09:07:12 -0500 you wrote: > This series mainly contains fixes to `bridge vni` command input and output. > There are also a few adjacent changes to `bridge vlan` and `bridge vni`. > > Benjamin Poirier (20): > bridge: vni: Accept 'del' command > bridge: vni: Remove dead code in group argument parsing > bridge: vni: Fix duplicate group and remote error messages > bridge: vni: Report duplicate vni argument using duparg() > bridge: vni: Fix vni filter help strings > bridge: vlan: Use printf() to avoid temporary buffer > bridge: vlan: Remove paranoid check > bridge: vni: Remove print_vnifilter_rtm_filter() > bridge: vni: Move open_json_object() within print_vni() > bridge: vni: Guard close_vni_port() call > bridge: vni: Reverse the logic in print_vnifilter_rtm() > bridge: vni: Remove stray newlines after each interface > bridge: vni: Replace open-coded instance of print_nl() > bridge: vni: Remove unused argument in open_vni_port() > bridge: vni: Align output columns > bridge: vni: Indent statistics with 2 spaces > bridge: Deduplicate print_range() > json_print: Output to temporary buffer in print_range() only as needed > json_print: Rename print_range() argument > bridge: Provide rta_type() > > [...] Here is the summary with links: - [iproute2-next,01/20] bridge: vni: Accept 'del' command https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=e8177094d515 - [iproute2-next,02/20] bridge: vni: Remove dead code in group argument parsing https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=ba1e68f04be3 - [iproute2-next,03/20] bridge: vni: Fix duplicate group and remote error messages https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=0b8c01b4058e - [iproute2-next,04/20] bridge: vni: Report duplicate vni argument using duparg() https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=aeb7ee297361 - [iproute2-next,05/20] bridge: vni: Fix vni filter help strings https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=58c8a0817558 - [iproute2-next,06/20] bridge: vlan: Use printf() to avoid temporary buffer https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=cf7b528a21f6 - [iproute2-next,07/20] bridge: vlan: Remove paranoid check https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=0b8508f44d85 - [iproute2-next,08/20] bridge: vni: Remove print_vnifilter_rtm_filter() https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=060eac10e764 - [iproute2-next,09/20] bridge: vni: Move open_json_object() within print_vni() https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=b627c387eb5c - [iproute2-next,10/20] bridge: vni: Guard close_vni_port() call https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=7418335b4b43 - [iproute2-next,11/20] bridge: vni: Reverse the logic in print_vnifilter_rtm() https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=14c9845f05f8 - [iproute2-next,12/20] bridge: vni: Remove stray newlines after each interface https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=4f11b21e0257 - [iproute2-next,13/20] bridge: vni: Replace open-coded instance of print_nl() https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=7d8509d84c12 - [iproute2-next,14/20] bridge: vni: Remove unused argument in open_vni_port() https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=562b208a7b4d - [iproute2-next,15/20] bridge: vni: Align output columns https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=717f2f82f1da - [iproute2-next,16/20] bridge: vni: Indent statistics with 2 spaces https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=dd4e1749a977 - [iproute2-next,17/20] bridge: Deduplicate print_range() (no matching commit) - [iproute2-next,18/20] json_print: Output to temporary buffer in print_range() only as needed (no matching commit) - [iproute2-next,19/20] json_print: Rename print_range() argument (no matching commit) - [iproute2-next,20/20] bridge: Provide rta_type() https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=d205b5cf3877 You are awesome, thank you!
Stephen Hemminger <stephen@networkplumber.org> writes: > consider consolidating some of the patches. > Better to have 10 patches than 20. The original that I reviewed internally was 7 patches. I asked Benjamin to split some of it more, because it was tricky to figure out that all the changes in an individual patch cancel out exactly right to deliver what the commit message promised. But yeah, I bet there's a middle ground.