Message ID | 20231207194011.273027-2-pvorel@suse.cz (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Add support bcachefs filesystem | expand |
On Thu 07 Dec 2023 at 20:40, Petr Vorel <pvorel@suse.cz> wrote: > Signed-off-by: Petr Vorel <pvorel@suse.cz> > --- > New in v2 > > include/tst_fs.h | 3 +++ > lib/tst_fs_type.c | 2 ++ > 2 files changed, 5 insertions(+) > > diff --git a/include/tst_fs.h b/include/tst_fs.h > index eb9841165..06f5be896 100644 > --- a/include/tst_fs.h > +++ b/include/tst_fs.h > @@ -34,6 +34,9 @@ > #define TST_VFAT_MAGIC 0x4d44 /* AKA MSDOS */ > #define TST_EXFAT_MAGIC 0x2011BAB0UL > > +/* fs/bcachefs/bcachefs_format.h */ > +#define TST_BCACHE_MAGIC 0xca451a4e > + > Not object to the patch. There are three MAGIC values in bcachefs_format.h: BCACHE_MAGIC, BCHFS_MAGIC, BCACHEFS_STATFS_MAGIC. IIUC, BCACHE_MAGIC is the older one in superblock, BCHFS_MAGIC is the new one. BCACHEFS_STATFS_MAGIC is for statfs. Kent, Would you please export needed magic values to include/uapi/linux/magic.h? Since you are the maintainer also I'm confused about variables to be named. -- Su > enum tst_fill_access_pattern { > TST_FILL_BLOCKS, > TST_FILL_RANDOM > diff --git a/lib/tst_fs_type.c b/lib/tst_fs_type.c > index d9c9c0817..7f0d61a8e 100644 > --- a/lib/tst_fs_type.c > +++ b/lib/tst_fs_type.c > @@ -36,6 +36,8 @@ const char *tst_fs_type_name(long f_type) > return "9p"; > case TST_RAMFS_MAGIC: > return "ramfs"; > + case TST_BCACHE_MAGIC: > + return "bcachefs"; > case TST_BTRFS_MAGIC: > return "btrfs"; > case TST_XFS_MAGIC:
Hi all, > On Thu 07 Dec 2023 at 20:40, Petr Vorel <pvorel@suse.cz> wrote: > > Signed-off-by: Petr Vorel <pvorel@suse.cz> > > --- > > New in v2 > > include/tst_fs.h | 3 +++ > > lib/tst_fs_type.c | 2 ++ > > 2 files changed, 5 insertions(+) > > diff --git a/include/tst_fs.h b/include/tst_fs.h > > index eb9841165..06f5be896 100644 > > --- a/include/tst_fs.h > > +++ b/include/tst_fs.h > > @@ -34,6 +34,9 @@ > > #define TST_VFAT_MAGIC 0x4d44 /* AKA MSDOS */ > > #define TST_EXFAT_MAGIC 0x2011BAB0UL > > +/* fs/bcachefs/bcachefs_format.h */ > > +#define TST_BCACHE_MAGIC 0xca451a4e > > + > Not object to the patch. There are three MAGIC values in > bcachefs_format.h: BCACHE_MAGIC, BCHFS_MAGIC, BCACHEFS_STATFS_MAGIC. > IIUC, BCACHE_MAGIC is the older one in superblock, BCHFS_MAGIC is the > new one. BCACHEFS_STATFS_MAGIC is for statfs. > Kent, > Would you please export needed magic values to include/uapi/linux/magic.h? +1, very good idea. Kind regards, Petr > Since you are the maintainer also I'm confused about variables to be named.
diff --git a/include/tst_fs.h b/include/tst_fs.h index eb9841165..06f5be896 100644 --- a/include/tst_fs.h +++ b/include/tst_fs.h @@ -34,6 +34,9 @@ #define TST_VFAT_MAGIC 0x4d44 /* AKA MSDOS */ #define TST_EXFAT_MAGIC 0x2011BAB0UL +/* fs/bcachefs/bcachefs_format.h */ +#define TST_BCACHE_MAGIC 0xca451a4e + enum tst_fill_access_pattern { TST_FILL_BLOCKS, TST_FILL_RANDOM diff --git a/lib/tst_fs_type.c b/lib/tst_fs_type.c index d9c9c0817..7f0d61a8e 100644 --- a/lib/tst_fs_type.c +++ b/lib/tst_fs_type.c @@ -36,6 +36,8 @@ const char *tst_fs_type_name(long f_type) return "9p"; case TST_RAMFS_MAGIC: return "ramfs"; + case TST_BCACHE_MAGIC: + return "bcachefs"; case TST_BTRFS_MAGIC: return "btrfs"; case TST_XFS_MAGIC:
Signed-off-by: Petr Vorel <pvorel@suse.cz> --- New in v2 include/tst_fs.h | 3 +++ lib/tst_fs_type.c | 2 ++ 2 files changed, 5 insertions(+)