Message ID | d5fbdb05-d16a-4390-946e-22a5a7a1b56a@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | branch: error description when deleting a not fully merged branch | expand |
Rubén Justo <rjusto@gmail.com> writes: > [ ... ] > diff --git a/advice.h b/advice.h > index 0f584163f5..2affbe1426 100644 > --- a/advice.h > +++ b/advice.h > @@ -49,6 +49,7 @@ struct string_list; > ADVICE_UPDATE_SPARSE_PATH, > ADVICE_WAITING_FOR_EDITOR, > ADVICE_SKIPPED_CHERRY_PICKS, > + ADVICE_WORKTREE_ADD_ORPHAN, > }; > > Note the hunk header, instead of a much more expected: > > @@ -49,6 +49,7 @@ enum advice_type Next time, don't include "diff" output in the proposed log message without indenting. It makes it hard to read and parse. The attached is what I queued in my tree. Thanks. ------- >8 ------------- >8 ------------- >8 ------------- >8 ------- From: Rubén Justo <rjusto@gmail.com> Subject: [PATCH] advice: fix an unexpected leading space This space was introduced, presumably unintentionally, in b3b18d1621 (advice: revamp advise API, 2020-03-02) I notice this space due to confuse diff outputs while doing some changes to enum advice_type. As a reference, a recent change we have to that enum is: $ git show 35f0383 ... diff --git a/advice.h b/advice.h index 0f584163f5..2affbe1426 100644 --- a/advice.h +++ b/advice.h @@ -49,6 +49,7 @@ struct string_list; ADVICE_UPDATE_SPARSE_PATH, ADVICE_WAITING_FOR_EDITOR, ADVICE_SKIPPED_CHERRY_PICKS, + ADVICE_WORKTREE_ADD_ORPHAN, }; Note the hunk header, instead of a much more expected: @@ -49,6 +49,7 @@ enum advice_type Signed-off-by: Rubén Justo <rjusto@gmail.com> Signed-off-by: Junio C Hamano <gitster@pobox.com> --- advice.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/advice.h b/advice.h index 9396bcdcf1..74d44d1156 100644 --- a/advice.h +++ b/advice.h @@ -10,7 +10,7 @@ struct string_list; * Add the new config variable to Documentation/config/advice.txt. * Call advise_if_enabled to print your advice. */ - enum advice_type { +enum advice_type { ADVICE_ADD_EMBEDDED_REPO, ADVICE_ADD_EMPTY_PATHSPEC, ADVICE_ADD_IGNORED_FILE,
On 11-ene-2024 17:21:22, Junio C Hamano wrote: > Rubén Justo <rjusto@gmail.com> writes: > > > [ ... ] > > diff --git a/advice.h b/advice.h > > index 0f584163f5..2affbe1426 100644 > > --- a/advice.h > > +++ b/advice.h > > @@ -49,6 +49,7 @@ struct string_list; > > ADVICE_UPDATE_SPARSE_PATH, > > ADVICE_WAITING_FOR_EDITOR, > > ADVICE_SKIPPED_CHERRY_PICKS, > > + ADVICE_WORKTREE_ADD_ORPHAN, > > }; > > > > Note the hunk header, instead of a much more expected: > > > > @@ -49,6 +49,7 @@ enum advice_type > > Next time, don't include "diff" output in the proposed log message > without indenting. It makes it hard to read and parse. My fault. Sorry. Is there any way to make git-format-patch issue a warning or refuse to continue when the resulting patch is not going to be accepted by git-am? > > The attached is what I queued in my tree. Thanks.
Rubén Justo <rjusto@gmail.com> writes: > On 11-ene-2024 17:21:22, Junio C Hamano wrote: >> Rubén Justo <rjusto@gmail.com> writes: >> >> > [ ... ] >> > diff --git a/advice.h b/advice.h >> > index 0f584163f5..2affbe1426 100644 >> > --- a/advice.h >> > +++ b/advice.h >> > @@ -49,6 +49,7 @@ struct string_list; >> > ADVICE_UPDATE_SPARSE_PATH, >> > ADVICE_WAITING_FOR_EDITOR, >> > ADVICE_SKIPPED_CHERRY_PICKS, >> > + ADVICE_WORKTREE_ADD_ORPHAN, >> > }; >> > >> > Note the hunk header, instead of a much more expected: >> > >> > @@ -49,6 +49,7 @@ enum advice_type >> >> Next time, don't include "diff" output in the proposed log message >> without indenting. It makes it hard to read and parse. > > My fault. Sorry. > > Is there any way to make git-format-patch issue a warning or refuse to > continue when the resulting patch is not going to be accepted by git-am? I meant it as primarily to help human readers, but you are right, it will break "am". How about doing it in the pre-commit hook?
Junio C Hamano <gitster@pobox.com> writes:
> ... How about doing it in the pre-commit hook?
Sorry, as it runs before obtaining the proposed commit log message
and making a commit, pre-commit is a wrong one to use. I meant to
say commit-msg hook that is used to verify the contents of the
proposed commit log message.
diff --git a/advice.h b/advice.h index 0f584163f5..2affbe1426 100644 --- a/advice.h +++ b/advice.h @@ -49,6 +49,7 @@ struct string_list; ADVICE_UPDATE_SPARSE_PATH, ADVICE_WAITING_FOR_EDITOR, ADVICE_SKIPPED_CHERRY_PICKS, + ADVICE_WORKTREE_ADD_ORPHAN, }; Note the hunk header, instead of a much more expected: @@ -49,6 +49,7 @@ enum advice_type Signed-off-by: Rubén Justo <rjusto@gmail.com> --- advice.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/advice.h b/advice.h index 9396bcdcf1..74d44d1156 100644 --- a/advice.h +++ b/advice.h @@ -10,7 +10,7 @@ struct string_list; * Add the new config variable to Documentation/config/advice.txt. * Call advise_if_enabled to print your advice. */ - enum advice_type { +enum advice_type { ADVICE_ADD_EMBEDDED_REPO, ADVICE_ADD_EMPTY_PATHSPEC, ADVICE_ADD_IGNORED_FILE,