Message ID | 20240206075149.864996-3-claudiu.beznea.uj@bp.renesas.com (mailing list archive) |
---|---|
State | Superseded |
Delegated to: | Geert Uytterhoeven |
Headers | show |
Series | watchdog: rzg2l_wdt: Add support for RZ/G3S | expand |
Hi Claudiu, Thanks for your patch! On Tue, Feb 6, 2024 at 8:52 AM Claudiu <claudiu.beznea@tuxon.dev> wrote: > From: Claudiu Beznea <claudiu.beznea.uj@bp.renesas.com> > > The rzg2l_wdt watchdog driver cannot work w/o CONFIG_PM=y (e.g. the > clocks are enabled though pm_runtime_* specific APIs). To avoid building > a driver that don't work select CONFIG_PM. depend on? > Suggested-by: Guenter Roeck <linux@roeck-us.net> > Signed-off-by: Claudiu Beznea <claudiu.beznea.uj@bp.renesas.com> > --- a/drivers/watchdog/Kconfig > +++ b/drivers/watchdog/Kconfig > @@ -910,7 +910,7 @@ config RENESAS_RZN1WDT > > config RENESAS_RZG2LWDT > tristate "Renesas RZ/G2L WDT Watchdog" > - depends on ARCH_RZG2L || ARCH_R9A09G011 || COMPILE_TEST > + depends on ((ARCH_RZG2L || ARCH_R9A09G011) && PM) || COMPILE_TEST IMHO this is still a bit futile, as both ARCH_RZG2L and ARCH_R9A09G011 select PM, so this is always met. In addition, the "&& PM" clutters the logic, and makes the expression harder to read. If Günter insists on having the dependency, what about adding a separate line instead? depends on PM || COMPILE_TEST > select WATCHDOG_CORE > help > This driver adds watchdog support for the integrated watchdogs in the Gr{oetje,eeting}s, Geert
Hi, Geert, On 06.02.2024 10:34, Geert Uytterhoeven wrote: > Hi Claudiu, > > Thanks for your patch! > > On Tue, Feb 6, 2024 at 8:52 AM Claudiu <claudiu.beznea@tuxon.dev> wrote: >> From: Claudiu Beznea <claudiu.beznea.uj@bp.renesas.com> >> >> The rzg2l_wdt watchdog driver cannot work w/o CONFIG_PM=y (e.g. the >> clocks are enabled though pm_runtime_* specific APIs). To avoid building >> a driver that don't work select CONFIG_PM. > > depend on? I knew I missed something... > >> Suggested-by: Guenter Roeck <linux@roeck-us.net> >> Signed-off-by: Claudiu Beznea <claudiu.beznea.uj@bp.renesas.com> > >> --- a/drivers/watchdog/Kconfig >> +++ b/drivers/watchdog/Kconfig >> @@ -910,7 +910,7 @@ config RENESAS_RZN1WDT >> >> config RENESAS_RZG2LWDT >> tristate "Renesas RZ/G2L WDT Watchdog" >> - depends on ARCH_RZG2L || ARCH_R9A09G011 || COMPILE_TEST >> + depends on ((ARCH_RZG2L || ARCH_R9A09G011) && PM) || COMPILE_TEST > > IMHO this is still a bit futile, as both ARCH_RZG2L and ARCH_R9A09G011 > select PM, so this is always met. In addition, the "&& PM" clutters > the logic, and makes the expression harder to read. I agree with all these. > > If Günter insists on having the dependency, what about adding a > separate line instead? > > depends on PM || COMPILE_TEST OK for me. > >> select WATCHDOG_CORE >> help >> This driver adds watchdog support for the integrated watchdogs in the > > Gr{oetje,eeting}s, > > Geert >
diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig index f6cb63a0d889..27e11ea7eeeb 100644 --- a/drivers/watchdog/Kconfig +++ b/drivers/watchdog/Kconfig @@ -910,7 +910,7 @@ config RENESAS_RZN1WDT config RENESAS_RZG2LWDT tristate "Renesas RZ/G2L WDT Watchdog" - depends on ARCH_RZG2L || ARCH_R9A09G011 || COMPILE_TEST + depends on ((ARCH_RZG2L || ARCH_R9A09G011) && PM) || COMPILE_TEST select WATCHDOG_CORE help This driver adds watchdog support for the integrated watchdogs in the