Message ID | cover.1707491248.git.fdmanana@suse.com (mailing list archive) |
---|---|
Headers | show |
Series | btrfs: cleanups and minor performance change to setting/clearing delalloc | expand |
On Fri, Feb 09, 2024 at 06:00:42PM +0000, fdmanana@kernel.org wrote: > From: Filipe Manana <fdmanana@suse.com> > > Some cleanups and a minor performance improvement around setting and > clearing delalloc ranges. More details in the changelogs. These all LGTM. If you want to hunt more wins to claim for the inode lock improvement, you can also try running fsperf. Reviewed-by: Boris Burkov <boris@bur.io> > > Filipe Manana (9): > btrfs: stop passing root argument to btrfs_add_delalloc_inodes() > btrfs: stop passing root argument to __btrfs_del_delalloc_inode() > btrfs: assert root delalloc lock is held at __btrfs_del_delalloc_inode() > btrfs: rename btrfs_add_delalloc_inodes() to singular form > btrfs: reduce inode lock critical section when setting and clearing delalloc > btrfs: add lockdep assertion to remaining delalloc callbacks > btrfs: use assertion instead of BUG_ON when adding/removing to delalloc list > btrfs: remove do_list variable at btrfs_set_delalloc_extent() > btrfs: remove do_list variable at btrfs_clear_delalloc_extent() > > fs/btrfs/btrfs_inode.h | 3 +- > fs/btrfs/disk-io.c | 2 +- > fs/btrfs/inode.c | 93 ++++++++++++++++++++++++++---------------- > 3 files changed, 60 insertions(+), 38 deletions(-) > > -- > 2.40.1 >
From: Filipe Manana <fdmanana@suse.com> Some cleanups and a minor performance improvement around setting and clearing delalloc ranges. More details in the changelogs. Filipe Manana (9): btrfs: stop passing root argument to btrfs_add_delalloc_inodes() btrfs: stop passing root argument to __btrfs_del_delalloc_inode() btrfs: assert root delalloc lock is held at __btrfs_del_delalloc_inode() btrfs: rename btrfs_add_delalloc_inodes() to singular form btrfs: reduce inode lock critical section when setting and clearing delalloc btrfs: add lockdep assertion to remaining delalloc callbacks btrfs: use assertion instead of BUG_ON when adding/removing to delalloc list btrfs: remove do_list variable at btrfs_set_delalloc_extent() btrfs: remove do_list variable at btrfs_clear_delalloc_extent() fs/btrfs/btrfs_inode.h | 3 +- fs/btrfs/disk-io.c | 2 +- fs/btrfs/inode.c | 93 ++++++++++++++++++++++++++---------------- 3 files changed, 60 insertions(+), 38 deletions(-)