Message ID | 20240325044452.3125418-5-dlemoal@kernel.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Zone write plugging | expand |
On 3/24/24 21:44, Damien Le Moal wrote: > +static inline bool bio_straddle_zones(struct bio *bio) > +{ > + return bio_sectors(bio) && > + bio_zone_no(bio) != > + disk_zone_no(bio->bi_bdev->bd_disk, bio_end_sector(bio) - 1); > +} Please rename bio_straddle_zones() into bio_straddles_zones() (grammar). Thanks, Bart.
On Mon, Mar 25, 2024 at 01:44:28PM +0900, Damien Le Moal wrote: > Implement the inline helper functions bio_straddle_zones() and > bio_offset_from_zone_start() to respectively test if a BIO crosses a > zone boundary (the start sector and last sector belong to different > zones) and to obtain the offset of a BIO from the start sector of its > target zone. Looks good: Reviewed-by: Christoph Hellwig <hch@lst.de> (the grammar fix from Bart looks good as well)
diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h index c3e8f7cf96be..93f93f352b54 100644 --- a/include/linux/blkdev.h +++ b/include/linux/blkdev.h @@ -853,6 +853,13 @@ static inline unsigned int bio_zone_no(struct bio *bio) return disk_zone_no(bio->bi_bdev->bd_disk, bio->bi_iter.bi_sector); } +static inline bool bio_straddle_zones(struct bio *bio) +{ + return bio_sectors(bio) && + bio_zone_no(bio) != + disk_zone_no(bio->bi_bdev->bd_disk, bio_end_sector(bio) - 1); +} + static inline unsigned int bio_zone_is_seq(struct bio *bio) { return disk_zone_is_seq(bio->bi_bdev->bd_disk, bio->bi_iter.bi_sector); @@ -1328,6 +1335,12 @@ static inline sector_t bdev_offset_from_zone_start(struct block_device *bdev, return sector & (bdev_zone_sectors(bdev) - 1); } +static inline sector_t bio_offset_from_zone_start(struct bio *bio) +{ + return bdev_offset_from_zone_start(bio->bi_bdev, + bio->bi_iter.bi_sector); +} + static inline bool bdev_is_zone_start(struct block_device *bdev, sector_t sector) {