Message ID | ee371cf7-69fa-4f9c-99b9-59bab86f25e4@p183 (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | module: ban '.', '..' as module names, ban '/' in module names | expand |
On Sun, Apr 14, 2024 at 10:05:05PM +0300, Alexey Dobriyan wrote: > --- a/include/linux/fs.h > +++ b/include/linux/fs.h > @@ -3616,4 +3616,12 @@ extern int vfs_fadvise(struct file *file, loff_t offset, loff_t len, > extern int generic_fadvise(struct file *file, loff_t offset, loff_t len, > int advice); > > +/* > + * Use this if data from userspace end up as directory/filename on > + * some virtual filesystem. > + */ > +static inline bool string_is_vfs_ready(const char *s) > +{ > + return strcmp(s, ".") != 0 && strcmp(s, "..") != 0 && !strchr(s, '/'); > +} > #endif /* _LINUX_FS_H */ > --- a/kernel/module/main.c > +++ b/kernel/module/main.c > @@ -2893,6 +2893,11 @@ static int load_module(struct load_info *info, const char __user *uargs, > > audit_log_kern_module(mod->name); > > + if (!string_is_vfs_ready(mod->name)) { > + err = -EINVAL; > + goto free_module; > + } > + Sensible change however to put string_is_vfs_ready() in include/linux/fs.h is a stretch if there really are no other users. Luis
On Sun, Apr 14, 2024 at 10:05:05PM +0300, Alexey Dobriyan wrote: > Any other subsystem should use nice helper function aptly named > > string_is_vfs_ready() > > and apply additional restrictions if necessary. > > /proc/modules hints that newlines should be banned too, > and \x1f, and whitespace, and similar looking characters > from different languages and emojis (except
Looks good:
Reviewed-by: Christoph Hellwig <hch@lst.de>
On Sun, Apr 14, 2024 at 01:58:55PM -0700, Luis Chamberlain wrote: > On Sun, Apr 14, 2024 at 10:05:05PM +0300, Alexey Dobriyan wrote: > > --- a/include/linux/fs.h > > +++ b/include/linux/fs.h > > @@ -3616,4 +3616,12 @@ extern int vfs_fadvise(struct file *file, loff_t offset, loff_t len, > > extern int generic_fadvise(struct file *file, loff_t offset, loff_t len, > > int advice); > > > > +/* > > + * Use this if data from userspace end up as directory/filename on > > + * some virtual filesystem. > > + */ > > +static inline bool string_is_vfs_ready(const char *s) > > +{ > > + return strcmp(s, ".") != 0 && strcmp(s, "..") != 0 && !strchr(s, '/'); > > +} > > #endif /* _LINUX_FS_H */ > > --- a/kernel/module/main.c > > +++ b/kernel/module/main.c > > @@ -2893,6 +2893,11 @@ static int load_module(struct load_info *info, const char __user *uargs, > > > > audit_log_kern_module(mod->name); > > > > + if (!string_is_vfs_ready(mod->name)) { > > + err = -EINVAL; > > + goto free_module; > > + } > > + > > Sensible change however to put string_is_vfs_ready() in include/linux/fs.h > is a stretch if there really are no other users. This is forward thinking patch :-) Other subsystems may create files/directories in proc/sysfs, and should check for bad names as well: /proc/2821/net/dev_snmp6/eth0 This looks exactly like something coming from userspace and making it into /proc, so the filter function doesn't belong to kernel/module/internal.h
* Alexey Dobriyan (adobriyan@gmail.com) wrote: > On Sun, Apr 14, 2024 at 01:58:55PM -0700, Luis Chamberlain wrote: > > On Sun, Apr 14, 2024 at 10:05:05PM +0300, Alexey Dobriyan wrote: > > > --- a/include/linux/fs.h > > > +++ b/include/linux/fs.h > > > @@ -3616,4 +3616,12 @@ extern int vfs_fadvise(struct file *file, loff_t offset, loff_t len, > > > extern int generic_fadvise(struct file *file, loff_t offset, loff_t len, > > > int advice); > > > > > > +/* > > > + * Use this if data from userspace end up as directory/filename on > > > + * some virtual filesystem. > > > + */ > > > +static inline bool string_is_vfs_ready(const char *s) > > > +{ > > > + return strcmp(s, ".") != 0 && strcmp(s, "..") != 0 && !strchr(s, '/'); > > > +} > > > #endif /* _LINUX_FS_H */ > > > --- a/kernel/module/main.c > > > +++ b/kernel/module/main.c > > > @@ -2893,6 +2893,11 @@ static int load_module(struct load_info *info, const char __user *uargs, > > > > > > audit_log_kern_module(mod->name); > > > > > > + if (!string_is_vfs_ready(mod->name)) { > > > + err = -EINVAL; > > > + goto free_module; > > > + } > > > + > > > > Sensible change however to put string_is_vfs_ready() in include/linux/fs.h > > is a stretch if there really are no other users. > > This is forward thinking patch :-) > > Other subsystems may create files/directories in proc/sysfs, and should > check for bad names as well: > > /proc/2821/net/dev_snmp6/eth0 > > This looks exactly like something coming from userspace and making it > into /proc, so the filter function doesn't belong to kernel/module/internal.h You mean like: [24180.292204] tuxthe____: renamed from tuxthe
--- a/include/linux/fs.h +++ b/include/linux/fs.h @@ -3616,4 +3616,12 @@ extern int vfs_fadvise(struct file *file, loff_t offset, loff_t len, extern int generic_fadvise(struct file *file, loff_t offset, loff_t len, int advice); +/* + * Use this if data from userspace end up as directory/filename on + * some virtual filesystem. + */ +static inline bool string_is_vfs_ready(const char *s) +{ + return strcmp(s, ".") != 0 && strcmp(s, "..") != 0 && !strchr(s, '/'); +} #endif /* _LINUX_FS_H */ --- a/kernel/module/main.c +++ b/kernel/module/main.c @@ -2893,6 +2893,11 @@ static int load_module(struct load_info *info, const char __user *uargs, audit_log_kern_module(mod->name); + if (!string_is_vfs_ready(mod->name)) { + err = -EINVAL; + goto free_module; + } + /* Reserve our place in the list. */ err = add_unformed_module(mod); if (err)