Message ID | 20240528191823.17775-3-admiyo@os.amperecomputing.com (mailing list archive) |
---|---|
State | Changes Requested |
Headers | show |
Series | MCTP over PCC | expand |
On 2024-05-29 at 00:48:22, admiyo@os.amperecomputing.com (admiyo@os.amperecomputing.com) wrote: > From: Adam Young <admiyo@amperecomputing.com> > --- a/drivers/acpi/acpica/rsaddr.c > +++ b/drivers/acpi/acpica/rsaddr.c > @@ -282,7 +282,7 @@ acpi_rs_get_address_common(struct acpi_resource *resource, > > /* Validate the Resource Type */ > > - if ((address.resource_type > 2) && (address.resource_type < 0xC0)) { > + if ((address.resource_type > 2) && (address.resource_type < 0xC0) && (address.resource_type != 10)) { use macros or enums instead of hard coded numbers. That will improve code readability. > return (FALSE); > } > > -- > 2.34.1 >
On 5/28/24 23:25, Ratheesh Kannoth wrote: > On 2024-05-29 at 00:48:22, admiyo@os.amperecomputing.com (admiyo@os.amperecomputing.com) wrote: >> From: Adam Young <admiyo@amperecomputing.com> >> --- a/drivers/acpi/acpica/rsaddr.c >> +++ b/drivers/acpi/acpica/rsaddr.c >> @@ -282,7 +282,7 @@ acpi_rs_get_address_common(struct acpi_resource *resource, >> >> /* Validate the Resource Type */ >> >> - if ((address.resource_type > 2) && (address.resource_type < 0xC0)) { >> + if ((address.resource_type > 2) && (address.resource_type < 0xC0) && (address.resource_type != 10)) { > use macros or enums instead of hard coded numbers. That will improve code readability. In general I agree, but this code is generated from ACPICA and will not be directly commited. The corresponding patch to acpica has already merged. What you see here is what the code will look like post-process from ACPICA conversion. > >> return (FALSE); >> } >> >> -- >> 2.34.1 >>
diff --git a/drivers/acpi/acpica/rsaddr.c b/drivers/acpi/acpica/rsaddr.c index fff48001d7ef..6bd9704f17b0 100644 --- a/drivers/acpi/acpica/rsaddr.c +++ b/drivers/acpi/acpica/rsaddr.c @@ -282,7 +282,7 @@ acpi_rs_get_address_common(struct acpi_resource *resource, /* Validate the Resource Type */ - if ((address.resource_type > 2) && (address.resource_type < 0xC0)) { + if ((address.resource_type > 2) && (address.resource_type < 0xC0) && (address.resource_type != 10)) { return (FALSE); }