Message ID | 20240531131142.1716-1-ilpo.jarvinen@linux.intel.com (mailing list archive) |
---|---|
Headers | show |
Series | selftests/resctrl: resctrl_val() related cleanups & improvements | expand |
Tested the series. Tested-by: Babu Moger <babu.moger@amd.com> On 5/31/2024 8:11 AM, Ilpo Järvinen wrote: > Hi all, > > This series does a number of cleanups into resctrl_val() and > generalizes it by removing test name specific handling from the > function. > > Hopefully these reach also Shuah successfully as I've recently seen > rejects for mail from @linux.intel.com to gmail addresses. > > v5: > - Open mem bw file only once and use rewind(). > - Add \n to mem bw file read to allow reading fresh values from the file. > - Return 0 if create_grp() is given NULL grp_name (matches the original > behavior). Mention this in function's kerneldoc. > - Cast pid_t to int before printing with %d. > - Caps/typo fixes to kerneldoc and commit messages. > - Use imperative tone in commit messages and improve them based on points > that came up during review. > > v4: > - Merged close fix into IMC READ+WRITE rework patch > - Add loop to reset imc_counters_config fds to -1 to be able know which > need closing > - Introduce perf_close_imc_mem_bw() to close fds > - Open resctrl mem bw file (twice) beforehand to avoid opening it during > the test > - Remove MBM .mongrp setup > - Remove mongrp from CMT test > > v3: > - Rename init functions to <testname>_init() > - Replace for loops with READ+WRITE statements for clarity > - Don't drop Return: entry from perf_open_imc_mem_bw() func comment > - New patch: Fix closing of IMC fds in case of error > - New patch: Make "bandwidth" consistent in comments & prints > - New patch: Simplify mem bandwidth file code > - Remove wrong comment > - Changed grp_name check to return -1 on fail (internal sanity check) > > v2: > - Resolved conflicts with kselftest/next > - Spaces -> tabs correction > > Ilpo Järvinen (16): > selftests/resctrl: Fix closing IMC fds on error and open-code R+W > instead of loops > selftests/resctrl: Calculate resctrl FS derived mem bw over sleep(1) > only > selftests/resctrl: Make "bandwidth" consistent in comments & prints > selftests/resctrl: Consolidate get_domain_id() into resctrl_val() > selftests/resctrl: Use correct type for pids > selftests/resctrl: Cleanup bm_pid and ppid usage & limit scope > selftests/resctrl: Rename measure_vals() to measure_mem_bw_vals() & > document > selftests/resctrl: Simplify mem bandwidth file code for MBA & MBM > tests > selftests/resctrl: Add ->measure() callback to resctrl_val_param > selftests/resctrl: Add ->init() callback into resctrl_val_param > selftests/resctrl: Simplify bandwidth report type handling > selftests/resctrl: Make some strings passed to resctrlfs functions > const > selftests/resctrl: Convert ctrlgrp & mongrp to pointers > selftests/resctrl: Remove mongrp from MBA test > selftests/resctrl: Remove mongrp from CMT test > selftests/resctrl: Remove test name comparing from > write_bm_pid_to_resctrl() > > tools/testing/selftests/resctrl/cache.c | 10 +- > tools/testing/selftests/resctrl/cat_test.c | 5 +- > tools/testing/selftests/resctrl/cmt_test.c | 22 +- > tools/testing/selftests/resctrl/mba_test.c | 26 +- > tools/testing/selftests/resctrl/mbm_test.c | 26 +- > tools/testing/selftests/resctrl/resctrl.h | 49 ++- > tools/testing/selftests/resctrl/resctrl_val.c | 364 ++++++++---------- > tools/testing/selftests/resctrl/resctrlfs.c | 67 ++-- > 8 files changed, 290 insertions(+), 279 deletions(-) >