Message ID | 20240830171443.3532077-1-kuba@kernel.org (mailing list archive) |
---|---|
State | Accepted |
Commit | c82299fbbccecf5866bdc3fa9cc46d5c6f5005ad |
Delegated to: | Netdev Maintainers |
Headers | show |
Series | [net,v2] docs: netdev: document guidance on cleanup.h | expand |
On Fri, Aug 30, 2024 at 10:14:42AM -0700, Jakub Kicinski wrote: > Document what was discussed multiple times on list and various > virtual / in-person conversations. guard() being okay in functions > <= 20 LoC is a bit of my own invention. If the function is trivial > it should be fine, but feel free to disagree :) > > We'll obviously revisit this guidance as time passes and we and other > subsystems get more experience. > > Reviewed-by: Eric Dumazet <edumazet@google.com> > Reviewed-by: Nikolay Aleksandrov <razor@blackwall.org> > Reviewed-by: Andrew Lunn <andrew@lunn.ch> > Signed-off-by: Jakub Kicinski <kuba@kernel.org> > --- > CC: horms@kernel.org > CC: corbet@lwn.net > CC: linux-doc@vger.kernel.org > > v2: > - add sentence about revisiting later to commit msg > - fix spelling > v1: https://lore.kernel.org/20240829152025.3203577-1-kuba@kernel.org Thanks. I think this patch has enough tags, so I won't add another. But, FTR, this version looks good to me. ...
Hello: This patch was applied to netdev/net.git (main) by Paolo Abeni <pabeni@redhat.com>: On Fri, 30 Aug 2024 10:14:42 -0700 you wrote: > Document what was discussed multiple times on list and various > virtual / in-person conversations. guard() being okay in functions > <= 20 LoC is a bit of my own invention. If the function is trivial > it should be fine, but feel free to disagree :) > > We'll obviously revisit this guidance as time passes and we and other > subsystems get more experience. > > [...] Here is the summary with links: - [net,v2] docs: netdev: document guidance on cleanup.h https://git.kernel.org/netdev/net/c/c82299fbbcce You are awesome, thank you!
diff --git a/Documentation/process/maintainer-netdev.rst b/Documentation/process/maintainer-netdev.rst index 30d24eecdaaa..c9edf9e7362d 100644 --- a/Documentation/process/maintainer-netdev.rst +++ b/Documentation/process/maintainer-netdev.rst @@ -375,6 +375,22 @@ When working in existing code which uses nonstandard formatting make your code follow the most recent guidelines, so that eventually all code in the domain of netdev is in the preferred format. +Using device-managed and cleanup.h constructs +~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + +Netdev remains skeptical about promises of all "auto-cleanup" APIs, +including even ``devm_`` helpers, historically. They are not the preferred +style of implementation, merely an acceptable one. + +Use of ``guard()`` is discouraged within any function longer than 20 lines, +``scoped_guard()`` is considered more readable. Using normal lock/unlock is +still (weakly) preferred. + +Low level cleanup constructs (such as ``__free()``) can be used when building +APIs and helpers, especially scoped iterators. However, direct use of +``__free()`` within networking core and drivers is discouraged. +Similar guidance applies to declaring variables mid-function. + Resending after review ~~~~~~~~~~~~~~~~~~~~~~