Message ID | 20240911-devel-anna-maria-b4-timers-flseep-v2-0-b0d3f33ccfe0@linutronix.de (mailing list archive) |
---|---|
Headers | show |
Series | timers: Cleanup delay/sleep related mess | expand |
Le 11/09/2024 à 07:13, Anna-Maria Behnsen a écrit : > Hi, > > a question about which sleeping function should be used in acpi_os_sleep() > started a discussion and examination about the existing documentation and > implementation of functions which insert a sleep/delay. > > The result of the discussion was, that the documentation is outdated and > the implemented fsleep() reflects the outdated documentation but doesn't > help to reflect reality which in turns leads to the queue which covers the > following things: > > - Split out all timeout and sleep related functions from hrtimer.c and timer.c > into a separate file > > - Update function descriptions of sleep related functions > > - Change fsleep() to reflect reality > > - Rework all comments or users which obviously rely on the outdated > documentation as they reference "Documentation/timers/timers-howto.rst" > > - Last but not least (as there are no more references): Update the outdated > documentation and move it into a file with a self explaining file name > > The queue is available here and applies on top of tip/timers/core: > > git://git.kernel.org/pub/scm/linux/kernel/git/anna-maria/linux-devel.git timers/misc > > Signed-off-by: Anna-Maria Behnsen <anna-maria@linutronix.de> Hi, not directly related to your serie, but some time ago I sent a patch to micro-optimize Optimize usleep_range(). (See [1]) The idea is that the 2 parameters of usleep_range() are usually constants and some code reordering could easily let the compiler compute a few things at compilation time. There was consensus on the value of the change (see [2]), but as you are touching things here, maybe it makes sense now to save a few cycles at runtime and a few bytes of code? CJ [1]: https://lore.kernel.org/all/f0361b83a0a0b549f8ec5ab8134905001a6f2509.1659126514.git.christophe.jaillet@wanadoo.fr/ [2]: https://lore.kernel.org/all/03c2bbe795fe4ddcab66eb852bae3715@AcuMS.aculab.com/
Le 16/09/2024 à 22:20, Christophe JAILLET a écrit : > Le 11/09/2024 à 07:13, Anna-Maria Behnsen a écrit : >> Hi, >> >> a question about which sleeping function should be used in >> acpi_os_sleep() >> started a discussion and examination about the existing documentation and >> implementation of functions which insert a sleep/delay. >> >> The result of the discussion was, that the documentation is outdated and >> the implemented fsleep() reflects the outdated documentation but doesn't >> help to reflect reality which in turns leads to the queue which covers >> the >> following things: >> >> - Split out all timeout and sleep related functions from hrtimer.c and >> timer.c >> into a separate file >> >> - Update function descriptions of sleep related functions >> >> - Change fsleep() to reflect reality >> >> - Rework all comments or users which obviously rely on the outdated >> documentation as they reference "Documentation/timers/timers- >> howto.rst" >> >> - Last but not least (as there are no more references): Update the >> outdated >> documentation and move it into a file with a self explaining file name >> >> The queue is available here and applies on top of tip/timers/core: >> >> git://git.kernel.org/pub/scm/linux/kernel/git/anna-maria/linux- >> devel.git timers/misc >> >> Signed-off-by: Anna-Maria Behnsen <anna-maria@linutronix.de> > > Hi, > > not directly related to your serie, but some time ago I sent a patch to > micro-optimize Optimize usleep_range(). (See [1]) > > The idea is that the 2 parameters of usleep_range() are usually > constants and some code reordering could easily let the compiler compute > a few things at compilation time. > > There was consensus on the value of the change (see [2]), but as you are Typo: there was *no* consensus... > touching things here, maybe it makes sense now to save a few cycles at > runtime and a few bytes of code? > > CJ > > [1]: https://lore.kernel.org/all/ > f0361b83a0a0b549f8ec5ab8134905001a6f2509.1659126514.git.christophe.jaillet@wanadoo.fr/ > > [2]: https://lore.kernel.org/ > all/03c2bbe795fe4ddcab66eb852bae3715@AcuMS.aculab.com/ > > > >
Christophe JAILLET <christophe.jaillet@wanadoo.fr> writes: > Le 16/09/2024 à 22:20, Christophe JAILLET a écrit : >> Le 11/09/2024 à 07:13, Anna-Maria Behnsen a écrit : >>> Hi, >>> >>> a question about which sleeping function should be used in >>> acpi_os_sleep() >>> started a discussion and examination about the existing documentation and >>> implementation of functions which insert a sleep/delay. >>> >>> The result of the discussion was, that the documentation is outdated and >>> the implemented fsleep() reflects the outdated documentation but doesn't >>> help to reflect reality which in turns leads to the queue which covers >>> the >>> following things: >>> >>> - Split out all timeout and sleep related functions from hrtimer.c and >>> timer.c >>> into a separate file >>> >>> - Update function descriptions of sleep related functions >>> >>> - Change fsleep() to reflect reality >>> >>> - Rework all comments or users which obviously rely on the outdated >>> documentation as they reference "Documentation/timers/timers- >>> howto.rst" >>> >>> - Last but not least (as there are no more references): Update the >>> outdated >>> documentation and move it into a file with a self explaining file name >>> >>> The queue is available here and applies on top of tip/timers/core: >>> >>> git://git.kernel.org/pub/scm/linux/kernel/git/anna-maria/linux- >>> devel.git timers/misc >>> >>> Signed-off-by: Anna-Maria Behnsen <anna-maria@linutronix.de> >> >> Hi, >> >> not directly related to your serie, but some time ago I sent a patch to >> micro-optimize Optimize usleep_range(). (See [1]) >> >> The idea is that the 2 parameters of usleep_range() are usually >> constants and some code reordering could easily let the compiler compute >> a few things at compilation time. >> >> There was consensus on the value of the change (see [2]), but as you are > > Typo: there was *no* consensus... > >> touching things here, maybe it makes sense now to save a few cycles at >> runtime and a few bytes of code? >> Sorry for the late reply. I'll check it and will come back to you. Thanks, Anna-Maria
On Mon, Sep 16 2024 at 22:20, Christophe JAILLET wrote: > Le 11/09/2024 à 07:13, Anna-Maria Behnsen a écrit : > > not directly related to your serie, but some time ago I sent a patch to > micro-optimize Optimize usleep_range(). (See [1]) > > The idea is that the 2 parameters of usleep_range() are usually > constants and some code reordering could easily let the compiler compute > a few things at compilation time. > > There was consensus on the value of the change (see [2]), but as you are > touching things here, maybe it makes sense now to save a few cycles at > runtime and a few bytes of code? For the price of yet another ugly interface and pushing the multiplication into the non-constant call sites. Seriously usleep() is not a hotpath operation and the multiplication is not even measurable except in micro benchmarks. Thanks, tglx
Hi, a question about which sleeping function should be used in acpi_os_sleep() started a discussion and examination about the existing documentation and implementation of functions which insert a sleep/delay. The result of the discussion was, that the documentation is outdated and the implemented fsleep() reflects the outdated documentation but doesn't help to reflect reality which in turns leads to the queue which covers the following things: - Split out all timeout and sleep related functions from hrtimer.c and timer.c into a separate file - Update function descriptions of sleep related functions - Change fsleep() to reflect reality - Rework all comments or users which obviously rely on the outdated documentation as they reference "Documentation/timers/timers-howto.rst" - Last but not least (as there are no more references): Update the outdated documentation and move it into a file with a self explaining file name The queue is available here and applies on top of tip/timers/core: git://git.kernel.org/pub/scm/linux/kernel/git/anna-maria/linux-devel.git timers/misc Signed-off-by: Anna-Maria Behnsen <anna-maria@linutronix.de> --- Changes in v2: - change udelay() and ndelay() as suggested by Thomas - Update some formatting in the new sleep_timeout.c file - minor typo changes and other small review remarks Thanks, Anna-Maria --- Anna-Maria Behnsen (15): MAINTAINERS: Add missing file include/linux/delay.h timers: Move *sleep*() and timeout functions into a separate file timers: Update schedule_[hr]timeout*() related function descriptions timers: Rename usleep_idle_range() to usleep_range_idle() timers: Update function descriptions of sleep/delay related functions delay: Rework udelay and ndelay timers: Adjust flseep() to reflect reality mm/damon/core: Use generic upper bound recommondation for usleep_range() timers: Add a warning to usleep_range_state() for wrong order of arguments checkpatch: Remove broken sleep/delay related checks regulator: core: Use fsleep() to get best sleep mechanism iopoll/regmap/phy/snd: Fix comment referencing outdated timer documentation powerpc/rtas: Use fsleep() to minimize additional sleep duration media: anysee: Fix link to outdated sleep function documentation timers/Documentation: Cleanup delay/sleep documentation Documentation/dev-tools/checkpatch.rst | 6 - Documentation/timers/delay_sleep_functions.rst | 122 ++++++++ Documentation/timers/index.rst | 2 +- Documentation/timers/timers-howto.rst | 115 -------- MAINTAINERS | 2 + arch/powerpc/kernel/rtas.c | 21 +- drivers/media/usb/dvb-usb-v2/anysee.c | 6 +- drivers/regulator/core.c | 47 +--- include/asm-generic/delay.h | 95 +++++-- include/linux/delay.h | 79 ++++-- include/linux/iopoll.h | 52 ++-- include/linux/phy.h | 9 +- include/linux/regmap.h | 38 +-- kernel/time/Makefile | 2 +- kernel/time/hrtimer.c | 120 -------- kernel/time/sleep_timeout.c | 376 +++++++++++++++++++++++++ kernel/time/timer.c | 192 ------------- mm/damon/core.c | 5 +- scripts/checkpatch.pl | 38 --- sound/soc/sof/ops.h | 8 +- 20 files changed, 701 insertions(+), 634 deletions(-)