mbox series

[0/5] Improve error handling in Rockchip SPI drivers

Message ID cover.1727337732.git.dsimic@manjaro.org (mailing list archive)
Headers show
Series Improve error handling in Rockchip SPI drivers | expand

Message

Dragan Simic Sept. 26, 2024, 8:38 a.m. UTC
This is a small series that improves error handling in the probe path
of the Rockchip SPI drivers, by using dev_err_probe() properly in multiple
places.  It also removes one unnecessary check of a function return value,
and performs a bunch of small, rather trivial code cleanups, to make the
code neater and a bit easier to read.

Dragan Simic (5):
  spi: rockchip: Perform trivial code cleanups
  spi: rockchip-sfc: Perform trivial code cleanups
  spi: rockchip: Don't check for failed get_fifo_len()
  spi: rockchip: Use dev_err_probe() in the probe path
  spi: rockchip-sfc: Use dev_err_probe() in the probe path

 drivers/spi/spi-rockchip-sfc.c | 21 +++++--------
 drivers/spi/spi-rockchip.c     | 57 ++++++++++++++--------------------
 2 files changed, 32 insertions(+), 46 deletions(-)

Comments

Heiko Stuebner Sept. 26, 2024, 9:01 a.m. UTC | #1
Am Donnerstag, 26. September 2024, 10:38:16 CEST schrieb Dragan Simic:
> Use function dev_err_probe() in the probe path instead of dev_err() where
> appropriate, to make the code a bit more uniform and compact.
> 
> Signed-off-by: Dragan Simic <dsimic@manjaro.org>

Reviewed-by: Heiko Stuebner <heiko@sntech.de>