mbox series

[v10,0/2] x86/boot: Improve MBI2 structure check (was: Reduce assembly code)

Message ID 20241015082513.2477806-1-frediano.ziglio@cloud.com (mailing list archive)
Headers show
Series x86/boot: Improve MBI2 structure check (was: Reduce assembly code) | expand

Message

Frediano Ziglio Oct. 15, 2024, 8:25 a.m. UTC
This series came from part of the work of removing duplications between
boot code and rewriting part of code from assembly to C.

Changes since v1, more details in specific commits:
- style updates;
- comments and descriptions improvements;
- other improvements.

Changes since v2:
- rebased on master, resolved conflicts;
- add comment on trampoline section.

Changes since v3:
- changed new function name;
- declare efi_multiboot2 in a separate header;
- distinguish entry point from using magic number;
- other minor changes (see commens in commits).

Changes since v4:
- rebase on staging;
- set %fs and %gs as other segment registers;
- style and other changes.

Changes since v5:
- fixed a typo.

Changes since v6:
- remove merged patch;
- comment and style;
- change some pointer checks to avoid overflows;
- rename parse-mbi2.c to mbi2.c.

Changes since v7:
- removed merged parts;
- add required stack alignment.

Changes since v8:
- added "Fixes:" line;
- typo in commit message: Adler -> Alder;
- add ".init" to mbi2.o;
- reduce difference in Makefile.

Changes since v9:
- minor messages updates.

Frediano Ziglio (2):
  x86/boot: Align mbi2.c stack to 16 bytes
  x86/boot: Improve MBI2 structure check

 xen/arch/x86/efi/Makefile | 4 ++--
 xen/arch/x86/efi/mbi2.c   | 7 +++++--
 2 files changed, 7 insertions(+), 4 deletions(-)

Comments

Marek Marczykowski-Górecki Oct. 15, 2024, 12:59 p.m. UTC | #1
On Tue, Oct 15, 2024 at 09:25:11AM +0100, Frediano Ziglio wrote:
> This series came from part of the work of removing duplications between
> boot code and rewriting part of code from assembly to C.

Acked-by: Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com>

> Changes since v1, more details in specific commits:
> - style updates;
> - comments and descriptions improvements;
> - other improvements.
> 
> Changes since v2:
> - rebased on master, resolved conflicts;
> - add comment on trampoline section.
> 
> Changes since v3:
> - changed new function name;
> - declare efi_multiboot2 in a separate header;
> - distinguish entry point from using magic number;
> - other minor changes (see commens in commits).
> 
> Changes since v4:
> - rebase on staging;
> - set %fs and %gs as other segment registers;
> - style and other changes.
> 
> Changes since v5:
> - fixed a typo.
> 
> Changes since v6:
> - remove merged patch;
> - comment and style;
> - change some pointer checks to avoid overflows;
> - rename parse-mbi2.c to mbi2.c.
> 
> Changes since v7:
> - removed merged parts;
> - add required stack alignment.
> 
> Changes since v8:
> - added "Fixes:" line;
> - typo in commit message: Adler -> Alder;
> - add ".init" to mbi2.o;
> - reduce difference in Makefile.
> 
> Changes since v9:
> - minor messages updates.
> 
> Frediano Ziglio (2):
>   x86/boot: Align mbi2.c stack to 16 bytes
>   x86/boot: Improve MBI2 structure check
> 
>  xen/arch/x86/efi/Makefile | 4 ++--
>  xen/arch/x86/efi/mbi2.c   | 7 +++++--
>  2 files changed, 7 insertions(+), 4 deletions(-)
> 
> -- 
> 2.34.1
>
Andrew Cooper Oct. 15, 2024, 5:51 p.m. UTC | #2
On 15/10/2024 1:59 pm, Marek Marczykowski-Górecki wrote:
> On Tue, Oct 15, 2024 at 09:25:11AM +0100, Frediano Ziglio wrote:
>> This series came from part of the work of removing duplications between
>> boot code and rewriting part of code from assembly to C.
> Acked-by: Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com>

I've committed this series, but I've rewritten the commit message on
patch 1.

As presented, that's a set of debugging notes of how the patch ended up
the way it did, not an explanation of the problem and how it is being
addressed.

~Andrew