mbox series

[v2,0/2] btrfs: unify the read and writer locks for btrfs_subpage

Message ID cover.1728452897.git.wqu@suse.com (mailing list archive)
Headers show
Series btrfs: unify the read and writer locks for btrfs_subpage | expand

Message

Qu Wenruo Oct. 9, 2024, 5:51 a.m. UTC
[CHANGELOG]
v2:
- Rename btrfs_subpage::locked to btrfs_subpage::nr_locked

When the handling of sector size < page size is introduced, there are
two types of locking, reader and writer lock.

The main reason for the reader lock is to handle metadata to make sure
the page::private is not released when there is still a metadata being
read.

However since commit d7172f52e993 ("btrfs: use per-buffer locking for
extent_buffer reading"), metadata read no longer relies on
btrfs_subpage::readers.

Making the writer lock as the only utilized subpage locking.

This patchset converts all the existing reader lock usage and rename the
writer lock into a generic lock.

This patchset relies on this patch "btrfs: fix the delalloc range
locking if sector size < page size", as it removes the last user of
btrfs_folio_start_writer_lock().

Qu Wenruo (2):
  btrfs: unify to use writer locks for subpage locking
  btrfs: rename btrfs_folio_(set|start|end)_writer_lock()

 fs/btrfs/compression.c |   3 +-
 fs/btrfs/extent_io.c   |  20 +++-----
 fs/btrfs/subpage.c     | 108 ++++++++++-------------------------------
 fs/btrfs/subpage.h     |  33 +++++--------
 4 files changed, 45 insertions(+), 119 deletions(-)

Comments

David Sterba Oct. 16, 2024, 3:28 p.m. UTC | #1
On Wed, Oct 09, 2024 at 04:21:05PM +1030, Qu Wenruo wrote:
> [CHANGELOG]
> v2:
> - Rename btrfs_subpage::locked to btrfs_subpage::nr_locked
> 
> When the handling of sector size < page size is introduced, there are
> two types of locking, reader and writer lock.
> 
> The main reason for the reader lock is to handle metadata to make sure
> the page::private is not released when there is still a metadata being
> read.
> 
> However since commit d7172f52e993 ("btrfs: use per-buffer locking for
> extent_buffer reading"), metadata read no longer relies on
> btrfs_subpage::readers.
> 
> Making the writer lock as the only utilized subpage locking.
> 
> This patchset converts all the existing reader lock usage and rename the
> writer lock into a generic lock.
> 
> This patchset relies on this patch "btrfs: fix the delalloc range
> locking if sector size < page size", as it removes the last user of
> btrfs_folio_start_writer_lock().
> 
> Qu Wenruo (2):
>   btrfs: unify to use writer locks for subpage locking
>   btrfs: rename btrfs_folio_(set|start|end)_writer_lock()

Reviewed-by: David Sterba <dsterba@suse.com>