diff mbox series

[1/2] mm/mremap: Clean up vma_to_resize()

Message ID 20241016201719.2449143-2-Liam.Howlett@oracle.com (mailing list archive)
State New
Headers show
Series mm/mremap: Remove extra vma tree walk | expand

Commit Message

Liam R. Howlett Oct. 16, 2024, 8:17 p.m. UTC
From: "Liam R. Howlett" <Liam.Howlett@Oracle.com>

vma_to_resize() is used in two locations to find and validate the vma
for the mremap location.  One of the two locations already has the vma,
which is then re-found to validate the same vma.

This code can be simplified by moving the vma_lookup() from
vma_to_resize() to mremap_to() and changing the return type to an int
error.

Since the function now just validates the vma, the function is renamed
to mremap_vma_check() to better reflect what it is doing.

Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>
---
 mm/mremap.c | 39 +++++++++++++++++++--------------------
 1 file changed, 19 insertions(+), 20 deletions(-)

Comments

Jeff Xu Oct. 17, 2024, 5:55 p.m. UTC | #1
On Wed, Oct 16, 2024 at 1:17 PM Liam R. Howlett <Liam.Howlett@oracle.com> wrote:
>
> From: "Liam R. Howlett" <Liam.Howlett@Oracle.com>
>
> vma_to_resize() is used in two locations to find and validate the vma
> for the mremap location.  One of the two locations already has the vma,
> which is then re-found to validate the same vma.
>
> This code can be simplified by moving the vma_lookup() from
> vma_to_resize() to mremap_to() and changing the return type to an int
> error.
>
> Since the function now just validates the vma, the function is renamed
> to mremap_vma_check() to better reflect what it is doing.
>
> Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>
> ---
>  mm/mremap.c | 39 +++++++++++++++++++--------------------
>  1 file changed, 19 insertions(+), 20 deletions(-)
>
> diff --git a/mm/mremap.c b/mm/mremap.c
> index 5917feafe8cc..648c29f568af 100644
> --- a/mm/mremap.c
> +++ b/mm/mremap.c
> @@ -826,17 +826,12 @@ static unsigned long move_vma(struct vm_area_struct *vma,
>         return new_addr;
>  }
>
> -static struct vm_area_struct *vma_to_resize(unsigned long addr,
> +static int mremap_vma_check(struct vm_area_struct *vma, unsigned long addr,
The original function is vma_to_resize, and mremap_vma_check is
missing this context.
Maybe mremap_vma_check_resize is a better name ?


>         unsigned long old_len, unsigned long new_len, unsigned long flags)
>  {
>         struct mm_struct *mm = current->mm;
> -       struct vm_area_struct *vma;
>         unsigned long pgoff;
>
> -       vma = vma_lookup(mm, addr);
> -       if (!vma)
> -               return ERR_PTR(-EFAULT);
> -
>         /*
>          * !old_len is a special case where an attempt is made to 'duplicate'
>          * a mapping.  This makes no sense for private mappings as it will
> @@ -847,37 +842,37 @@ static struct vm_area_struct *vma_to_resize(unsigned long addr,
>          */
>         if (!old_len && !(vma->vm_flags & (VM_SHARED | VM_MAYSHARE))) {
>                 pr_warn_once("%s (%d): attempted to duplicate a private mapping with mremap.  This is not supported.\n", current->comm, current->pid);
> -               return ERR_PTR(-EINVAL);
> +               return -EINVAL;
>         }
>
>         if ((flags & MREMAP_DONTUNMAP) &&
>                         (vma->vm_flags & (VM_DONTEXPAND | VM_PFNMAP)))
> -               return ERR_PTR(-EINVAL);
> +               return -EINVAL;
>
>         /* We can't remap across vm area boundaries */
>         if (old_len > vma->vm_end - addr)
> -               return ERR_PTR(-EFAULT);
> +               return -EFAULT;
>
>         if (new_len == old_len)
> -               return vma;
> +               return 0;
>
>         /* Need to be careful about a growing mapping */
>         pgoff = (addr - vma->vm_start) >> PAGE_SHIFT;
>         pgoff += vma->vm_pgoff;
>         if (pgoff + (new_len >> PAGE_SHIFT) < pgoff)
> -               return ERR_PTR(-EINVAL);
> +               return -EINVAL;
>
>         if (vma->vm_flags & (VM_DONTEXPAND | VM_PFNMAP))
> -               return ERR_PTR(-EFAULT);
> +               return -EFAULT;
>
>         if (!mlock_future_ok(mm, vma->vm_flags, new_len - old_len))
> -               return ERR_PTR(-EAGAIN);
> +               return -EAGAIN;
>
>         if (!may_expand_vm(mm, vma->vm_flags,
>                                 (new_len - old_len) >> PAGE_SHIFT))
> -               return ERR_PTR(-ENOMEM);
> +               return -ENOMEM;
>
> -       return vma;
> +       return 0;
>  }
>
>  static unsigned long mremap_to(unsigned long addr, unsigned long old_len,
> @@ -936,7 +931,13 @@ static unsigned long mremap_to(unsigned long addr, unsigned long old_len,
>                 old_len = new_len;
>         }
>
> -       vma = vma_to_resize(addr, old_len, new_len, flags);
> +       vma = vma_lookup(mm, addr);
> +       if (!vma) {
> +               ret = -EFAULT;
> +               goto out;
> +       }
> +
> +       mremap_vma_check(vma, addr, old_len, new_len, flags);
>         if (IS_ERR(vma)) {
>                 ret = PTR_ERR(vma);
>                 goto out;
> @@ -1114,11 +1115,9 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
>         /*
>          * Ok, we need to grow..
>          */
> -       vma = vma_to_resize(addr, old_len, new_len, flags);
> -       if (IS_ERR(vma)) {
> -               ret = PTR_ERR(vma);
> +       ret = mremap_vma_check(vma, addr, old_len, new_len, flags);
> +       if (ret)
>                 goto out;
> -       }
>
>         /* old_len exactly to the end of the area..
>          */
> --
> 2.43.0
>
Liam R. Howlett Oct. 17, 2024, 6:07 p.m. UTC | #2
* Jeff Xu <jeffxu@chromium.org> [241017 13:55]:
> On Wed, Oct 16, 2024 at 1:17 PM Liam R. Howlett <Liam.Howlett@oracle.com> wrote:
> >
> > From: "Liam R. Howlett" <Liam.Howlett@Oracle.com>
> >
> > vma_to_resize() is used in two locations to find and validate the vma
> > for the mremap location.  One of the two locations already has the vma,
> > which is then re-found to validate the same vma.
> >
> > This code can be simplified by moving the vma_lookup() from
> > vma_to_resize() to mremap_to() and changing the return type to an int
> > error.
> >
> > Since the function now just validates the vma, the function is renamed
> > to mremap_vma_check() to better reflect what it is doing.
> >
> > Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>
> > ---
> >  mm/mremap.c | 39 +++++++++++++++++++--------------------
> >  1 file changed, 19 insertions(+), 20 deletions(-)
> >
> > diff --git a/mm/mremap.c b/mm/mremap.c
> > index 5917feafe8cc..648c29f568af 100644
> > --- a/mm/mremap.c
> > +++ b/mm/mremap.c
> > @@ -826,17 +826,12 @@ static unsigned long move_vma(struct vm_area_struct *vma,
> >         return new_addr;
> >  }
> >
> > -static struct vm_area_struct *vma_to_resize(unsigned long addr,
> > +static int mremap_vma_check(struct vm_area_struct *vma, unsigned long addr,
> The original function is vma_to_resize, and mremap_vma_check is
> missing this context.
> Maybe mremap_vma_check_resize is a better name ?

Good point.  That suggestion is long though.  Perhaps
vma_check_resize(), since this is a static function in the mremap.c
file, it is fine to drop mremap from the name.

...

Thanks,
Liam
Jeff Xu Oct. 17, 2024, 6:15 p.m. UTC | #3
On Thu, Oct 17, 2024 at 11:07 AM Liam R. Howlett
<Liam.Howlett@oracle.com> wrote:
>
> * Jeff Xu <jeffxu@chromium.org> [241017 13:55]:
> > On Wed, Oct 16, 2024 at 1:17 PM Liam R. Howlett <Liam.Howlett@oracle.com> wrote:
> > >
> > > From: "Liam R. Howlett" <Liam.Howlett@Oracle.com>
> > >
> > > vma_to_resize() is used in two locations to find and validate the vma
> > > for the mremap location.  One of the two locations already has the vma,
> > > which is then re-found to validate the same vma.
> > >
> > > This code can be simplified by moving the vma_lookup() from
> > > vma_to_resize() to mremap_to() and changing the return type to an int
> > > error.
> > >
> > > Since the function now just validates the vma, the function is renamed
> > > to mremap_vma_check() to better reflect what it is doing.
> > >
> > > Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>
> > > ---
> > >  mm/mremap.c | 39 +++++++++++++++++++--------------------
> > >  1 file changed, 19 insertions(+), 20 deletions(-)
> > >
> > > diff --git a/mm/mremap.c b/mm/mremap.c
> > > index 5917feafe8cc..648c29f568af 100644
> > > --- a/mm/mremap.c
> > > +++ b/mm/mremap.c
> > > @@ -826,17 +826,12 @@ static unsigned long move_vma(struct vm_area_struct *vma,
> > >         return new_addr;
> > >  }
> > >
> > > -static struct vm_area_struct *vma_to_resize(unsigned long addr,
> > > +static int mremap_vma_check(struct vm_area_struct *vma, unsigned long addr,
> > The original function is vma_to_resize, and mremap_vma_check is
> > missing this context.
> > Maybe mremap_vma_check_resize is a better name ?
>
> Good point.  That suggestion is long though.  Perhaps
> vma_check_resize(), since this is a static function in the mremap.c
> file, it is fine to drop mremap from the name.
>
I'm ok with that.

> ...
>
> Thanks,
> Liam
Andrew Morton Oct. 17, 2024, 9:08 p.m. UTC | #4
On Thu, 17 Oct 2024 11:15:20 -0700 Jeff Xu <jeffxu@chromium.org> wrote:

> > > > -static struct vm_area_struct *vma_to_resize(unsigned long addr,
> > > > +static int mremap_vma_check(struct vm_area_struct *vma, unsigned long addr,
> > > The original function is vma_to_resize, and mremap_vma_check is
> > > missing this context.
> > > Maybe mremap_vma_check_resize is a better name ?
> >
> > Good point.  That suggestion is long though.  Perhaps
> > vma_check_resize(), since this is a static function in the mremap.c
> > file, it is fine to drop mremap from the name.
> >
> I'm ok with that.

Any function with "check" in the name makes my teeth ache.  "check"
what?  And the name doesn't carry any connotation of the return value's
meaning.

eg, "check_the_cheese()" versus "cheese_is_fresh()".  The latter name
tells you what is being checked and it tells you what a "true" return
value means.

Also, the dang function isn't documented.

Also, why is mremap_to() calling mremap_vma_check() without testing its
return value?  mremap_vma_check() doesn't actually alter anything, does
it?  If it does then it's misnamed.
Liam R. Howlett Oct. 17, 2024, 11:53 p.m. UTC | #5
* Andrew Morton <akpm@linux-foundation.org> [241017 17:08]:
> On Thu, 17 Oct 2024 11:15:20 -0700 Jeff Xu <jeffxu@chromium.org> wrote:
> 
> > > > > -static struct vm_area_struct *vma_to_resize(unsigned long addr,
> > > > > +static int mremap_vma_check(struct vm_area_struct *vma, unsigned long addr,
> > > > The original function is vma_to_resize, and mremap_vma_check is
> > > > missing this context.
> > > > Maybe mremap_vma_check_resize is a better name ?
> > >
> > > Good point.  That suggestion is long though.  Perhaps
> > > vma_check_resize(), since this is a static function in the mremap.c
> > > file, it is fine to drop mremap from the name.
> > >
> > I'm ok with that.
> 
> Any function with "check" in the name makes my teeth ache.  "check"
> what?  And the name doesn't carry any connotation of the return value's
> meaning.
> 
> eg, "check_the_cheese()" versus "cheese_is_fresh()".  The latter name
> tells you what is being checked and it tells you what a "true" return
> value means.

Fair enough, how about resize_is_valid()?

> 
> Also, the dang function isn't documented.

I'll add that, thanks.

> 
> Also, why is mremap_to() calling mremap_vma_check() without testing its
> return value?  mremap_vma_check() doesn't actually alter anything, does
> it?  If it does then it's misnamed.

That's an issue, I'll fix it.

Thanks,
Liam
Andrew Morton Oct. 18, 2024, midnight UTC | #6
On Thu, 17 Oct 2024 19:53:10 -0400 "Liam R. Howlett" <Liam.Howlett@oracle.com> wrote:

> > eg, "check_the_cheese()" versus "cheese_is_fresh()".  The latter name
> > tells you what is being checked and it tells you what a "true" return
> > value means.
> 
> Fair enough, how about resize_is_valid()?

Sounds great.  Although I do prefer cheese_is_fresh().
diff mbox series

Patch

diff --git a/mm/mremap.c b/mm/mremap.c
index 5917feafe8cc..648c29f568af 100644
--- a/mm/mremap.c
+++ b/mm/mremap.c
@@ -826,17 +826,12 @@  static unsigned long move_vma(struct vm_area_struct *vma,
 	return new_addr;
 }
 
-static struct vm_area_struct *vma_to_resize(unsigned long addr,
+static int mremap_vma_check(struct vm_area_struct *vma, unsigned long addr,
 	unsigned long old_len, unsigned long new_len, unsigned long flags)
 {
 	struct mm_struct *mm = current->mm;
-	struct vm_area_struct *vma;
 	unsigned long pgoff;
 
-	vma = vma_lookup(mm, addr);
-	if (!vma)
-		return ERR_PTR(-EFAULT);
-
 	/*
 	 * !old_len is a special case where an attempt is made to 'duplicate'
 	 * a mapping.  This makes no sense for private mappings as it will
@@ -847,37 +842,37 @@  static struct vm_area_struct *vma_to_resize(unsigned long addr,
 	 */
 	if (!old_len && !(vma->vm_flags & (VM_SHARED | VM_MAYSHARE))) {
 		pr_warn_once("%s (%d): attempted to duplicate a private mapping with mremap.  This is not supported.\n", current->comm, current->pid);
-		return ERR_PTR(-EINVAL);
+		return -EINVAL;
 	}
 
 	if ((flags & MREMAP_DONTUNMAP) &&
 			(vma->vm_flags & (VM_DONTEXPAND | VM_PFNMAP)))
-		return ERR_PTR(-EINVAL);
+		return -EINVAL;
 
 	/* We can't remap across vm area boundaries */
 	if (old_len > vma->vm_end - addr)
-		return ERR_PTR(-EFAULT);
+		return -EFAULT;
 
 	if (new_len == old_len)
-		return vma;
+		return 0;
 
 	/* Need to be careful about a growing mapping */
 	pgoff = (addr - vma->vm_start) >> PAGE_SHIFT;
 	pgoff += vma->vm_pgoff;
 	if (pgoff + (new_len >> PAGE_SHIFT) < pgoff)
-		return ERR_PTR(-EINVAL);
+		return -EINVAL;
 
 	if (vma->vm_flags & (VM_DONTEXPAND | VM_PFNMAP))
-		return ERR_PTR(-EFAULT);
+		return -EFAULT;
 
 	if (!mlock_future_ok(mm, vma->vm_flags, new_len - old_len))
-		return ERR_PTR(-EAGAIN);
+		return -EAGAIN;
 
 	if (!may_expand_vm(mm, vma->vm_flags,
 				(new_len - old_len) >> PAGE_SHIFT))
-		return ERR_PTR(-ENOMEM);
+		return -ENOMEM;
 
-	return vma;
+	return 0;
 }
 
 static unsigned long mremap_to(unsigned long addr, unsigned long old_len,
@@ -936,7 +931,13 @@  static unsigned long mremap_to(unsigned long addr, unsigned long old_len,
 		old_len = new_len;
 	}
 
-	vma = vma_to_resize(addr, old_len, new_len, flags);
+	vma = vma_lookup(mm, addr);
+	if (!vma) {
+		ret = -EFAULT;
+		goto out;
+	}
+
+	mremap_vma_check(vma, addr, old_len, new_len, flags);
 	if (IS_ERR(vma)) {
 		ret = PTR_ERR(vma);
 		goto out;
@@ -1114,11 +1115,9 @@  SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
 	/*
 	 * Ok, we need to grow..
 	 */
-	vma = vma_to_resize(addr, old_len, new_len, flags);
-	if (IS_ERR(vma)) {
-		ret = PTR_ERR(vma);
+	ret = mremap_vma_check(vma, addr, old_len, new_len, flags);
+	if (ret)
 		goto out;
-	}
 
 	/* old_len exactly to the end of the area..
 	 */