diff mbox series

[v2,1/2] mm/mremap: Clean up vma_to_resize()

Message ID 20241018174114.2871880-2-Liam.Howlett@oracle.com (mailing list archive)
State New
Headers show
Series mm/mremap: Remove extra vma tree walk | expand

Commit Message

Liam R. Howlett Oct. 18, 2024, 5:41 p.m. UTC
From: "Liam R. Howlett" <Liam.Howlett@Oracle.com>

vma_to_resize() is used in two locations to find and validate the vma
for the mremap location.  One of the two locations already has the vma,
which is then re-found to validate the same vma.

This code can be simplified by moving the vma_lookup() from
vma_to_resize() to mremap_to() and changing the return type to an int
error.

Since the function now just validates the vma, the function is renamed
to resize_is_valid() to better reflect what it is doing.

This commit also adds documentation about the function.

Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>
---
 mm/mremap.c | 53 +++++++++++++++++++++++++++++++----------------------
 1 file changed, 31 insertions(+), 22 deletions(-)

Comments

Lorenzo Stoakes Oct. 21, 2024, 10:03 a.m. UTC | #1
On Fri, Oct 18, 2024 at 01:41:13PM -0400, Liam R. Howlett wrote:
> From: "Liam R. Howlett" <Liam.Howlett@Oracle.com>
>
> vma_to_resize() is used in two locations to find and validate the vma
> for the mremap location.  One of the two locations already has the vma,
> which is then re-found to validate the same vma.
>
> This code can be simplified by moving the vma_lookup() from
> vma_to_resize() to mremap_to() and changing the return type to an int
> error.
>
> Since the function now just validates the vma, the function is renamed
> to resize_is_valid() to better reflect what it is doing.
>
> This commit also adds documentation about the function.
>
> Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>

git-icdiff helped here a lot :)

This LGTM,

Reviewed-by: Lorenzo Stoakes <lorenzo.stoakes@oracle.com>

Generally a really nice clean up in any case, thanks for doing this!

> ---
>  mm/mremap.c | 53 +++++++++++++++++++++++++++++++----------------------
>  1 file changed, 31 insertions(+), 22 deletions(-)
>
> diff --git a/mm/mremap.c b/mm/mremap.c
> index 5917feafe8cc..e781ec4573ca 100644
> --- a/mm/mremap.c
> +++ b/mm/mremap.c
> @@ -826,17 +826,24 @@ static unsigned long move_vma(struct vm_area_struct *vma,
>  	return new_addr;
>  }
>
> -static struct vm_area_struct *vma_to_resize(unsigned long addr,
> +/*
> + * resize_is_valid() - Ensure the vma can be resized to the new length at the give
> + * address.
> + *
> + * @vma: The vma to resize
> + * @addr: The old address
> + * @old_len: The current size
> + * @new_len: The desired size
> + * @flags: The vma flags
> + *
> + * Return 0 on success, error otherwise.
> + */
> +static int resize_is_valid(struct vm_area_struct *vma, unsigned long addr,
>  	unsigned long old_len, unsigned long new_len, unsigned long flags)
>  {
>  	struct mm_struct *mm = current->mm;
> -	struct vm_area_struct *vma;
>  	unsigned long pgoff;
>
> -	vma = vma_lookup(mm, addr);
> -	if (!vma)
> -		return ERR_PTR(-EFAULT);
> -
>  	/*
>  	 * !old_len is a special case where an attempt is made to 'duplicate'
>  	 * a mapping.  This makes no sense for private mappings as it will
> @@ -847,37 +854,37 @@ static struct vm_area_struct *vma_to_resize(unsigned long addr,
>  	 */
>  	if (!old_len && !(vma->vm_flags & (VM_SHARED | VM_MAYSHARE))) {
>  		pr_warn_once("%s (%d): attempted to duplicate a private mapping with mremap.  This is not supported.\n", current->comm, current->pid);
> -		return ERR_PTR(-EINVAL);
> +		return -EINVAL;
>  	}
>
>  	if ((flags & MREMAP_DONTUNMAP) &&
>  			(vma->vm_flags & (VM_DONTEXPAND | VM_PFNMAP)))
> -		return ERR_PTR(-EINVAL);
> +		return -EINVAL;
>
>  	/* We can't remap across vm area boundaries */
>  	if (old_len > vma->vm_end - addr)
> -		return ERR_PTR(-EFAULT);
> +		return -EFAULT;
>
>  	if (new_len == old_len)
> -		return vma;
> +		return 0;
>
>  	/* Need to be careful about a growing mapping */
>  	pgoff = (addr - vma->vm_start) >> PAGE_SHIFT;
>  	pgoff += vma->vm_pgoff;
>  	if (pgoff + (new_len >> PAGE_SHIFT) < pgoff)
> -		return ERR_PTR(-EINVAL);
> +		return -EINVAL;
>
>  	if (vma->vm_flags & (VM_DONTEXPAND | VM_PFNMAP))
> -		return ERR_PTR(-EFAULT);
> +		return -EFAULT;
>
>  	if (!mlock_future_ok(mm, vma->vm_flags, new_len - old_len))
> -		return ERR_PTR(-EAGAIN);
> +		return -EAGAIN;
>
>  	if (!may_expand_vm(mm, vma->vm_flags,
>  				(new_len - old_len) >> PAGE_SHIFT))
> -		return ERR_PTR(-ENOMEM);
> +		return -ENOMEM;
>
> -	return vma;
> +	return 0;
>  }
>
>  static unsigned long mremap_to(unsigned long addr, unsigned long old_len,
> @@ -936,12 +943,16 @@ static unsigned long mremap_to(unsigned long addr, unsigned long old_len,
>  		old_len = new_len;
>  	}
>
> -	vma = vma_to_resize(addr, old_len, new_len, flags);
> -	if (IS_ERR(vma)) {
> -		ret = PTR_ERR(vma);
> +	vma = vma_lookup(mm, addr);
> +	if (!vma) {
> +		ret = -EFAULT;
>  		goto out;
>  	}
>
> +	ret = resize_is_valid(vma, addr, old_len, new_len, flags);
> +	if (ret)
> +		goto out;
> +
>  	/* MREMAP_DONTUNMAP expands by old_len since old_len == new_len */
>  	if (flags & MREMAP_DONTUNMAP &&
>  		!may_expand_vm(mm, vma->vm_flags, old_len >> PAGE_SHIFT)) {
> @@ -1114,11 +1125,9 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
>  	/*
>  	 * Ok, we need to grow..
>  	 */
> -	vma = vma_to_resize(addr, old_len, new_len, flags);
> -	if (IS_ERR(vma)) {
> -		ret = PTR_ERR(vma);
> +	ret = resize_is_valid(vma, addr, old_len, new_len, flags);
> +	if (ret)
>  		goto out;
> -	}
>
>  	/* old_len exactly to the end of the area..
>  	 */
> --
> 2.43.0
>
Pedro Falcato Oct. 22, 2024, 10:08 p.m. UTC | #2
On Fri, Oct 18, 2024 at 6:41 PM Liam R. Howlett <Liam.Howlett@oracle.com> wrote:
>
> From: "Liam R. Howlett" <Liam.Howlett@Oracle.com>
>
> vma_to_resize() is used in two locations to find and validate the vma
> for the mremap location.  One of the two locations already has the vma,
> which is then re-found to validate the same vma.
>
> This code can be simplified by moving the vma_lookup() from
> vma_to_resize() to mremap_to() and changing the return type to an int
> error.
>
> Since the function now just validates the vma, the function is renamed
> to resize_is_valid() to better reflect what it is doing.

Small nit: Could we pick a stable naming scheme?
I understand the kernel has historically had plenty of ways to name
functions, including
do_stuff
is_stuff
stuff_do
stuff_is

I thought we were starting to converge into vma_/vmi_/vms_ :(
I would personally prefer vma_resize_is_valid/vma_resize_valid (even
if it's a static function, so it doesn't matter _too_ much).
Anyway, enough bikeshedding...

>
> This commit also adds documentation about the function.
>
> Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>

Reviewed-by: Pedro Falcato <pedro.falcato@gmail.com>

This patch made me realize there's a couple of small improvements we
can still do (maybe with a vmi) to clean up and speed up mremap (at
least!). I'll look into those if I find some time.
Liam R. Howlett Oct. 23, 2024, 2:10 a.m. UTC | #3
* Pedro Falcato <pedro.falcato@gmail.com> [241022 18:08]:
> On Fri, Oct 18, 2024 at 6:41 PM Liam R. Howlett <Liam.Howlett@oracle.com> wrote:
> >
> > From: "Liam R. Howlett" <Liam.Howlett@Oracle.com>
> >
> > vma_to_resize() is used in two locations to find and validate the vma
> > for the mremap location.  One of the two locations already has the vma,
> > which is then re-found to validate the same vma.
> >
> > This code can be simplified by moving the vma_lookup() from
> > vma_to_resize() to mremap_to() and changing the return type to an int
> > error.
> >
> > Since the function now just validates the vma, the function is renamed
> > to resize_is_valid() to better reflect what it is doing.
> 
> Small nit: Could we pick a stable naming scheme?
> I understand the kernel has historically had plenty of ways to name
> functions, including
> do_stuff
> is_stuff
> stuff_do
> stuff_is
> 
> I thought we were starting to converge into vma_/vmi_/vms_ :(
> I would personally prefer vma_resize_is_valid/vma_resize_valid (even
> if it's a static function, so it doesn't matter _too_ much).
> Anyway, enough bikeshedding...

Right.  Usually the vma_/vmi_/vms_ stuff indicates the first argument to
the functions exposed to other files.  Yes, vma_ would work here, and I
don't really mind that it's static and has the vma_ name.

I'd suggest relocating it to vma.c or vma.h, but then we'd have to put
mremap in the name and that would be rather long - I don't think we do
anything like this elsewhere.

> 
> >
> > This commit also adds documentation about the function.
> >
> > Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>
> 
> Reviewed-by: Pedro Falcato <pedro.falcato@gmail.com>

Thanks!

> 
> This patch made me realize there's a couple of small improvements we
> can still do (maybe with a vmi) to clean up and speed up mremap (at
> least!). I'll look into those if I find some time.

Agreed.  If you do get to doing more clean up, I'd be fine with a rename
of this function.

Regards,
Liam
diff mbox series

Patch

diff --git a/mm/mremap.c b/mm/mremap.c
index 5917feafe8cc..e781ec4573ca 100644
--- a/mm/mremap.c
+++ b/mm/mremap.c
@@ -826,17 +826,24 @@  static unsigned long move_vma(struct vm_area_struct *vma,
 	return new_addr;
 }
 
-static struct vm_area_struct *vma_to_resize(unsigned long addr,
+/*
+ * resize_is_valid() - Ensure the vma can be resized to the new length at the give
+ * address.
+ *
+ * @vma: The vma to resize
+ * @addr: The old address
+ * @old_len: The current size
+ * @new_len: The desired size
+ * @flags: The vma flags
+ *
+ * Return 0 on success, error otherwise.
+ */
+static int resize_is_valid(struct vm_area_struct *vma, unsigned long addr,
 	unsigned long old_len, unsigned long new_len, unsigned long flags)
 {
 	struct mm_struct *mm = current->mm;
-	struct vm_area_struct *vma;
 	unsigned long pgoff;
 
-	vma = vma_lookup(mm, addr);
-	if (!vma)
-		return ERR_PTR(-EFAULT);
-
 	/*
 	 * !old_len is a special case where an attempt is made to 'duplicate'
 	 * a mapping.  This makes no sense for private mappings as it will
@@ -847,37 +854,37 @@  static struct vm_area_struct *vma_to_resize(unsigned long addr,
 	 */
 	if (!old_len && !(vma->vm_flags & (VM_SHARED | VM_MAYSHARE))) {
 		pr_warn_once("%s (%d): attempted to duplicate a private mapping with mremap.  This is not supported.\n", current->comm, current->pid);
-		return ERR_PTR(-EINVAL);
+		return -EINVAL;
 	}
 
 	if ((flags & MREMAP_DONTUNMAP) &&
 			(vma->vm_flags & (VM_DONTEXPAND | VM_PFNMAP)))
-		return ERR_PTR(-EINVAL);
+		return -EINVAL;
 
 	/* We can't remap across vm area boundaries */
 	if (old_len > vma->vm_end - addr)
-		return ERR_PTR(-EFAULT);
+		return -EFAULT;
 
 	if (new_len == old_len)
-		return vma;
+		return 0;
 
 	/* Need to be careful about a growing mapping */
 	pgoff = (addr - vma->vm_start) >> PAGE_SHIFT;
 	pgoff += vma->vm_pgoff;
 	if (pgoff + (new_len >> PAGE_SHIFT) < pgoff)
-		return ERR_PTR(-EINVAL);
+		return -EINVAL;
 
 	if (vma->vm_flags & (VM_DONTEXPAND | VM_PFNMAP))
-		return ERR_PTR(-EFAULT);
+		return -EFAULT;
 
 	if (!mlock_future_ok(mm, vma->vm_flags, new_len - old_len))
-		return ERR_PTR(-EAGAIN);
+		return -EAGAIN;
 
 	if (!may_expand_vm(mm, vma->vm_flags,
 				(new_len - old_len) >> PAGE_SHIFT))
-		return ERR_PTR(-ENOMEM);
+		return -ENOMEM;
 
-	return vma;
+	return 0;
 }
 
 static unsigned long mremap_to(unsigned long addr, unsigned long old_len,
@@ -936,12 +943,16 @@  static unsigned long mremap_to(unsigned long addr, unsigned long old_len,
 		old_len = new_len;
 	}
 
-	vma = vma_to_resize(addr, old_len, new_len, flags);
-	if (IS_ERR(vma)) {
-		ret = PTR_ERR(vma);
+	vma = vma_lookup(mm, addr);
+	if (!vma) {
+		ret = -EFAULT;
 		goto out;
 	}
 
+	ret = resize_is_valid(vma, addr, old_len, new_len, flags);
+	if (ret)
+		goto out;
+
 	/* MREMAP_DONTUNMAP expands by old_len since old_len == new_len */
 	if (flags & MREMAP_DONTUNMAP &&
 		!may_expand_vm(mm, vma->vm_flags, old_len >> PAGE_SHIFT)) {
@@ -1114,11 +1125,9 @@  SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
 	/*
 	 * Ok, we need to grow..
 	 */
-	vma = vma_to_resize(addr, old_len, new_len, flags);
-	if (IS_ERR(vma)) {
-		ret = PTR_ERR(vma);
+	ret = resize_is_valid(vma, addr, old_len, new_len, flags);
+	if (ret)
 		goto out;
-	}
 
 	/* old_len exactly to the end of the area..
 	 */