diff mbox series

[v1,2/4] regulator: tps65219: Update driver name

Message ID 20241217204526.1010989-3-s-ramamoorthy@ti.com (mailing list archive)
State New
Headers show
Series TPS65219 Regulator Driver Cleanup Series | expand

Commit Message

Shree Ramamoorthy Dec. 17, 2024, 8:45 p.m. UTC
Follow the same naming convention in tps6594-regulator.c with
tpsxxx-regulator instead of tpsxxx-pmic.

Signed-off-by: Shree Ramamoorthy <s-ramamoorthy@ti.com>
---
 drivers/regulator/tps65219-regulator.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Mark Brown Dec. 17, 2024, 9:01 p.m. UTC | #1
On Tue, Dec 17, 2024 at 02:45:24PM -0600, Shree Ramamoorthy wrote:

> Follow the same naming convention in tps6594-regulator.c with
> tpsxxx-regulator instead of tpsxxx-pmic.

>  static struct platform_driver tps65219_regulator_driver = {
>  	.driver = {
> -		.name = "tps65219-pmic",
> +		.name = "tps65219-regulator",
>  		.probe_type = PROBE_PREFER_ASYNCHRONOUS,

This isn't just a naming convention thing AFACIT, the MFD registers the
new name so the driver wouldn't previously have loaded.  How did this
ever work?
Andrew Davis Dec. 17, 2024, 9:16 p.m. UTC | #2
On 12/17/24 3:01 PM, Mark Brown wrote:
> On Tue, Dec 17, 2024 at 02:45:24PM -0600, Shree Ramamoorthy wrote:
> 
>> Follow the same naming convention in tps6594-regulator.c with
>> tpsxxx-regulator instead of tpsxxx-pmic.
> 
>>   static struct platform_driver tps65219_regulator_driver = {
>>   	.driver = {
>> -		.name = "tps65219-pmic",
>> +		.name = "tps65219-regulator",
>>   		.probe_type = PROBE_PREFER_ASYNCHRONOUS,
> 
> This isn't just a naming convention thing AFACIT, the MFD registers the
> new name so the driver wouldn't previously have loaded.  How did this
> ever work?

It matches based on the platform device .id_table[0] which does have
"tps65219-regulator" listed, the driver .name itself is only used
as a last fallback when there is no .id_table.

[0] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/base/platform.c#n1352

Andrew
Mark Brown Dec. 17, 2024, 9:19 p.m. UTC | #3
On Tue, Dec 17, 2024 at 03:16:44PM -0600, Andrew Davis wrote:
> On 12/17/24 3:01 PM, Mark Brown wrote:

> > This isn't just a naming convention thing AFACIT, the MFD registers the
> > new name so the driver wouldn't previously have loaded.  How did this
> > ever work?

> It matches based on the platform device .id_table[0] which does have
> "tps65219-regulator" listed, the driver .name itself is only used
> as a last fallback when there is no .id_table.

Ah, there's not enough context in the diff to show the ID table.
diff mbox series

Patch

diff --git a/drivers/regulator/tps65219-regulator.c b/drivers/regulator/tps65219-regulator.c
index 14d843a99d0f..5decf69f327a 100644
--- a/drivers/regulator/tps65219-regulator.c
+++ b/drivers/regulator/tps65219-regulator.c
@@ -379,7 +379,7 @@  MODULE_DEVICE_TABLE(platform, tps65219_regulator_id_table);
 
 static struct platform_driver tps65219_regulator_driver = {
 	.driver = {
-		.name = "tps65219-pmic",
+		.name = "tps65219-regulator",
 		.probe_type = PROBE_PREFER_ASYNCHRONOUS,
 	},
 	.probe = tps65219_regulator_probe,