Message ID | 20250228-netcons_current-v2-2-f53ff79a0db2@debian.org (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | netconsole: Add taskname sysdata support | expand |
On Fri, Feb 28, 2025 at 04:50:18AM -0800, Breno Leitao wrote: > Convert the current state assignment to use explicit boolean conversion, > making the code more robust and easier to read. This change adds a > double-negation operator to ensure consistent boolean conversion as > suggested by Paolo[1]. > > This approach aligns with the existing pattern used in > sysdata_cpu_nr_enabled_show(). > > Link: https://lore.kernel.org/all/7309e760-63b0-4b58-ad33-2fb8db361141@redhat.com/ [1] > Signed-off-by: Breno Leitao <leitao@debian.org> Thanks Breno, FWIIW, I 100% agree with this change. Reviewed-by: Simon Horman <horms@kernel.org>
diff --git a/drivers/net/netconsole.c b/drivers/net/netconsole.c index c086e2fe51f87..698dbbea2713f 100644 --- a/drivers/net/netconsole.c +++ b/drivers/net/netconsole.c @@ -850,7 +850,7 @@ static ssize_t sysdata_cpu_nr_enabled_store(struct config_item *item, return ret; mutex_lock(&dynamic_netconsole_mutex); - curr = nt->sysdata_fields & SYSDATA_CPU_NR; + curr = !!(nt->sysdata_fields & SYSDATA_CPU_NR); if (cpu_nr_enabled == curr) /* no change requested */ goto unlock_ok;
Convert the current state assignment to use explicit boolean conversion, making the code more robust and easier to read. This change adds a double-negation operator to ensure consistent boolean conversion as suggested by Paolo[1]. This approach aligns with the existing pattern used in sysdata_cpu_nr_enabled_show(). Link: https://lore.kernel.org/all/7309e760-63b0-4b58-ad33-2fb8db361141@redhat.com/ [1] Signed-off-by: Breno Leitao <leitao@debian.org> --- drivers/net/netconsole.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)