Message ID | 20250411082357.392713-2-dongcheng.yan@intel.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | [v1,1/2] platform/x86: int3472: add hpd pin support | expand |
Hi, On 11-Apr-25 10:23 AM, Dongcheng Yan wrote: > lt6911uxe is used in IPU6 / x86 platform, worked with an out-of-tree > int3472 patch and upstream intel/ipu6 before. > The upstream int3472 driver uses "hpd" instead of "readystat" now. > this patch updates the irq_gpio name to "hpd" accordingly, so that > mere users can now use the upstream version directly without relying > on out-of-tree int3472 pin support. > > The new name "hpd" (Hotplug Detect) aligns with common naming > conventions used in other drivers(like adv7604) and documentation. > > Fixes: e49563c3be09d4 ("media: i2c: add lt6911uxe hdmi bridge driver") > Cc: stable@vger.kernel.org > Signed-off-by: Dongcheng Yan <dongcheng.yan@intel.com> The commit message needs an extra sentence to explain that this change is ok to make since at the moment this driver is only used on ACPI platforms which will use the new "hpd" name and there are no devicetree bindings for this driver. Regards, Hans > --- > drivers/media/i2c/lt6911uxe.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/media/i2c/lt6911uxe.c b/drivers/media/i2c/lt6911uxe.c > index c5b40bb58a37..24857d683fcf 100644 > --- a/drivers/media/i2c/lt6911uxe.c > +++ b/drivers/media/i2c/lt6911uxe.c > @@ -605,10 +605,10 @@ static int lt6911uxe_probe(struct i2c_client *client) > return dev_err_probe(dev, PTR_ERR(lt6911uxe->reset_gpio), > "failed to get reset gpio\n"); > > - lt6911uxe->irq_gpio = devm_gpiod_get(dev, "readystat", GPIOD_IN); > + lt6911uxe->irq_gpio = devm_gpiod_get(dev, "hpd", GPIOD_IN); > if (IS_ERR(lt6911uxe->irq_gpio)) > return dev_err_probe(dev, PTR_ERR(lt6911uxe->irq_gpio), > - "failed to get ready_stat gpio\n"); > + "failed to get hpd gpio\n"); > > ret = lt6911uxe_fwnode_parse(lt6911uxe, dev); > if (ret)
Hi hans, On 4/11/2025 4:34 PM, Hans de Goede wrote: > Hi, > > On 11-Apr-25 10:23 AM, Dongcheng Yan wrote: >> lt6911uxe is used in IPU6 / x86 platform, worked with an out-of-tree >> int3472 patch and upstream intel/ipu6 before. >> The upstream int3472 driver uses "hpd" instead of "readystat" now. >> this patch updates the irq_gpio name to "hpd" accordingly, so that >> mere users can now use the upstream version directly without relying >> on out-of-tree int3472 pin support. >> >> The new name "hpd" (Hotplug Detect) aligns with common naming >> conventions used in other drivers(like adv7604) and documentation. >> >> Fixes: e49563c3be09d4 ("media: i2c: add lt6911uxe hdmi bridge driver") >> Cc: stable@vger.kernel.org >> Signed-off-by: Dongcheng Yan <dongcheng.yan@intel.com> > > The commit message needs an extra sentence to explain that this change > is ok to make since at the moment this driver is only used on ACPI > platforms which will use the new "hpd" name and there are no devicetree > bindings for this driver. > Thanks for your great advice. I'll update commit message next patch. Best Regard, Dongcheng> Regards, > > Hans > > > >> --- >> drivers/media/i2c/lt6911uxe.c | 4 ++-- >> 1 file changed, 2 insertions(+), 2 deletions(-) >> >> diff --git a/drivers/media/i2c/lt6911uxe.c b/drivers/media/i2c/lt6911uxe.c >> index c5b40bb58a37..24857d683fcf 100644 >> --- a/drivers/media/i2c/lt6911uxe.c >> +++ b/drivers/media/i2c/lt6911uxe.c >> @@ -605,10 +605,10 @@ static int lt6911uxe_probe(struct i2c_client *client) >> return dev_err_probe(dev, PTR_ERR(lt6911uxe->reset_gpio), >> "failed to get reset gpio\n"); >> >> - lt6911uxe->irq_gpio = devm_gpiod_get(dev, "readystat", GPIOD_IN); >> + lt6911uxe->irq_gpio = devm_gpiod_get(dev, "hpd", GPIOD_IN); >> if (IS_ERR(lt6911uxe->irq_gpio)) >> return dev_err_probe(dev, PTR_ERR(lt6911uxe->irq_gpio), >> - "failed to get ready_stat gpio\n"); >> + "failed to get hpd gpio\n"); >> >> ret = lt6911uxe_fwnode_parse(lt6911uxe, dev); >> if (ret) >
diff --git a/drivers/media/i2c/lt6911uxe.c b/drivers/media/i2c/lt6911uxe.c index c5b40bb58a37..24857d683fcf 100644 --- a/drivers/media/i2c/lt6911uxe.c +++ b/drivers/media/i2c/lt6911uxe.c @@ -605,10 +605,10 @@ static int lt6911uxe_probe(struct i2c_client *client) return dev_err_probe(dev, PTR_ERR(lt6911uxe->reset_gpio), "failed to get reset gpio\n"); - lt6911uxe->irq_gpio = devm_gpiod_get(dev, "readystat", GPIOD_IN); + lt6911uxe->irq_gpio = devm_gpiod_get(dev, "hpd", GPIOD_IN); if (IS_ERR(lt6911uxe->irq_gpio)) return dev_err_probe(dev, PTR_ERR(lt6911uxe->irq_gpio), - "failed to get ready_stat gpio\n"); + "failed to get hpd gpio\n"); ret = lt6911uxe_fwnode_parse(lt6911uxe, dev); if (ret)
lt6911uxe is used in IPU6 / x86 platform, worked with an out-of-tree int3472 patch and upstream intel/ipu6 before. The upstream int3472 driver uses "hpd" instead of "readystat" now. this patch updates the irq_gpio name to "hpd" accordingly, so that mere users can now use the upstream version directly without relying on out-of-tree int3472 pin support. The new name "hpd" (Hotplug Detect) aligns with common naming conventions used in other drivers(like adv7604) and documentation. Fixes: e49563c3be09d4 ("media: i2c: add lt6911uxe hdmi bridge driver") Cc: stable@vger.kernel.org Signed-off-by: Dongcheng Yan <dongcheng.yan@intel.com> --- drivers/media/i2c/lt6911uxe.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)