Message ID | 1361961178-1912-1-git-send-email-vikas.sajjan@linaro.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On 02/27/2013 07:32 PM, Vikas Sajjan wrote: > modified compatible string for exynos4 fimd as "exynos4210-fimd" and > exynos5 fimd as "exynos5250-fimd" to stick to the rule that compatible > value should be named after first specific SoC model in which this > particular IP version was included as discussed at > https://patchwork.kernel.org/patch/2144861/ > > Signed-off-by: Vikas Sajjan <vikas.sajjan@linaro.org> > --- > drivers/gpu/drm/exynos/exynos_drm_fimd.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/gpu/drm/exynos/exynos_drm_fimd.c b/drivers/gpu/drm/exynos/exynos_drm_fimd.c > index 9537761..433ed35 100644 > --- a/drivers/gpu/drm/exynos/exynos_drm_fimd.c > +++ b/drivers/gpu/drm/exynos/exynos_drm_fimd.c > @@ -109,9 +109,9 @@ struct fimd_context { > > #ifdef CONFIG_OF > static const struct of_device_id fimd_driver_dt_match[] = { > - { .compatible = "samsung,exynos4-fimd", > + { .compatible = "samsung,exynos4210-fimd", > .data = &exynos4_fimd_driver_data }, > - { .compatible = "samsung,exynos5-fimd", > + { .compatible = "samsung,exynos5250-fimd", > .data = &exynos5_fimd_driver_data }, > {}, > }; Acked-by: Joonyoung Shim <jy0922.shim@samsung.com> Thanks. -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
Thanks Mr. Shim. On 28 February 2013 08:12, Joonyoung Shim <jy0922.shim@samsung.com> wrote: > On 02/27/2013 07:32 PM, Vikas Sajjan wrote: >> >> modified compatible string for exynos4 fimd as "exynos4210-fimd" and >> exynos5 fimd as "exynos5250-fimd" to stick to the rule that compatible >> value should be named after first specific SoC model in which this >> particular IP version was included as discussed at >> https://patchwork.kernel.org/patch/2144861/ >> >> Signed-off-by: Vikas Sajjan <vikas.sajjan@linaro.org> >> --- >> drivers/gpu/drm/exynos/exynos_drm_fimd.c | 4 ++-- >> 1 file changed, 2 insertions(+), 2 deletions(-) >> >> diff --git a/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> b/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> index 9537761..433ed35 100644 >> --- a/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> +++ b/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> @@ -109,9 +109,9 @@ struct fimd_context { >> #ifdef CONFIG_OF >> static const struct of_device_id fimd_driver_dt_match[] = { >> - { .compatible = "samsung,exynos4-fimd", >> + { .compatible = "samsung,exynos4210-fimd", >> .data = &exynos4_fimd_driver_data }, >> - { .compatible = "samsung,exynos5-fimd", >> + { .compatible = "samsung,exynos5250-fimd", >> .data = &exynos5_fimd_driver_data }, >> {}, >> }; > > > Acked-by: Joonyoung Shim <jy0922.shim@samsung.com> > > Thanks.
Hi Mr Inki Dae, On 28 February 2013 08:12, Joonyoung Shim <jy0922.shim@samsung.com> wrote: > On 02/27/2013 07:32 PM, Vikas Sajjan wrote: >> >> modified compatible string for exynos4 fimd as "exynos4210-fimd" and >> exynos5 fimd as "exynos5250-fimd" to stick to the rule that compatible >> value should be named after first specific SoC model in which this >> particular IP version was included as discussed at >> https://patchwork.kernel.org/patch/2144861/ >> >> Signed-off-by: Vikas Sajjan <vikas.sajjan@linaro.org> >> --- >> drivers/gpu/drm/exynos/exynos_drm_fimd.c | 4 ++-- >> 1 file changed, 2 insertions(+), 2 deletions(-) >> >> diff --git a/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> b/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> index 9537761..433ed35 100644 >> --- a/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> +++ b/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> @@ -109,9 +109,9 @@ struct fimd_context { >> #ifdef CONFIG_OF >> static const struct of_device_id fimd_driver_dt_match[] = { >> - { .compatible = "samsung,exynos4-fimd", >> + { .compatible = "samsung,exynos4210-fimd", >> .data = &exynos4_fimd_driver_data }, >> - { .compatible = "samsung,exynos5-fimd", >> + { .compatible = "samsung,exynos5250-fimd", >> .data = &exynos5_fimd_driver_data }, >> {}, >> }; > > > Acked-by: Joonyoung Shim <jy0922.shim@samsung.com> Can you please apply this patch. > > Thanks.
Already merged. :) > -----Original Message----- > From: Vikas Sajjan [mailto:vikas.sajjan@linaro.org] > Sent: Thursday, March 07, 2013 4:09 PM > To: InKi Dae > Cc: dri-devel@lists.freedesktop.org; linux-media@vger.kernel.org; > kgene.kim@samsung.com; Joonyoung Shim; sunil joshi > Subject: Re: [PATCH] drm/exynos: modify the compatible string for exynos > fimd > > Hi Mr Inki Dae, > > On 28 February 2013 08:12, Joonyoung Shim <jy0922.shim@samsung.com> wrote: > > On 02/27/2013 07:32 PM, Vikas Sajjan wrote: > >> > >> modified compatible string for exynos4 fimd as "exynos4210-fimd" and > >> exynos5 fimd as "exynos5250-fimd" to stick to the rule that compatible > >> value should be named after first specific SoC model in which this > >> particular IP version was included as discussed at > >> https://patchwork.kernel.org/patch/2144861/ > >> > >> Signed-off-by: Vikas Sajjan <vikas.sajjan@linaro.org> > >> --- > >> drivers/gpu/drm/exynos/exynos_drm_fimd.c | 4 ++-- > >> 1 file changed, 2 insertions(+), 2 deletions(-) > >> > >> diff --git a/drivers/gpu/drm/exynos/exynos_drm_fimd.c > >> b/drivers/gpu/drm/exynos/exynos_drm_fimd.c > >> index 9537761..433ed35 100644 > >> --- a/drivers/gpu/drm/exynos/exynos_drm_fimd.c > >> +++ b/drivers/gpu/drm/exynos/exynos_drm_fimd.c > >> @@ -109,9 +109,9 @@ struct fimd_context { > >> #ifdef CONFIG_OF > >> static const struct of_device_id fimd_driver_dt_match[] = { > >> - { .compatible = "samsung,exynos4-fimd", > >> + { .compatible = "samsung,exynos4210-fimd", > >> .data = &exynos4_fimd_driver_data }, > >> - { .compatible = "samsung,exynos5-fimd", > >> + { .compatible = "samsung,exynos5250-fimd", > >> .data = &exynos5_fimd_driver_data }, > >> {}, > >> }; > > > > > > Acked-by: Joonyoung Shim <jy0922.shim@samsung.com> > > Can you please apply this patch. > > > > > Thanks. > > > > -- > Thanks and Regards > Vikas Sajjan -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
Thanks. On 7 March 2013 12:47, Inki Dae <inki.dae@samsung.com> wrote: > Already merged. :) > >> -----Original Message----- >> From: Vikas Sajjan [mailto:vikas.sajjan@linaro.org] >> Sent: Thursday, March 07, 2013 4:09 PM >> To: InKi Dae >> Cc: dri-devel@lists.freedesktop.org; linux-media@vger.kernel.org; >> kgene.kim@samsung.com; Joonyoung Shim; sunil joshi >> Subject: Re: [PATCH] drm/exynos: modify the compatible string for exynos >> fimd >> >> Hi Mr Inki Dae, >> >> On 28 February 2013 08:12, Joonyoung Shim <jy0922.shim@samsung.com> wrote: >> > On 02/27/2013 07:32 PM, Vikas Sajjan wrote: >> >> >> >> modified compatible string for exynos4 fimd as "exynos4210-fimd" and >> >> exynos5 fimd as "exynos5250-fimd" to stick to the rule that compatible >> >> value should be named after first specific SoC model in which this >> >> particular IP version was included as discussed at >> >> https://patchwork.kernel.org/patch/2144861/ >> >> >> >> Signed-off-by: Vikas Sajjan <vikas.sajjan@linaro.org> >> >> --- >> >> drivers/gpu/drm/exynos/exynos_drm_fimd.c | 4 ++-- >> >> 1 file changed, 2 insertions(+), 2 deletions(-) >> >> >> >> diff --git a/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> >> b/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> >> index 9537761..433ed35 100644 >> >> --- a/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> >> +++ b/drivers/gpu/drm/exynos/exynos_drm_fimd.c >> >> @@ -109,9 +109,9 @@ struct fimd_context { >> >> #ifdef CONFIG_OF >> >> static const struct of_device_id fimd_driver_dt_match[] = { >> >> - { .compatible = "samsung,exynos4-fimd", >> >> + { .compatible = "samsung,exynos4210-fimd", >> >> .data = &exynos4_fimd_driver_data }, >> >> - { .compatible = "samsung,exynos5-fimd", >> >> + { .compatible = "samsung,exynos5250-fimd", >> >> .data = &exynos5_fimd_driver_data }, >> >> {}, >> >> }; >> > >> > >> > Acked-by: Joonyoung Shim <jy0922.shim@samsung.com> >> >> Can you please apply this patch. >> >> > >> > Thanks. >> >> >> >> -- >> Thanks and Regards >> Vikas Sajjan >
diff --git a/drivers/gpu/drm/exynos/exynos_drm_fimd.c b/drivers/gpu/drm/exynos/exynos_drm_fimd.c index 9537761..433ed35 100644 --- a/drivers/gpu/drm/exynos/exynos_drm_fimd.c +++ b/drivers/gpu/drm/exynos/exynos_drm_fimd.c @@ -109,9 +109,9 @@ struct fimd_context { #ifdef CONFIG_OF static const struct of_device_id fimd_driver_dt_match[] = { - { .compatible = "samsung,exynos4-fimd", + { .compatible = "samsung,exynos4210-fimd", .data = &exynos4_fimd_driver_data }, - { .compatible = "samsung,exynos5-fimd", + { .compatible = "samsung,exynos5250-fimd", .data = &exynos5_fimd_driver_data }, {}, };
modified compatible string for exynos4 fimd as "exynos4210-fimd" and exynos5 fimd as "exynos5250-fimd" to stick to the rule that compatible value should be named after first specific SoC model in which this particular IP version was included as discussed at https://patchwork.kernel.org/patch/2144861/ Signed-off-by: Vikas Sajjan <vikas.sajjan@linaro.org> --- drivers/gpu/drm/exynos/exynos_drm_fimd.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)