Message ID | 1379010952-8928-1-git-send-email-mikedunn@newsguy.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Hi Mike, On Thu, Sep 12, 2013 at 11:35:52AM -0700, Mike Dunn wrote: > Currently the driver assumes that the values specified in the brightness-levels > device tree property increase as they are parsed from left to right. But boards > that invert the signal between the PWM output and the backlight will need to > specify decreasing brightness-levels. This patch removes the assumption that > the last element of the array is the max value, and instead searches the array > for the max value and uses that as the normalizing value when determining the > duty cycle. Note there's also support for inverted PWMs in the PWM framework provided your hardware supports this. Sascha
On 09/17/2013 02:36 AM, Sascha Hauer wrote: > Hi Mike, > > On Thu, Sep 12, 2013 at 11:35:52AM -0700, Mike Dunn wrote: >> Currently the driver assumes that the values specified in the brightness-levels >> device tree property increase as they are parsed from left to right. But boards >> that invert the signal between the PWM output and the backlight will need to >> specify decreasing brightness-levels. This patch removes the assumption that >> the last element of the array is the max value, and instead searches the array >> for the max value and uses that as the normalizing value when determining the >> duty cycle. > > Note there's also support for inverted PWMs in the PWM framework > provided your hardware supports this. Yes, and in fact my first solution was to implement simulated polarity inversion in the pwm driver, but that was shot down because polarity inversion is not actually supported by the pwm hardware. My inverter is external in the path between the pwm output and the backlight. Not sure of the reason for its presence. Thanks, Mike -- To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Thu, Sep 12, 2013 at 11:35:52AM -0700, Mike Dunn wrote: > Currently the driver assumes that the values specified in the brightness-levels > device tree property increase as they are parsed from left to right. But boards > that invert the signal between the PWM output and the backlight will need to > specify decreasing brightness-levels. This patch removes the assumption that > the last element of the array is the max value, and instead searches the array > for the max value and uses that as the normalizing value when determining the > duty cycle. "maximum value", "... and uses that as the scale to normalize the duty cycle"? Also please wrap commit messages at 72 characters. > diff --git a/drivers/video/backlight/pwm_bl.c b/drivers/video/backlight/pwm_bl.c > index 1fea627..d66aaa0 100644 > --- a/drivers/video/backlight/pwm_bl.c > +++ b/drivers/video/backlight/pwm_bl.c > @@ -27,6 +27,7 @@ struct pwm_bl_data { > unsigned int period; > unsigned int lth_brightness; > unsigned int *levels; > + unsigned int max_level; Perhaps call this "scale"? Otherwise there some potential to mix it up with max_brightness. > @@ -195,7 +196,15 @@ static int pwm_backlight_probe(struct platform_device *pdev) > } > > if (data->levels) { > - max = data->levels[data->max_brightness]; > + int i, max_value = 0, max_idx = 0; i should be unsigned int to match the type of data->max_brightness. > + for (i = 0; i <= data->max_brightness; i++) { There should be a blank line above this one to increase readability. > + if (data->levels[i] > max_value) { > + max_value = data->levels[i]; > + max_idx = i; > + } > + } > + pb->max_level = max_idx; Some here. Also I suggest to just drop the max_ prefix from the local variables. Perhaps also simplify all of it to something like: for (i = 0; i <= data->max_brightness; i++) if (data->levels[i] > pb->scale) pb->scale = data->levels[i]; And get rid of the index altogether. That way you can use pb->scale directly during the computation of the duty cycle and don't have to index the levels array over and over again. Thierry
On 09/19/2013 04:56 AM, Thierry Reding wrote: > On Thu, Sep 12, 2013 at 11:35:52AM -0700, Mike Dunn wrote: >> Currently the driver assumes that the values specified in the brightness-levels >> device tree property increase as they are parsed from left to right. But boards >> that invert the signal between the PWM output and the backlight will need to >> specify decreasing brightness-levels. This patch removes the assumption that >> the last element of the array is the max value, and instead searches the array >> for the max value and uses that as the normalizing value when determining the >> duty cycle. > > "maximum value", "... and uses that as the scale to normalize the duty > cycle"? It's been a while since my last math class... is "normalizing value" not the correct term? Maybe just "uses that in the duty cycle calculation"? > > Also please wrap commit messages at 72 characters. OK. Sorry, didn't know. > >> diff --git a/drivers/video/backlight/pwm_bl.c b/drivers/video/backlight/pwm_bl.c >> index 1fea627..d66aaa0 100644 >> --- a/drivers/video/backlight/pwm_bl.c >> +++ b/drivers/video/backlight/pwm_bl.c >> @@ -27,6 +27,7 @@ struct pwm_bl_data { >> unsigned int period; >> unsigned int lth_brightness; >> unsigned int *levels; >> + unsigned int max_level; > > Perhaps call this "scale"? Otherwise there some potential to mix it up > with max_brightness. Yes, this name is thorny. The code was somewhat confusing to me until I realized that for the DT case, brightness and max_brightness are indices into the levels[] array, whereas they are actual values for the platform_data case. I'll go with "scale" if you prefer. > >> @@ -195,7 +196,15 @@ static int pwm_backlight_probe(struct platform_device *pdev) >> } >> >> if (data->levels) { >> - max = data->levels[data->max_brightness]; >> + int i, max_value = 0, max_idx = 0; > > i should be unsigned int to match the type of data->max_brightness. Yes, thanks. I'm surprised there's no warning from the compiler. I'm also assigning an unsigned to a signed. > >> + for (i = 0; i <= data->max_brightness; i++) { > > There should be a blank line above this one to increase readability. > >> + if (data->levels[i] > max_value) { >> + max_value = data->levels[i]; >> + max_idx = i; >> + } >> + } >> + pb->max_level = max_idx; > > Some here. > > Also I suggest to just drop the max_ prefix from the local variables. > Perhaps also simplify all of it to something like: > > for (i = 0; i <= data->max_brightness; i++) > if (data->levels[i] > pb->scale) > pb->scale = data->levels[i]; > > And get rid of the index altogether. That way you can use pb->scale > directly during the computation of the duty cycle and don't have to > index the levels array over and over again. Ok, if you prefer. The reason I made max_level an index is for consistency. For the DT case, brightness and max_brightness are indices, and I had already been confused by the value-versus-index issue. Thanks much for the review! I'll ready a v2 patch. Mike -- To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/drivers/video/backlight/pwm_bl.c b/drivers/video/backlight/pwm_bl.c index 1fea627..d66aaa0 100644 --- a/drivers/video/backlight/pwm_bl.c +++ b/drivers/video/backlight/pwm_bl.c @@ -27,6 +27,7 @@ struct pwm_bl_data { unsigned int period; unsigned int lth_brightness; unsigned int *levels; + unsigned int max_level; int (*notify)(struct device *, int brightness); void (*notify_after)(struct device *, @@ -57,7 +58,7 @@ static int pwm_backlight_update_status(struct backlight_device *bl) if (pb->levels) { duty_cycle = pb->levels[brightness]; - max = pb->levels[max]; + max = pb->levels[pb->max_level]; } else { duty_cycle = brightness; } @@ -195,7 +196,15 @@ static int pwm_backlight_probe(struct platform_device *pdev) } if (data->levels) { - max = data->levels[data->max_brightness]; + int i, max_value = 0, max_idx = 0; + for (i = 0; i <= data->max_brightness; i++) { + if (data->levels[i] > max_value) { + max_value = data->levels[i]; + max_idx = i; + } + } + pb->max_level = max_idx; + max = data->levels[max_idx]; pb->levels = data->levels; } else max = data->max_brightness;
Currently the driver assumes that the values specified in the brightness-levels device tree property increase as they are parsed from left to right. But boards that invert the signal between the PWM output and the backlight will need to specify decreasing brightness-levels. This patch removes the assumption that the last element of the array is the max value, and instead searches the array for the max value and uses that as the normalizing value when determining the duty cycle. Signed-off-by: Mike Dunn <mikedunn@newsguy.com> --- drivers/video/backlight/pwm_bl.c | 13 +++++++++++-- 1 file changed, 11 insertions(+), 2 deletions(-)