diff mbox

[RESEND,v2,1/3] usb: chipidea: msm: Add device tree binding information

Message ID 1392889988-24312-1-git-send-email-iivanov@mm-sol.com (mailing list archive)
State New, archived
Headers show

Commit Message

Ivan T. Ivanov Feb. 20, 2014, 9:53 a.m. UTC
From: "Ivan T. Ivanov" <iivanov@mm-sol.com>

Document device tree binding information as required by
the Qualcomm USB controller.

Signed-off-by: Ivan T. Ivanov <iivanov@mm-sol.com>
---
 .../devicetree/bindings/usb/msm-hsusb.txt          |   17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

Peter Chen Feb. 24, 2014, 8:15 a.m. UTC | #1
> +CI13xxx (Chipidea) USB controllers
> +
> +Required properties:
> +- compatible:   should contain "qcom,ci-hdrc"
> +- reg:          offset and length of the register set in the memory map
> +- interrupts:   interrupt-specifier for the controller interrupt.
> +- usb-phy:      phandle for the PHY device
> +- dr_mode:      Sould be "peripheral"
> +
> +	gadget@f9a55000 {
> +		compatible = "qcom,ci-hdrc";
> +		reg = <0xf9a55000 0x400>;
> +		dr_mode = "peripheral";
> +		interrupts = <0 134 0>;
> +		usb-phy = <&usb_otg>;
> +	};
> +

usb_otg is not a good name for the node of usb phy.

Peter

--
To unsubscribe from this list: send the line "unsubscribe linux-arm-msm" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Ivan T. Ivanov Feb. 24, 2014, 10:09 a.m. UTC | #2
On Mon, 2014-02-24 at 08:15 +0000, Peter Chen wrote: 
> > +CI13xxx (Chipidea) USB controllers
> > +
> > +Required properties:
> > +- compatible:   should contain "qcom,ci-hdrc"
> > +- reg:          offset and length of the register set in the memory map
> > +- interrupts:   interrupt-specifier for the controller interrupt.
> > +- usb-phy:      phandle for the PHY device
> > +- dr_mode:      Sould be "peripheral"
> > +
> > +	gadget@f9a55000 {
> > +		compatible = "qcom,ci-hdrc";
> > +		reg = <0xf9a55000 0x400>;
> > +		dr_mode = "peripheral";
> > +		interrupts = <0 134 0>;
> > +		usb-phy = <&usb_otg>;
> > +	};
> > +
> 
> usb_otg is not a good name for the node of usb phy.

Well, this is just an example. Is this better <&phy0>?

Regards,
Ivan


> 
> Peter
> 


--
To unsubscribe from this list: send the line "unsubscribe linux-arm-msm" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Peter Chen Feb. 24, 2014, 10:19 a.m. UTC | #3
> 
> On Mon, 2014-02-24 at 08:15 +0000, Peter Chen wrote:
> > > +CI13xxx (Chipidea) USB controllers
> > > +
> > > +Required properties:
> > > +- compatible:   should contain "qcom,ci-hdrc"
> > > +- reg:          offset and length of the register set in the memory
> map
> > > +- interrupts:   interrupt-specifier for the controller interrupt.
> > > +- usb-phy:      phandle for the PHY device
> > > +- dr_mode:      Sould be "peripheral"
> > > +
> > > +	gadget@f9a55000 {
> > > +		compatible = "qcom,ci-hdrc";
> > > +		reg = <0xf9a55000 0x400>;
> > > +		dr_mode = "peripheral";
> > > +		interrupts = <0 134 0>;
> > > +		usb-phy = <&usb_otg>;
> > > +	};
> > > +
> >
> > usb_otg is not a good name for the node of usb phy.
> 
> Well, this is just an example. Is this better <&phy0>?
> 

<&usbphy0> is better since we have ethernet, sata, pcie phy.

Peter

--
To unsubscribe from this list: send the line "unsubscribe linux-arm-msm" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/Documentation/devicetree/bindings/usb/msm-hsusb.txt b/Documentation/devicetree/bindings/usb/msm-hsusb.txt
index 5ea26c6..d4e7e41 100644
--- a/Documentation/devicetree/bindings/usb/msm-hsusb.txt
+++ b/Documentation/devicetree/bindings/usb/msm-hsusb.txt
@@ -15,3 +15,20 @@  Example EHCI controller device node:
 		usb-phy = <&usb_otg>;
 	};
 
+CI13xxx (Chipidea) USB controllers
+
+Required properties:
+- compatible:   should contain "qcom,ci-hdrc"
+- reg:          offset and length of the register set in the memory map
+- interrupts:   interrupt-specifier for the controller interrupt.
+- usb-phy:      phandle for the PHY device
+- dr_mode:      Sould be "peripheral"
+
+	gadget@f9a55000 {
+		compatible = "qcom,ci-hdrc";
+		reg = <0xf9a55000 0x400>;
+		dr_mode = "peripheral";
+		interrupts = <0 134 0>;
+		usb-phy = <&usb_otg>;
+	};
+