mbox series

[0/8] sd patches for kernel v5.1

Message ID 20190111000858.76261-1-bvanassche@acm.org (mailing list archive)
Headers show
Series sd patches for kernel v5.1 | expand

Message

Bart Van Assche Jan. 11, 2019, 12:08 a.m. UTC
Hi Martin,

This patch series includes the following patches:
- Two patches that increase SCSI probing concurrency.
- Seven patches that clean up/rearrange the code in the sd driver.

Please consider these patches for kernel v5.1.

Thanks,

Bart.

Bart Van Assche (4):
  sd: Rely on the driver core for asynchronous probing
  sd: Inline sd_probe_part2()
  sd: Remove a local variable
  sd: Rename 'SCpnt' into 'cmd'

Martin K. Petersen (4):
  sd: Be consistent about blocks vs. sectors
  sd: Simplify misaligned I/O check
  sd: Create helper functions for read/write commands
  sd: Clean up sd_setup_read_write_cmnd()

 drivers/scsi/scsi.c      |  14 --
 drivers/scsi/scsi_pm.c   |  22 +-
 drivers/scsi/scsi_priv.h |   3 -
 drivers/scsi/sd.c        | 484 +++++++++++++++++----------------------
 4 files changed, 211 insertions(+), 312 deletions(-)