mbox series

[0/1] Use inode_lock/unlock class of provided APIs in filesystems

Message ID 20191205103902.23618-1-riteshh@linux.ibm.com (mailing list archive)
Headers show
Series Use inode_lock/unlock class of provided APIs in filesystems | expand

Message

Ritesh Harjani Dec. 5, 2019, 10:39 a.m. UTC
Matthew Wilcox in [1] suggested that it will be a good idea
to define some missing API instead of directly using i_rwsem in
filesystems drivers for lock/unlock/downgrade purposes.

This patch does that work. No functionality change in this patch.

After this there are only lockdep class of APIs at certain places
in filesystems which are directly using i_rwsem and second is XFS,
but it seems to be anyway defining it's own xfs_ilock/iunlock set
of APIs and 'iolock' naming convention for this lock.

[1]: https://www.spinics.net/lists/linux-ext4/msg68689.html

Ritesh Harjani (1):
  fs: Use inode_lock/unlock class of provided APIs in filesystems

 fs/btrfs/delayed-inode.c |  2 +-
 fs/btrfs/ioctl.c         |  4 ++--
 fs/ceph/io.c             | 24 ++++++++++++------------
 fs/nfs/io.c              | 24 ++++++++++++------------
 fs/orangefs/file.c       |  4 ++--
 fs/overlayfs/readdir.c   |  2 +-
 fs/readdir.c             |  4 ++--
 include/linux/fs.h       | 21 +++++++++++++++++++++
 8 files changed, 53 insertions(+), 32 deletions(-)

Comments

Ritesh Harjani Dec. 17, 2019, 8:12 a.m. UTC | #1
Al, do you think this can be picked up via your tree?
Please let me know if anything needed from my end on this.

-ritesh

On 12/5/19 4:09 PM, Ritesh Harjani wrote:
> Matthew Wilcox in [1] suggested that it will be a good idea
> to define some missing API instead of directly using i_rwsem in
> filesystems drivers for lock/unlock/downgrade purposes.
> 
> This patch does that work. No functionality change in this patch.
> 
> After this there are only lockdep class of APIs at certain places
> in filesystems which are directly using i_rwsem and second is XFS,
> but it seems to be anyway defining it's own xfs_ilock/iunlock set
> of APIs and 'iolock' naming convention for this lock.
> 
> [1]: https://www.spinics.net/lists/linux-ext4/msg68689.html
> 
> Ritesh Harjani (1):
>    fs: Use inode_lock/unlock class of provided APIs in filesystems
> 
>   fs/btrfs/delayed-inode.c |  2 +-
>   fs/btrfs/ioctl.c         |  4 ++--
>   fs/ceph/io.c             | 24 ++++++++++++------------
>   fs/nfs/io.c              | 24 ++++++++++++------------
>   fs/orangefs/file.c       |  4 ++--
>   fs/overlayfs/readdir.c   |  2 +-
>   fs/readdir.c             |  4 ++--
>   include/linux/fs.h       | 21 +++++++++++++++++++++
>   8 files changed, 53 insertions(+), 32 deletions(-)
>