drm: some KMS todo ideas
diff mbox

Message ID 20171017162918.8380-1-daniel.vetter@ffwll.ch
State New
Headers show

Commit Message

Daniel Vetter Oct. 17, 2017, 4:29 p.m. UTC
Inspired by discussions with Keith and Ville.

Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
Cc: Keith Packard <keithp@keithp.com>
Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
---
 Documentation/gpu/todo.rst | 12 ++++++++++++
 1 file changed, 12 insertions(+)

Comments

Sean Paul Oct. 17, 2017, 5:14 p.m. UTC | #1
On Tue, Oct 17, 2017 at 06:29:18PM +0200, Daniel Vetter wrote:
> Inspired by discussions with Keith and Ville.
> 
> Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
> Cc: Keith Packard <keithp@keithp.com>
> Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>

Acked-by: Sean Paul <seanpaul@chromium.org>

> ---
>  Documentation/gpu/todo.rst | 12 ++++++++++++
>  1 file changed, 12 insertions(+)
> 
> diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
> index 92ee2f982572..96f8ec7dbe4e 100644
> --- a/Documentation/gpu/todo.rst
> +++ b/Documentation/gpu/todo.rst
> @@ -304,6 +304,18 @@ There's a bunch of issues with it:
>  
>  Contact: Daniel Vetter
>  
> +KMS cleanups
> +------------
> +
> +Some of these date from the very introduction of KMS in 2008 ...
> +
> +- drm_mode_config.crtc_idr is misnamed, since it contains all KMS object. Should
> +  be renamed to drm_mode_config.object_idr.
> +
> +- drm_display_mode doesn't need to be derived from drm_mode_object. That's
> +  leftovers from older (never merged into upstream) KMS designs where modes
> +  where set using their ID, including support to add/remove modes.
> +
>  Better Testing
>  ==============
>  
> -- 
> 2.14.1
> 
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel

Patch
diff mbox

diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
index 92ee2f982572..96f8ec7dbe4e 100644
--- a/Documentation/gpu/todo.rst
+++ b/Documentation/gpu/todo.rst
@@ -304,6 +304,18 @@  There's a bunch of issues with it:
 
 Contact: Daniel Vetter
 
+KMS cleanups
+------------
+
+Some of these date from the very introduction of KMS in 2008 ...
+
+- drm_mode_config.crtc_idr is misnamed, since it contains all KMS object. Should
+  be renamed to drm_mode_config.object_idr.
+
+- drm_display_mode doesn't need to be derived from drm_mode_object. That's
+  leftovers from older (never merged into upstream) KMS designs where modes
+  where set using their ID, including support to add/remove modes.
+
 Better Testing
 ==============