diff mbox

drm/stm: dsi: Rename driver name

Message ID 1509012290-16906-1-git-send-email-philippe.cornu@st.com (mailing list archive)
State New, archived
Headers show

Commit Message

Philippe CORNU Oct. 26, 2017, 10:04 a.m. UTC
Rename the driver name from "dw_mipi_dsi-stm" to
"stm32-display-dsi" for a better readability
in /sys/bus/platform/drivers entries.

Signed-off-by: Philippe Cornu <philippe.cornu@st.com>
---
 drivers/gpu/drm/stm/dw_mipi_dsi-stm.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Gustavo Padovan Nov. 1, 2017, 11:31 a.m. UTC | #1
Hi Philippe,

2017-10-26 Philippe Cornu <philippe.cornu@st.com>:

> Rename the driver name from "dw_mipi_dsi-stm" to
> "stm32-display-dsi" for a better readability
> in /sys/bus/platform/drivers entries.
> 
> Signed-off-by: Philippe Cornu <philippe.cornu@st.com>
> ---
>  drivers/gpu/drm/stm/dw_mipi_dsi-stm.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c b/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c
> index e5b6310..10b2b77 100644
> --- a/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c
> +++ b/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c
> @@ -342,7 +342,7 @@ static int dw_mipi_dsi_stm_remove(struct platform_device *pdev)
>  	.remove		= dw_mipi_dsi_stm_remove,
>  	.driver		= {
>  		.of_match_table = dw_mipi_dsi_stm_dt_ids,
> -		.name	= "dw_mipi_dsi-stm",
> +		.name	= "stm32-display-dsi",

Reviewed-by: Gustavo Padovan <gustavo.padovan@collabora.com>

Gustavo
Benjamin Gaignard Nov. 7, 2017, 1:57 p.m. UTC | #2
2017-11-01 12:31 GMT+01:00 Gustavo Padovan <gustavo@padovan.org>:
> Hi Philippe,
>
> 2017-10-26 Philippe Cornu <philippe.cornu@st.com>:
>
>> Rename the driver name from "dw_mipi_dsi-stm" to
>> "stm32-display-dsi" for a better readability
>> in /sys/bus/platform/drivers entries.
>>
>> Signed-off-by: Philippe Cornu <philippe.cornu@st.com>
>> ---
>>  drivers/gpu/drm/stm/dw_mipi_dsi-stm.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c b/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c
>> index e5b6310..10b2b77 100644
>> --- a/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c
>> +++ b/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c
>> @@ -342,7 +342,7 @@ static int dw_mipi_dsi_stm_remove(struct platform_device *pdev)
>>       .remove         = dw_mipi_dsi_stm_remove,
>>       .driver         = {
>>               .of_match_table = dw_mipi_dsi_stm_dt_ids,
>> -             .name   = "dw_mipi_dsi-stm",
>> +             .name   = "stm32-display-dsi",
>
> Reviewed-by: Gustavo Padovan <gustavo.padovan@collabora.com>
>
> Gustavo

Applied on drm-misc-next.
Thanks

Benjamin
diff mbox

Patch

diff --git a/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c b/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c
index e5b6310..10b2b77 100644
--- a/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c
+++ b/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c
@@ -342,7 +342,7 @@  static int dw_mipi_dsi_stm_remove(struct platform_device *pdev)
 	.remove		= dw_mipi_dsi_stm_remove,
 	.driver		= {
 		.of_match_table = dw_mipi_dsi_stm_dt_ids,
-		.name	= "dw_mipi_dsi-stm",
+		.name	= "stm32-display-dsi",
 	},
 };